summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-11 04:29:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-11 04:29:25 +0000
commit160450632f2d9034f1152cca3fa75cac5eb0ccac (patch)
tree09f13f09b24dd2da0c30ca785d133e39c379fd4c /sys-boot/grub
parentVersion bump and housekeeping (diff)
downloadgentoo-2-160450632f2d9034f1152cca3fa75cac5eb0ccac.tar.gz
gentoo-2-160450632f2d9034f1152cca3fa75cac5eb0ccac.tar.bz2
gentoo-2-160450632f2d9034f1152cca3fa75cac5eb0ccac.zip
unset BLOCK_SIZE #73499 by Frank Szczerba
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/grub-0.92-r1.ebuild10
-rw-r--r--sys-boot/grub/grub-0.93.20030118.ebuild4
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild4
-rw-r--r--sys-boot/grub/grub-0.94-r2.ebuild4
-rw-r--r--sys-boot/grub/grub-0.95.20040823.ebuild4
-rw-r--r--sys-boot/grub/grub-0.96.ebuild4
6 files changed, 20 insertions, 10 deletions
diff --git a/sys-boot/grub/grub-0.92-r1.ebuild b/sys-boot/grub/grub-0.92-r1.ebuild
index 539f0e99a8f4..6e538e977b67 100644
--- a/sys-boot/grub/grub-0.92-r1.ebuild
+++ b/sys-boot/grub/grub-0.92-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.7 2005/01/20 18:37:45 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.92-r1.ebuild,v 1.8 2005/03/11 04:29:25 vapier Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -11,13 +11,12 @@ SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz
mirror://gentoo/${P}-gentoo-${PATCHVER}.tar.bz2
http://dev.gentoo.org/~seemant/extras/${P}-gentoo-${PATCHVER}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 -amd64 -ppc -sparc -alpha -mips"
+SLOT="0"
+KEYWORDS="-* x86"
IUSE=""
DEPEND=">=sys-libs/ncurses-5.2-r5"
-
PROVIDE="virtual/bootloader"
src_unpack() {
@@ -32,9 +31,10 @@ src_unpack() {
}
src_compile() {
-
filter-flags "-fstack-protector"
+ unset BLOCK_SIZE #73499
+
#i686-specific code in the boot loader is a bad idea; disabling to ensure
#at least some compatibility if the hard drive is moved to an older or
#incompatible system.
diff --git a/sys-boot/grub/grub-0.93.20030118.ebuild b/sys-boot/grub/grub-0.93.20030118.ebuild
index 7d431e25becd..f1756081b62f 100644
--- a/sys-boot/grub/grub-0.93.20030118.ebuild
+++ b/sys-boot/grub/grub-0.93.20030118.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.93.20030118.ebuild,v 1.10 2005/03/11 04:17:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.93.20030118.ebuild,v 1.11 2005/03/11 04:29:25 vapier Exp $
inherit mount-boot eutils flag-o-matic
@@ -46,6 +46,8 @@ src_compile() {
filter-flags -fstack-protector
filter-flags -fPIC
+ unset BLOCK_SIZE #73499
+
### i686-specific code in the boot loader is a bad idea; disabling to ensure
### at least some compatibility if the hard drive is moved to an older or
### incompatible system.
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index 69d945679ec6..7bb34b1c0d26 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.16 2005/03/11 04:17:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.17 2005/03/11 04:29:25 vapier Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -41,6 +41,8 @@ src_unpack() {
}
src_compile() {
+ unset BLOCK_SIZE #73499
+
### i686-specific code in the boot loader is a bad idea; disabling to ensure
### at least some compatibility if the hard drive is moved to an older or
### incompatible system.
diff --git a/sys-boot/grub/grub-0.94-r2.ebuild b/sys-boot/grub/grub-0.94-r2.ebuild
index f0540df9a16d..8e86eb469d11 100644
--- a/sys-boot/grub/grub-0.94-r2.ebuild
+++ b/sys-boot/grub/grub-0.94-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r2.ebuild,v 1.5 2005/03/11 04:17:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r2.ebuild,v 1.6 2005/03/11 04:29:25 vapier Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -44,6 +44,8 @@ src_unpack() {
}
src_compile() {
+ unset BLOCK_SIZE #73499
+
### i686-specific code in the boot loader is a bad idea; disabling to ensure
### at least some compatibility if the hard drive is moved to an older or
### incompatible system.
diff --git a/sys-boot/grub/grub-0.95.20040823.ebuild b/sys-boot/grub/grub-0.95.20040823.ebuild
index 0c128c663a00..0b5d1cbe9de7 100644
--- a/sys-boot/grub/grub-0.95.20040823.ebuild
+++ b/sys-boot/grub/grub-0.95.20040823.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.13 2005/03/11 04:17:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.14 2005/03/11 04:29:25 vapier Exp $
inherit mount-boot eutils flag-o-matic gcc gnuconfig toolchain-funcs
@@ -49,6 +49,8 @@ src_unpack() {
}
src_compile() {
+ unset BLOCK_SIZE #73499
+
### i686-specific code in the boot loader is a bad idea; disabling to ensure
### at least some compatibility if the hard drive is moved to an older or
### incompatible system.
diff --git a/sys-boot/grub/grub-0.96.ebuild b/sys-boot/grub/grub-0.96.ebuild
index 29ce08cc8742..1069c93892c2 100644
--- a/sys-boot/grub/grub-0.96.ebuild
+++ b/sys-boot/grub/grub-0.96.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96.ebuild,v 1.2 2005/03/05 21:05:43 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96.ebuild,v 1.3 2005/03/11 04:29:25 vapier Exp $
inherit mount-boot eutils flag-o-matic gcc gnuconfig toolchain-funcs
@@ -48,6 +48,8 @@ src_unpack() {
}
src_compile() {
+ unset BLOCK_SIZE #73499
+
### i686-specific code in the boot loader is a bad idea; disabling to ensure
### at least some compatibility if the hard drive is moved to an older or
### incompatible system.