summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-25 04:27:08 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-25 04:27:08 +0000
commitc58e0cce512bbac95ebc41d194ab1cfd88bba14a (patch)
tree45ed39a870cca17432285e0e3d2171ca0f0908d1 /sys-boot/gnu-efi
parentPush out fixes from upstream for #439432 and 439988. (diff)
downloadgentoo-2-c58e0cce512bbac95ebc41d194ab1cfd88bba14a.tar.gz
gentoo-2-c58e0cce512bbac95ebc41d194ab1cfd88bba14a.tar.bz2
gentoo-2-c58e0cce512bbac95ebc41d194ab1cfd88bba14a.zip
Version bump and update to EAPI=4 #412645 by Rod Smith. Disable QA checks on compiled objects as they do not make sense for bootloaders #329823 by Dane Smith. Disable ssp since that requires a C library (like glibc) to work, and does not make sense for bootloaders #444246 by Maxim Kammerer.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-boot/gnu-efi')
-rw-r--r--sys-boot/gnu-efi/ChangeLog13
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0s.ebuild54
2 files changed, 64 insertions, 3 deletions
diff --git a/sys-boot/gnu-efi/ChangeLog b/sys-boot/gnu-efi/ChangeLog
index 5c8210367065..81c7bbfe45c6 100644
--- a/sys-boot/gnu-efi/ChangeLog
+++ b/sys-boot/gnu-efi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-boot/gnu-efi
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.18 2010/08/28 22:43:29 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/ChangeLog,v 1.19 2012/11/25 04:27:08 vapier Exp $
+
+*gnu-efi-3.0s (25 Nov 2012)
+
+ 25 Nov 2012; Mike Frysinger <vapier@gentoo.org> +gnu-efi-3.0s.ebuild:
+ Version bump and update to EAPI=4 #412645 by Rod Smith. Disable QA checks on
+ compiled objects as they do not make sense for bootloaders #329823 by Dane
+ Smith. Disable ssp since that requires a C library (like glibc) to work, and
+ does not make sense for bootloaders #444246 by Maxim Kammerer.
28 Aug 2010; Mike Frysinger <vapier@gentoo.org> gnu-efi-3.0i.ebuild:
Clean up and document the ebuild a bit.
@@ -66,4 +74,3 @@
files/gnu-efi-3.0a-lds.patch:
New ebuild for gnu-efi with patches from Debian. Thanks to Matt Anderson in
bug 38875
-
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0s.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0s.ebuild
new file mode 100644
index 000000000000..d206aa81535e
--- /dev/null
+++ b/sys-boot/gnu-efi/gnu-efi-3.0s.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0s.ebuild,v 1.1 2012/11/25 04:27:08 vapier Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_P="${PN}_${PV}"
+DEB_VER="3.0i-4"
+DESCRIPTION="Library for build EFI Applications"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="mirror://sourceforge/gnu-efi/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/g/gnu-efi/${PN}_${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+RDEPEND=""
+
+S=${WORKDIR}/${P%?}
+
+# These objects get run early boot (i.e. not inside of Linux),
+# so doing these QA checks on them doesn't make sense.
+QA_EXECSTACK="usr/*/lib*efi.a:* usr/*/crt*.o"
+
+src_prepare() {
+ EPATCH_OPTS="-p1" epatch "${WORKDIR}"/*.diff
+ sed -i -e '/^CFLAGS/s:$: -fno-stack-protector:' Make.defaults || die #444246
+}
+
+_emake() {
+ emake prefix=${CHOST}- ARCH=${iarch} LIBDIR=$(get_libdir) "$@"
+}
+
+src_compile() {
+ case ${ARCH} in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+ # The lib subdir uses unsafe archive targets, and
+ # the apps subdir needs gnuefi subdir
+ _emake -j1
+}
+
+src_install() {
+ _emake install INSTALLROOT="${D}"/usr
+ dodoc README* ChangeLog
+}