summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-03-30 19:50:57 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-03-30 19:50:57 +0000
commitc11139298be3c178283686fdec16867bc10c6ff5 (patch)
tree3f32915fd282aff9fc672e372fa49871b3548e89 /sys-boot/elilo
parentAdd ~alpha keyword, bug 86602. (diff)
downloadgentoo-2-c11139298be3c178283686fdec16867bc10c6ff5.tar.gz
gentoo-2-c11139298be3c178283686fdec16867bc10c6ff5.tar.bz2
gentoo-2-c11139298be3c178283686fdec16867bc10c6ff5.zip
Backport --efiboot fix for 2.6 kernels from Debian.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-boot/elilo')
-rw-r--r--sys-boot/elilo/ChangeLog7
-rw-r--r--sys-boot/elilo/elilo-3.4-r1.ebuild64
-rw-r--r--sys-boot/elilo/files/digest-elilo-3.4-r11
-rw-r--r--sys-boot/elilo/files/elilo-3.44
4 files changed, 73 insertions, 3 deletions
diff --git a/sys-boot/elilo/ChangeLog b/sys-boot/elilo/ChangeLog
index 5c8755d7ef43..a10bfec38ba9 100644
--- a/sys-boot/elilo/ChangeLog
+++ b/sys-boot/elilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/elilo
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.7 2005/01/22 13:29:32 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.8 2005/03/30 19:50:57 plasmaroo Exp $
+
+*elilo-3.4-r1 (30 Mar 2005)
+
+ 30 Mar 2005; <plasmaroo@gentoo.org> +elilo-3.4-r1.ebuild, files/elilo-3.4:
+ Backport --efiboot fix for 2.6 kernels from Debian.
22 Jan 2005; <plasmaroo@gentoo.org> elilo-3.4.ebuild:
Fix total build breakage; inherit toolchain-funcs please...
diff --git a/sys-boot/elilo/elilo-3.4-r1.ebuild b/sys-boot/elilo/elilo-3.4-r1.ebuild
new file mode 100644
index 000000000000..1f7132c082cf
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.4-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4-r1.ebuild,v 1.1 2005/03/30 19:50:57 plasmaroo Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/elilo-3.4-makefile.patch
+ epatch ${FILESDIR}/elilo-3.3a-devscheme.patch
+}
+
+src_compile() {
+ local iarch
+ case $ARCH in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;; # for cross-compiling?
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+
+ # unversion the man-pages and Debian's elilo script
+ cp ${FILESDIR}/elilo.8-${PV} elilo.8
+ cp ${FILESDIR}/eliloalt.8-${PV} eliloalt.8
+ cp ${FILESDIR}/elilo-${PV} elilo
+}
+
+src_install() {
+ dodir /usr/lib/elilo /usr/sbin /etc
+
+ # install the efi executable in a known location
+ install -m755 elilo.efi ${D}/usr/lib/elilo || die
+
+ # install eliloalt
+ install -m755 tools/eliloalt ${D}/usr/sbin || die
+ doman eliloalt.8 || die
+
+ # text docs
+ dodoc docs/*
+
+ # install the debian elilo script
+ install -m755 elilo ${D}/usr/sbin || die
+ install -m644 ${FILESDIR}/elilo.conf.sample ${D}/etc || die
+ doman elilo.8 || die
+}
diff --git a/sys-boot/elilo/files/digest-elilo-3.4-r1 b/sys-boot/elilo/files/digest-elilo-3.4-r1
new file mode 100644
index 000000000000..6c9603e2135d
--- /dev/null
+++ b/sys-boot/elilo/files/digest-elilo-3.4-r1
@@ -0,0 +1 @@
+MD5 e7357929dfca29436d35ad6386fc051c elilo-3.4.tar.gz 316518
diff --git a/sys-boot/elilo/files/elilo-3.4 b/sys-boot/elilo/files/elilo-3.4
index 08bbb03527f4..f34a2fe75a54 100644
--- a/sys-boot/elilo/files/elilo-3.4
+++ b/sys-boot/elilo/files/elilo-3.4
@@ -269,8 +269,8 @@ checkconf()
local CONFERR=1
fi
- if [ ! -d /proc/efi/vars -a "$efiboot" = 1 ] ; then
- echo 1>&2 "$PRG: /proc/efi/vars not available, boot menu not updated"
+ if [ ! -d /proc/efi/vars ] && [ ! -d /sys/firmware/efi/vars ] && [ "$efiboot" = 1 ] && ! modprobe -q efivars; then
+ echo 1>&2 "$PRG: no efi/vars under /proc or /sys/firmware, boot menu not updated"
efiboot=0
fi