summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-13 16:47:50 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-13 16:47:50 +0000
commitbf554a9cd4af540c698152942df2bab79d4e6666 (patch)
tree12499b4644f367af56e3fd59d4d5ac97f5477ad9 /sys-boot/efibootmgr
parentVersion bump, longterm stable. (diff)
downloadgentoo-2-bf554a9cd4af540c698152942df2bab79d4e6666.tar.gz
gentoo-2-bf554a9cd4af540c698152942df2bab79d4e6666.tar.bz2
gentoo-2-bf554a9cd4af540c698152942df2bab79d4e6666.zip
Use common tc-getPKG_CONFIG helper.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/efibootmgr')
-rw-r--r--sys-boot/efibootmgr/ChangeLog7
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild17
2 files changed, 8 insertions, 16 deletions
diff --git a/sys-boot/efibootmgr/ChangeLog b/sys-boot/efibootmgr/ChangeLog
index 4616a7c82362..2c69cf65346d 100644
--- a/sys-boot/efibootmgr/ChangeLog
+++ b/sys-boot/efibootmgr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-boot/efibootmgr
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.20 2010/03/03 19:44:51 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/ChangeLog,v 1.21 2012/01/13 16:47:50 vapier Exp $
+
+ 13 Jan 2012; Mike Frysinger <vapier@gentoo.org> efibootmgr-0.5.4.ebuild:
+ Use common tc-getPKG_CONFIG helper.
03 Mar 2010; Raúl Porcel <armin76@gentoo.org> efibootmgr-0.5.4.ebuild:
Add dev-util/pkgconfig to DEPEND, bug #306125
diff --git a/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild b/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild
index 0c8453819cf0..189875e3fc84 100644
--- a/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild
+++ b/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild,v 1.4 2010/03/03 19:44:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild,v 1.5 2012/01/13 16:47:50 vapier Exp $
inherit flag-o-matic toolchain-funcs
@@ -17,22 +17,11 @@ RDEPEND="sys-apps/pciutils"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_config() {
- # should prob get moved into tc-funcs or something ...
- if [[ ${PKG_CONFIG+set} == "set" ]] ; then
- echo ${PKG_CONFIG}
- elif type -p ${CHOST}-pkg-config >/dev/null ; then
- echo ${CHOST}-pkg-config
- else
- echo pkg-config
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
sed -i \
- -e "/^LIBS/s:=.*:=$($(pkg_config) libpci --libs):" \
+ -e "/^LIBS/s:=.*:=$($(tc-getPKG_CONFIG) libpci --libs):" \
src/efibootmgr/module.mk || die
}