summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-08-14 21:26:02 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-08-14 21:26:02 +0000
commit6a4fb097ab73e1edea677e9561e1a8bcd0b07e6e (patch)
tree6890ec41c5f004f049f3af716d0fef70fe4b12bf /sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild
parentAdded a --missing false since not all versions of pciutils support the zlib U... (diff)
downloadgentoo-2-6a4fb097ab73e1edea677e9561e1a8bcd0b07e6e.tar.gz
gentoo-2-6a4fb097ab73e1edea677e9561e1a8bcd0b07e6e.tar.bz2
gentoo-2-6a4fb097ab73e1edea677e9561e1a8bcd0b07e6e.zip
Modified to use the same built_with_use logic as other ebuilds in the tree and added --missing as reported on bug #188221.
(Portage version: 2.1.3.3)
Diffstat (limited to 'sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild b/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild
index 32e86eeac8b9..360e163465aa 100644
--- a/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild
+++ b/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild,v 1.3 2007/07/11 14:18:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.3.ebuild,v 1.4 2007/08/14 21:26:02 wolf31o2 Exp $
inherit eutils flag-o-matic
@@ -11,14 +11,19 @@ SRC_URI="http://linux.dell.com/efibootmgr/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ia64"
-IUSE=""
+IUSE="zlib"
DEPEND="virtual/libc
+ zlib? ( sys-libs/zlib )
sys-apps/pciutils"
src_compile() {
- if built_with_use sys-apps/pciutils zlib ; then
+ if use zlib
+ then
append-ldflags -lz
+ elif built_with_use --missing false sys-apps/pciutils zlib
+ then
+ die "You need to build with USE=zlib to match sys-apps/pcituils"
fi
emake || die "emake failed"