summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-15 07:07:59 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-15 07:07:59 +0000
commit4138aa830ceefef6d5daaffbf2c513ff28576fc9 (patch)
treed02d1347d760cdb7e1a78fb6750c1814c1c86bcc /sys-boot/aboot
parentwhitespace (diff)
downloadgentoo-2-4138aa830ceefef6d5daaffbf2c513ff28576fc9.tar.gz
gentoo-2-4138aa830ceefef6d5daaffbf2c513ff28576fc9.tar.bz2
gentoo-2-4138aa830ceefef6d5daaffbf2c513ff28576fc9.zip
Pull in our own copy of unsanitized kernel headers to build against #166769.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-boot/aboot')
-rw-r--r--sys-boot/aboot/ChangeLog8
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408-r1.ebuild72
-rw-r--r--sys-boot/aboot/files/digest-aboot-1.0_pre20040408-r16
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-boot/aboot/ChangeLog b/sys-boot/aboot/ChangeLog
index c4f2e9dddbe7..2e74098d89e1 100644
--- a/sys-boot/aboot/ChangeLog
+++ b/sys-boot/aboot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/aboot
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.9 2007/02/09 05:49:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.10 2007/07/15 07:07:59 vapier Exp $
+
+*aboot-1.0_pre20040408-r1 (15 Jul 2007)
+
+ 15 Jul 2007; Mike Frysinger <vapier@gentoo.org>
+ +aboot-1.0_pre20040408-r1.ebuild:
+ Pull in our own copy of unsanitized kernel headers to build against #166769.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408-r1.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408-r1.ebuild
new file mode 100644
index 000000000000..af2bd556d08f
--- /dev/null
+++ b/sys-boot/aboot/aboot-1.0_pre20040408-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/aboot-1.0_pre20040408-r1.ebuild,v 1.1 2007/07/15 07:07:59 vapier Exp $
+
+inherit eutils
+
+KERN_VER="2.6.22"
+
+DESCRIPTION="Alpha Linux boot loader for SRM"
+HOMEPAGE="http://aboot.sourceforge.net/"
+SRC_URI="http://aboot.sourceforge.net/tarballs/${P}.tar.bz2
+ mirror://gentoo/gentoo-headers-base-${KERN_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~alpha"
+IUSE=""
+
+DEPEND=""
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+ # setup local copies of kernel headers since we rely so
+ # heavily on linux internals.
+ mv gentoo-headers-base-${KERN_VER}/include/{linux,asm-generic,asm-alpha} "${S}"/include/ || die
+ cd "${S}"/include
+ ln -s asm-alpha asm || die
+ touch linux/config.h || die
+ cd "${S}"
+ sed -i '1i#define bool int' cons.c
+ sed -i "s:/usr/man:/usr/share/man:" Makefile || die
+ epatch "${FILESDIR}/aboot-gcc-3.4.patch"
+}
+
+src_install() {
+ dodir /boot /sbin /usr/share/man/man5
+ make \
+ root="${D}" \
+ bindir="${D}"/sbin \
+ bootdir="${D}"/boot \
+ mandir="${D}"/usr/share/man \
+ install
+
+ dodoc ChangeLog INSTALL README TODO aboot.conf
+
+ insinto /etc
+ newins "${FILESDIR}"/aboot.conf aboot.conf.example
+}
+
+pkg_postinst() {
+ einfo "To make aboot install a new bootloader on your harddisk follow"
+ einfo "these steps:"
+ einfo ""
+ einfo " - edit the file /etc/aboot.conf"
+ einfo " - cd /boot"
+ einfo " - swriteboot -c2 /dev/sda bootlx"
+ einfo " This will install a new bootsector on /dev/sda and aboot will"
+ einfo " use the second partition on this device to lookup kernel and "
+ einfo " initrd (as described in the aboot.conf file)"
+ einfo ""
+ einfo "IMPORTANT :"
+ einfo ""
+ einfo "The partition table of your boot device has to contain "
+ einfo "a BSD-DISKLABEL and the first 12 megabytes of your boot device"
+ einfo "must not be part of a partition as aboot will write its bootloader"
+ einfo "in there and not as with most x86 bootloaders into the "
+ einfo "master boot sector. If your partition table does not reflect this"
+ einfo "you are going to destroy your installation !"
+ einfo "Also note that aboot currently only supports ext2/3 partitions"
+ einfo "to boot from."
+}
diff --git a/sys-boot/aboot/files/digest-aboot-1.0_pre20040408-r1 b/sys-boot/aboot/files/digest-aboot-1.0_pre20040408-r1
new file mode 100644
index 000000000000..3b19fa8cb398
--- /dev/null
+++ b/sys-boot/aboot/files/digest-aboot-1.0_pre20040408-r1
@@ -0,0 +1,6 @@
+MD5 ac1214102d8304f326655e3e36d89847 aboot-1.0_pre20040408.tar.bz2 115062
+RMD160 7ba6619e6cee1d570b5df806a1dbd23b2918303b aboot-1.0_pre20040408.tar.bz2 115062
+SHA256 a8ae8f2bf549c1cc79ea66a0a11c8db5c0257ce0d94b97418eb1c658723b12d2 aboot-1.0_pre20040408.tar.bz2 115062
+MD5 9ff186f91c21c4cf02d73b9fd22ef28d gentoo-headers-base-2.6.22.tar.bz2 4700338
+RMD160 0742adecc4cf093a2df13c61c3d11e7566f08a9d gentoo-headers-base-2.6.22.tar.bz2 4700338
+SHA256 da57d0d8d12a59b05f0d3851e6d2f67c413baece046f4ec03831aa70df88710a gentoo-headers-base-2.6.22.tar.bz2 4700338