summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-11-05 23:03:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-11-05 23:03:00 +0000
commitf27d287e85fc9efca831674788697f0468bcb7a5 (patch)
tree872dd89969ff8f9580cea400224a37f12e53dd82 /sys-block
parentStabilize for amd64/x86. (diff)
downloadgentoo-2-f27d287e85fc9efca831674788697f0468bcb7a5.tar.gz
gentoo-2-f27d287e85fc9efca831674788697f0468bcb7a5.tar.bz2
gentoo-2-f27d287e85fc9efca831674788697f0468bcb7a5.zip
Fix linux_chkconfig_module usage to be non-fatal, this package does not build kernel modules. Verified good build with no kernel sources or kernel config available.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/ChangeLog9
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild4
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild4
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.ebuild4
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.872.ebuild4
5 files changed, 16 insertions, 9 deletions
diff --git a/sys-block/open-iscsi/ChangeLog b/sys-block/open-iscsi/ChangeLog
index 5ffded14e357..e92e7797a1d4 100644
--- a/sys-block/open-iscsi/ChangeLog
+++ b/sys-block/open-iscsi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/open-iscsi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.36 2011/11/02 06:18:40 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.37 2011/11/05 23:03:00 robbat2 Exp $
+
+ 05 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> open-iscsi-2.0.871.ebuild,
+ open-iscsi-2.0.871-r1.ebuild, open-iscsi-2.0.871.3.ebuild,
+ open-iscsi-2.0.872.ebuild:
+ Fix linux_chkconfig_module usage to be non-fatal, this package does not build
+ kernel modules. Verified good build with no kernel sources or kernel config
+ available.
02 Nov 2011; Mike Doty <kingtaco@gentoo.org> metadata.xml:
Setting maintainer to base-system
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
index 5a09c82ca48f..9d06bdc2a9f1 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.7 2011/06/13 01:47:26 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.8 2011/11/05 23:03:00 robbat2 Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -34,7 +34,7 @@ pkg_setup() {
CONFIG_CHECK_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
- linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
done
fi
}
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
index 40aa8eefeaf5..9e648f242a6f 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.6 2011/06/19 13:56:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.7 2011/11/05 23:03:00 robbat2 Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -31,7 +31,7 @@ pkg_setup() {
CONFIG_CHECK_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
- linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
done
fi
}
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
index 2c2e17941b52..8acf6859c826 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild,v 1.3 2011/06/13 01:47:26 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.ebuild,v 1.4 2011/11/05 23:03:00 robbat2 Exp $
inherit versionator linux-mod eutils flag-o-matic
@@ -36,7 +36,7 @@ pkg_setup() {
# If there's a new release, check whether this is still valid!
for module in ${CONFIG_CHECK_MODULES}; do
- linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
done
}
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
index 8b548e46b393..839054a624bd 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild,v 1.2 2011/06/13 01:47:26 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild,v 1.3 2011/11/05 23:03:00 robbat2 Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -34,7 +34,7 @@ pkg_setup() {
CONFIG_CHECK_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
- linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
done
fi
}