summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2010-03-07 18:45:40 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2010-03-07 18:45:40 +0000
commitd1fa38a8118bde3dcd6cf988115ab5d8ddb768e5 (patch)
tree4cc7a0f3c15c00e985b92298ef8e067653f184f3 /sys-block
parentAdd <sys-fs/e2fsprogs-1.41.9 to the e2fsprogs mask (diff)
downloadgentoo-2-d1fa38a8118bde3dcd6cf988115ab5d8ddb768e5.tar.gz
gentoo-2-d1fa38a8118bde3dcd6cf988115ab5d8ddb768e5.tar.bz2
gentoo-2-d1fa38a8118bde3dcd6cf988115ab5d8ddb768e5.zip
Version bump, proxy committing for Craig #301602
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/ChangeLog10
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild86
2 files changed, 94 insertions, 2 deletions
diff --git a/sys-block/open-iscsi/ChangeLog b/sys-block/open-iscsi/ChangeLog
index 60b4f856f7ae..6b69f8ef37db 100644
--- a/sys-block/open-iscsi/ChangeLog
+++ b/sys-block/open-iscsi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/open-iscsi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.27 2009/12/08 19:08:11 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.28 2010/03/07 18:45:40 dertobi123 Exp $
+
+*open-iscsi-2.0.871.3 (07 Mar 2010)
+
+ 07 Mar 2010; Tobias Scherbaum <dertobi123@gentoo.org>
+ +open-iscsi-2.0.871.3.ebuild:
+ Version bump, proxy committing for Craig #301602
08 Dec 2009; nixnut <nixnut@gentoo.org> open-iscsi-2.0.871-r1.ebuild:
ppc stable #293712
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
new file mode 100644
index 000000000000..663bbc21ace1
--- /dev/null
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.1 2010/03/07 18:45:40 dertobi123 Exp $
+
+EAPI=2
+inherit versionator linux-info eutils flag-o-matic
+
+DESCRIPTION="Open-iSCSI is a high performance, transport independent, multi-platform implementation of RFC3720"
+HOMEPAGE="http://www.open-iscsi.org/"
+SRC_URI="mirror://kernel/linux/kernel/people/mnc/open-iscsi/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="debug"
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if [ $KV_PATCH -lt 15 ]; then
+ die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
+ fi
+
+ # Needs to be done, as iscsid currently only starts, when having the iSCSI
+ # support loaded as module. Kernel builtion options don't work. See this for
+ # more information:
+ # http://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966
+ # If there's a new release, check whether this is still valid!
+ if linux_config_exists; then
+ for module in ${CONFIG_CHECK_MODULES}; do
+ linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
+ done
+ fi
+}
+
+src_prepare() {
+ export EPATCH_OPTS="-d${S}"
+ epatch "${FILESDIR}"/CVE-2009-1297.patch
+ epatch "${FILESDIR}"/${PN}-2.0.871-makefile-cleanup.patch
+}
+
+src_compile() {
+ use debug && append-flags -DDEBUG_TCP -DDEBUG_SCSI
+
+ einfo "Building userspace"
+ cd "${S}" && \
+ CFLAGS="" emake OPTFLAGS="${CFLAGS}" user \
+ || die "emake failed"
+}
+
+src_install() {
+ einfo "Installing userspace"
+ dosbin usr/iscsid usr/iscsiadm usr/iscsistart
+
+ einfo "Installing utilities"
+ dosbin utils/iscsi-iname utils/iscsi_discovery
+
+ einfo "Installing docs"
+ doman doc/*[1-8]
+ dodoc README THANKS
+ docinto test
+ dodoc test/*
+
+ einfo "Installing configuration"
+ insinto /etc/iscsi
+ doins etc/iscsid.conf
+ newins "${FILESDIR}"/initiatorname.iscsi initiatorname.iscsi.example
+ insinto /etc/iscsi/ifaces
+ doins etc/iface.example
+
+ newconfd "${FILESDIR}"/iscsid-conf.d iscsid
+ newinitd "${FILESDIR}"/iscsid-2.0.871-r1.init.d iscsid
+
+ keepdir /var/db/iscsi
+ fperms 700 /var/db/iscsi
+ fperms 600 /etc/iscsi/iscsid.conf
+}
+
+pkg_postinst() {
+ in='/etc/iscsi/initiatorname.iscsi'
+ if [ ! -f "${ROOT}${in}" -a -f "${ROOT}${in}.example" ]; then
+ cp -f "${ROOT}${in}.example" "${ROOT}${in}"
+ fi
+}