summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-03-07 19:49:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-03-07 19:49:54 +0000
commit6dc59263865ad8734ca3c90fd1124e0297593905 (patch)
tree93cd3ab297c50cd05608ba030e3ec17f3b193c8f /sys-block
parentFix autotools usage. (diff)
downloadgentoo-2-6dc59263865ad8734ca3c90fd1124e0297593905.tar.gz
gentoo-2-6dc59263865ad8734ca3c90fd1124e0297593905.tar.bz2
gentoo-2-6dc59263865ad8734ca3c90fd1124e0297593905.zip
Version bump, bug #159994. Fix init.d stop problem, bug #137016.
(Portage version: 2.1.2.1-r1)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/vblade/ChangeLog8
-rw-r--r--sys-block/vblade/files/digest-vblade-143
-rw-r--r--sys-block/vblade/files/init.d-vblade.vblade0-14114
-rw-r--r--sys-block/vblade/vblade-14.ebuild43
4 files changed, 167 insertions, 1 deletions
diff --git a/sys-block/vblade/ChangeLog b/sys-block/vblade/ChangeLog
index 350e8e5a0b29..5ad4251fa303 100644
--- a/sys-block/vblade/ChangeLog
+++ b/sys-block/vblade/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/vblade
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/ChangeLog,v 1.12 2007/02/22 01:01:15 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/ChangeLog,v 1.13 2007/03/07 19:49:54 robbat2 Exp $
+
+*vblade-14 (07 Mar 2007)
+
+ 07 Mar 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/init.d-vblade.vblade0-14, +vblade-14.ebuild:
+ Version bump, bug #159994. Fix init.d stop problem, bug #137016.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-block/vblade/files/digest-vblade-14 b/sys-block/vblade/files/digest-vblade-14
new file mode 100644
index 000000000000..1d306fb9616b
--- /dev/null
+++ b/sys-block/vblade/files/digest-vblade-14
@@ -0,0 +1,3 @@
+MD5 c5c7ed7b859d6d74575dd9facd82e2a1 vblade-14.tgz 20317
+RMD160 ad0fe6f0c4ab40fa31daa68c7b14143ad87f443c vblade-14.tgz 20317
+SHA256 29374180e288293aa0206cbdfd8444fcc69c189946ec380959a85a35a3129253 vblade-14.tgz 20317
diff --git a/sys-block/vblade/files/init.d-vblade.vblade0-14 b/sys-block/vblade/files/init.d-vblade.vblade0-14
new file mode 100644
index 000000000000..dc22c9f17463
--- /dev/null
+++ b/sys-block/vblade/files/init.d-vblade.vblade0-14
@@ -0,0 +1,114 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/files/init.d-vblade.vblade0-14,v 1.1 2007/03/07 19:49:54 robbat2 Exp $
+
+opts="${opts} checkconfig"
+
+depend() {
+ need net
+}
+
+conf="$(add_suffix /etc/conf.d/vblade)"
+[[ -e "${conf}" ]] && source "${conf}"
+vblade_name="${myservice#*.}"
+vblade_conf_variable="config_${vblade_name}"
+vblade_conf="${!vblade_conf_variable}"
+pidfile="/var/run/vblade-${vblade_name}.pid"
+srvname="vblade.${vblade_name}"
+
+getconfig() {
+ tmp="${vblade_conf}"
+ shelf="${tmp/ *}"
+ tmp="${tmp#* }"
+ slot="${tmp/ *}"
+ tmp="${tmp#* }"
+ netif="${tmp/ *}"
+ tmp="${tmp#* }"
+ src="${tmp}"
+ export shelf slot netif src
+}
+
+
+checkconfig() {
+ if [ -z "${vblade_conf}" ]; then
+ eerror "vblade configuration not specified for ${vblade_name}"
+ return 1
+ fi
+ getconfig
+
+ is_valid_numeric "${shelf}" 0
+ if [[ $? -ne 0 ]]; then
+ eerror "Shelf '${shelf}' is non-numeric or less than zero."
+ return 1
+ fi
+ is_valid_numeric "${slot}" 0 15
+ if [[ $? -ne 0 ]]; then
+ eerror "Slot '${slot}' is outside the valid range [0..15]."
+ return 1
+ fi
+
+ sysfs_base="/sys/class/net/"
+ procfs_base="/proc/sys/net/ipv4/conf/"
+ if test ! \( -e "${sysfs_base}${netif}" -o -e "${procfs_base}${netif}" \); then
+ eerror "Network interface '${netif}' does not exist"
+ return 1
+ fi
+
+ if test ! \( -f "${src}" -o -b "${src}" \) ; then
+ eerror "Source '${src}' must be a file or block device"
+ return 1
+ fi
+
+ if test ! \( -e "${src}" -a -r "${src}" \) ; then
+ eerror "Source '${src}' is not readable."
+ return 1
+ fi
+
+ return 0
+}
+
+is_valid_numeric() {
+ num="${1}"
+ min="${2}"
+ max="${3}"
+ # non-numeric
+ test "$num" -ge "0" 2>/dev/null
+ rc=$?
+ test "$rc" -eq 2 && return 2
+ # check for min
+ test -z "$min" && return 0
+ test "$num" -lt "$min" && return 1
+ # check for max
+ test -z "$max" && return 0
+ test "$num" -gt "$max" && return 1
+ # done
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+ getconfig
+ ebegin "Starting ${srvname}: e${shelf}.${slot} on ${netif} using '${src}'"
+ export LOGTAG="${srvname}"
+ start-stop-daemon --start --quiet \
+ --pidfile ${pidfile} --background \
+ --make-pidfile --exec /usr/sbin/vbladed -- \
+ ${shelf} ${slot} ${netif} "${src}"
+ eend $?
+
+ #${shelf} ${slot} ${netif} "${src}" 2>&1 | logger -t ${srvname} &
+}
+
+stop() {
+ ebegin "Stopping ${srvname}"
+ #start-stop-daemon --stop --quiet --pidfile ${pidfile}
+ getconfig
+ ps -Ao pid,args | egrep "^[[:space:]]*[[:digit:]]+ /usr/sbin/vblade ${shelf} ${slot} ${netif} ${src}" | awk '{print $1}' | xargs kill
+ eend $?
+
+ #start-stop-daemon --stop --quiet --exec /usr/sbin/vblade
+}
+
+# vim: ft=gentoo-init-d syntax=gentoo-init-d :
+# vim: ai sw=4 sts=4 ts=4 :
diff --git a/sys-block/vblade/vblade-14.ebuild b/sys-block/vblade/vblade-14.ebuild
new file mode 100644
index 000000000000..592e3edf4e90
--- /dev/null
+++ b/sys-block/vblade/vblade-14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-14.ebuild,v 1.1 2007/03/07 19:49:54 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="vblade exports a block device using AoE"
+HOMEPAGE="http://sf.net/projects/aoetools/"
+#SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # messy tarball
+ make clean || die "Failed to clean up source"
+ sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
+}
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ doman vblade.8
+ dodoc HACKING NEWS README
+ dosbin vblade
+ dosbin ${FILESDIR}/vbladed
+ newconfd ${FILESDIR}/conf.d-vblade vblade
+ newinitd ${FILESDIR}/init.d-vblade.vblade0-14 vblade.vblade0
+}
+
+pkg_postinst() {
+ einfo "We do now include an init.d script, please look in your init.d and"
+ einfo "conf.d directories for it."
+}