summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVikraman Choudhury <vikraman@gentoo.org>2013-05-28 19:48:25 +0000
committerVikraman Choudhury <vikraman@gentoo.org>2013-05-28 19:48:25 +0000
commit4b1cdf3045772a6d5275d1f65c397f543e409c73 (patch)
tree5c6cb604506e7f9c445dfbc6fc2cc78d05680666 /sys-block
parentVersion bump. (diff)
downloadgentoo-2-4b1cdf3045772a6d5275d1f65c397f543e409c73.tar.gz
gentoo-2-4b1cdf3045772a6d5275d1f65c397f543e409c73.tar.bz2
gentoo-2-4b1cdf3045772a6d5275d1f65c397f543e409c73.zip
Patch to fix build on linux 3.8, fixes bug #471606
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key B0A72FD2)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/rts_pstor/ChangeLog8
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch29
-rw-r--r--sys-block/rts_pstor/rts_pstor-1.10-r1.ebuild34
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-block/rts_pstor/ChangeLog b/sys-block/rts_pstor/ChangeLog
index 43922342e301..34421778f5c4 100644
--- a/sys-block/rts_pstor/ChangeLog
+++ b/sys-block/rts_pstor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/rts_pstor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/rts_pstor/ChangeLog,v 1.1 2013/02/28 17:48:08 vikraman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/rts_pstor/ChangeLog,v 1.2 2013/05/28 19:48:25 vikraman Exp $
+
+*rts_pstor-1.10-r1 (28 May 2013)
+
+ 28 May 2013; Vikraman <vikraman@gentoo.org> +rts_pstor-1.10-r1.ebuild,
+ +files/rts_pstor-linux-3.8.patch:
+ Patch to fix build on linux 3.8, fixes bug #471606
*rts_pstor-1.10 (28 Feb 2013)
diff --git a/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch b/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch
new file mode 100644
index 000000000000..797b1088f31b
--- /dev/null
+++ b/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch
@@ -0,0 +1,29 @@
+--- rts_pstor.a/rtsx.c 2011-01-11 14:41:07.000000000 +0530
++++ rts_pstor.b/rtsx.c 2013-05-29 00:39:11.319267655 +0530
+@@ -913,7 +913,7 @@
+ chip->s3_pwr_off_delay = 1000;
+ }
+
+-static int __devinit rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
++static int rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
+ {
+ struct Scsi_Host *host;
+ struct rtsx_dev *dev;
+@@ -1077,7 +1077,7 @@
+ }
+
+
+-static void __devexit rtsx_remove(struct pci_dev *pci)
++static void rtsx_remove(struct pci_dev *pci)
+ {
+ struct rtsx_dev *dev = (struct rtsx_dev *)pci_get_drvdata(pci);
+
+@@ -1104,7 +1104,7 @@
+ .name = CR_DRIVER_NAME,
+ .id_table = rtsx_ids,
+ .probe = rtsx_probe,
+- .remove = __devexit_p(rtsx_remove),
++ .remove = rtsx_remove,
+ #ifdef CONFIG_PM
+ .suspend = rtsx_suspend,
+ .resume = rtsx_resume,
diff --git a/sys-block/rts_pstor/rts_pstor-1.10-r1.ebuild b/sys-block/rts_pstor/rts_pstor-1.10-r1.ebuild
new file mode 100644
index 000000000000..52847e49fe5d
--- /dev/null
+++ b/sys-block/rts_pstor/rts_pstor-1.10-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/rts_pstor/rts_pstor-1.10-r1.ebuild,v 1.1 2013/05/28 19:48:25 vikraman Exp $
+
+EAPI=4
+
+inherit linux-mod
+
+DESCRIPTION="PCIE RTS5209 card reader driver for Linux"
+HOMEPAGE="http://www.realtek.com.tw/Downloads/downloadsView.aspx?PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3"
+SRC_URI="http://dev.gentoo.org/~vikraman/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+MODULE_NAMES="rts_pstor(kernel/drivers/scsi)"
+BUILD_TARGETS="default"
+
+src_prepare() {
+ sed -i -e 's/\/lib\/modules\/\$(shell uname -r)\/build\//\$(KERNELDIR)/g' Makefile || die "Sed failed!"
+ epatch "${FILESDIR}/${PN}-linux-3.8.patch"
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+}