summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 19:50:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 19:50:07 +0000
commit47bcc233fa5828c2c1d3594f5e48239464e2c38d (patch)
tree18211ffc3fb5cba3303c2767dca3d3f3bcd92b65 /sys-block
parentRemove older ebuilds. Remove most keywords from 1.5.6. (diff)
downloadgentoo-2-47bcc233fa5828c2c1d3594f5e48239464e2c38d.tar.gz
gentoo-2-47bcc233fa5828c2c1d3594f5e48239464e2c38d.tar.bz2
gentoo-2-47bcc233fa5828c2c1d3594f5e48239464e2c38d.zip
Fix building with GLIBC 2.10+ wrt #278182.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/scsirastools/ChangeLog8
-rw-r--r--sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch87
-rw-r--r--sys-block/scsirastools/scsirastools-1.5.6.ebuild16
3 files changed, 102 insertions, 9 deletions
diff --git a/sys-block/scsirastools/ChangeLog b/sys-block/scsirastools/ChangeLog
index 03b0c0b7f698..dd7e1d248599 100644
--- a/sys-block/scsirastools/ChangeLog
+++ b/sys-block/scsirastools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/scsirastools
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/scsirastools/ChangeLog,v 1.7 2008/06/29 07:53:32 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/scsirastools/ChangeLog,v 1.8 2009/08/05 19:50:07 ssuominen Exp $
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ scsirastools-1.5.6.ebuild, +files/scsirastools-1.5.6-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #278182.
29 Jun 2008; Torsten Veller <tove@gentoo.org> scsirastools-1.5.4.ebuild,
scsirastools-1.5.6.ebuild:
diff --git a/sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch b/sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch
new file mode 100644
index 000000000000..de874bad2911
--- /dev/null
+++ b/sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch
@@ -0,0 +1,87 @@
+diff -ur scsirastools-1.5.6.orig/src/getmd.c scsirastools-1.5.6/src/getmd.c
+--- scsirastools-1.5.6.orig/src/getmd.c 2007-02-02 21:16:38.000000000 +0200
++++ scsirastools-1.5.6/src/getmd.c 2009-08-05 22:51:00.000000000 +0300
+@@ -81,7 +81,7 @@
+ } else return (-1); /*not found*/
+ }
+
+-static int getline(FILE * fd, char *buf, int len)
++static int get_line(FILE * fd, char *buf, int len)
+ {
+ int i;
+ int ch;
+@@ -119,7 +119,7 @@
+ sraidstr = strlen(raidstr);
+ strcpy(mdpart, "/dev/sda1"); /* default */
+ strcpy(rdev, "/dev/md0"); /* default */
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* look for raiddev string */
+ i = findmatch(buf, rlen, raidstr, sraidstr, 0);
+diff -ur scsirastools-1.5.6.orig/src/sgraidmon.c scsirastools-1.5.6/src/sgraidmon.c
+--- scsirastools-1.5.6.orig/src/sgraidmon.c 2007-10-16 01:15:15.000000000 +0300
++++ scsirastools-1.5.6/src/sgraidmon.c 2009-08-05 22:51:00.000000000 +0300
+@@ -330,7 +330,7 @@
+ rdev[0] = 0; /* default rdev (mddev) */
+ strcpy(mdpart, "/dev/sdz1"); /* default mdpart */
+ foundit = 0;
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* check for comment */
+ if (buf[0] == '#') continue;
+@@ -392,7 +392,7 @@
+ if (fd == NULL) return (np);
+ sraidstr = strlen(raidstr);
+ sdevstr = strlen(devstr);
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* check for comment */
+ if (buf[0] == '#') continue;
+diff -ur scsirastools-1.5.6.orig/src/sgsafte.c scsirastools-1.5.6/src/sgsafte.c
+--- scsirastools-1.5.6.orig/src/sgsafte.c 2007-09-13 00:45:29.000000000 +0300
++++ scsirastools-1.5.6/src/sgsafte.c 2009-08-05 22:51:00.000000000 +0300
+@@ -231,7 +231,7 @@
+ rdev[0] = 0; /* default rdev (mddev) */
+ strcpy(mdpart, "/dev/sdz1"); /* default mdpart */
+ foundit = 0;
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* look for raiddev string */
+ i = findmatch(buf, rlen, raidstr, sraidstr, 0);
+@@ -284,7 +284,7 @@
+ fd = fopen(raidfile, "r");
+ if (fd == NULL) return (np);
+ sraidstr = strlen(raidstr);
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* look for raiddev string */
+ i = findmatch(buf, rlen, raidstr, sraidstr, 0);
+diff -ur scsirastools-1.5.6.orig/src/sgsubmon.c scsirastools-1.5.6/src/sgsubmon.c
+--- scsirastools-1.5.6.orig/src/sgsubmon.c 2007-10-16 17:03:39.000000000 +0300
++++ scsirastools-1.5.6/src/sgsubmon.c 2009-08-05 22:51:00.000000000 +0300
+@@ -159,7 +159,7 @@
+ return;
+ }
+
+-int getline(FILE * fd, char *buf, int len)
++int get_line(FILE * fd, char *buf, int len)
+ {
+ int i;
+ int ch;
+diff -ur scsirastools-1.5.6.orig/src/sgsubmon.h scsirastools-1.5.6/src/sgsubmon.h
+--- scsirastools-1.5.6.orig/src/sgsubmon.h 2007-09-13 00:38:28.000000000 +0300
++++ scsirastools-1.5.6/src/sgsubmon.h 2009-08-05 22:50:59.000000000 +0300
+@@ -124,7 +124,7 @@
+ void itoh(uchar * chp, int len, char *str);
+ void dumpbufr(FILE * fdout, uchar * bufp, int mlen, char *hdr);
+ void dump_buf(FILE * fdout, uchar * bufp, int mlen, char *hdr, char fascii);
+-int getline(FILE * fd, char *buf, int len) ;
++int get_line(FILE * fd, char *buf, int len) ;
+ int findmatch(char *buffer,int sbuf, char *pattern,int spattern,char figncase);
+ int fillstr(char *to, uchar *from,int len);
+ int IsSATA(int idev);
diff --git a/sys-block/scsirastools/scsirastools-1.5.6.ebuild b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
index aa5ce69ef7f4..a0a7878ba7ad 100644
--- a/sys-block/scsirastools/scsirastools-1.5.6.ebuild
+++ b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/scsirastools/scsirastools-1.5.6.ebuild,v 1.2 2008/06/29 07:53:32 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/scsirastools/scsirastools-1.5.6.ebuild,v 1.3 2009/08/05 19:50:07 ssuominen Exp $
-inherit autotools
+inherit autotools eutils
DESCRIPTION="Serviceability for SCSI Disks and Arrays"
HOMEPAGE="http://scsirastools.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
-DEPEND="virtual/libc
- sys-apps/rescan-scsi-bus
- sys-apps/sg3_utils"
-#RDEPEND=""
+
+RDEPEND="sys-apps/rescan-scsi-bus
+ sys-apps/sg3_utils"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
@@ -25,6 +26,7 @@ src_unpack() {
-e '/^SUBDIRS/s,files,,' \
"${S}"/Makefile.am || die "sed Makefile.am failed"
cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
eautoreconf
# i386 ELF binaries in tarball = bad
rm -f "${S}"/files/alarms*