summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-03 05:34:51 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-03 05:34:51 +0000
commit43fb899a6c3b61a6819ecfba780fb9f76348bba1 (patch)
tree4c3451c4467a0bc655fa5960751c6733b9b3b76e /sys-block
parentVersion bump #168768 by Kevin Parent. (diff)
downloadgentoo-2-43fb899a6c3b61a6819ecfba780fb9f76348bba1.tar.gz
gentoo-2-43fb899a6c3b61a6819ecfba780fb9f76348bba1.tar.bz2
gentoo-2-43fb899a6c3b61a6819ecfba780fb9f76348bba1.zip
Use syscall() rather than _syscall#() #163800 by Peter Ruskin.
(Portage version: 2.1.2-r13)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/gpart/ChangeLog8
-rw-r--r--sys-block/gpart/files/gpart-0.1h-no-_syscall.patch15
-rw-r--r--sys-block/gpart/gpart-0.1h-r1.ebuild9
3 files changed, 26 insertions, 6 deletions
diff --git a/sys-block/gpart/ChangeLog b/sys-block/gpart/ChangeLog
index b26d56cac443..20dbf0785416 100644
--- a/sys-block/gpart/ChangeLog
+++ b/sys-block/gpart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/gpart
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/gpart/ChangeLog,v 1.4 2006/01/28 17:25:38 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/gpart/ChangeLog,v 1.5 2007/03/03 05:34:51 vapier Exp $
+
+ 03 Mar 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/gpart-0.1h-no-_syscall.patch, gpart-0.1h-r1.ebuild:
+ Use syscall() rather than _syscall#() #163800 by Peter Ruskin.
28 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> gpart-0.1h-r1.ebuild:
Move to -amd64 as per bug #120741 waiting for a solution.
diff --git a/sys-block/gpart/files/gpart-0.1h-no-_syscall.patch b/sys-block/gpart/files/gpart-0.1h-no-_syscall.patch
new file mode 100644
index 000000000000..b50bcd2d75e9
--- /dev/null
+++ b/sys-block/gpart/files/gpart-0.1h-no-_syscall.patch
@@ -0,0 +1,15 @@
+use syscall() rather than _syscall#()
+
+http://bugs.gentoo.org/163800
+
+--- src/l64seek.c
++++ src/l64seek.c
+@@ -27,7 +27,7 @@
+ static int osptr = -1;
+
+ #if defined(__linux__) && defined(__i386__) && ! defined(__PIC__)
+-_syscall5(int,_llseek,uint,fd,ulong,hi,ulong,lo,loff_t *,res,uint,wh)
++#define _llseek(fildes,offset,whence) syscall(__NR__llseek,fildes,offset,whence)
+ #endif
+
+
diff --git a/sys-block/gpart/gpart-0.1h-r1.ebuild b/sys-block/gpart/gpart-0.1h-r1.ebuild
index 41b7857eb4f0..ef8cd2c6f39d 100644
--- a/sys-block/gpart/gpart-0.1h-r1.ebuild
+++ b/sys-block/gpart/gpart-0.1h-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/gpart/gpart-0.1h-r1.ebuild,v 1.3 2006/01/28 17:25:38 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/gpart/gpart-0.1h-r1.ebuild,v 1.4 2007/03/03 05:34:51 vapier Exp $
inherit eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="-amd64 ~hppa x86"
IUSE=""
-RDEPEND="virtual/libc"
+RDEPEND=""
src_unpack() {
unpack ${A}
@@ -23,6 +23,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-vfat.patch
epatch "${FILESDIR}"/${P}-ntfs.patch
epatch "${FILESDIR}"/${P}-PIC.patch
+ epatch "${FILESDIR}"/${P}-no-_syscall.patch
epatch "${WORKDIR}"/gpart-0.1h-reiserfs-3.6.patch
sed -i -e "/^CFLAGS/s: -O2 : ${CFLAGS} :" make.defs
}
@@ -30,5 +31,5 @@ src_unpack() {
src_install() {
dobin src/gpart || die
doman man/gpart.8
- dodoc README CHANGES INSTALL LSM
+ dodoc README Changes INSTALL LSM
}