summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-10 15:30:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-10 15:30:44 +0000
commit4178d9048c3071c4fe17e9725bdde28c12fd3f02 (patch)
tree42baf7d6869c3b83e4805f2c6d0225ab3148a036 /sys-block
parentInstall desktop icon from livestation forums. (diff)
downloadgentoo-2-4178d9048c3071c4fe17e9725bdde28c12fd3f02.tar.gz
gentoo-2-4178d9048c3071c4fe17e9725bdde28c12fd3f02.tar.bz2
gentoo-2-4178d9048c3071c4fe17e9725bdde28c12fd3f02.zip
Add patch to build with kernel 2.6.30 released today.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/iscsitarget/ChangeLog6
-rw-r--r--sys-block/iscsitarget/files/iscsitarget-0.4.17+linux-2.6.30.patch37
-rw-r--r--sys-block/iscsitarget/iscsitarget-0.4.17.ebuild3
3 files changed, 44 insertions, 2 deletions
diff --git a/sys-block/iscsitarget/ChangeLog b/sys-block/iscsitarget/ChangeLog
index 223daefc7d3d..961cec704fbd 100644
--- a/sys-block/iscsitarget/ChangeLog
+++ b/sys-block/iscsitarget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/iscsitarget
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/ChangeLog,v 1.23 2009/03/25 15:20:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/ChangeLog,v 1.24 2009/06/10 15:30:44 flameeyes Exp $
+
+ 10 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ iscsitarget-0.4.17.ebuild, +files/iscsitarget-0.4.17+linux-2.6.30.patch:
+ Add patch to build with kernel 2.6.30 released today.
25 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
iscsitarget-0.4.17.ebuild:
diff --git a/sys-block/iscsitarget/files/iscsitarget-0.4.17+linux-2.6.30.patch b/sys-block/iscsitarget/files/iscsitarget-0.4.17+linux-2.6.30.patch
new file mode 100644
index 000000000000..fa420e97b375
--- /dev/null
+++ b/sys-block/iscsitarget/files/iscsitarget-0.4.17+linux-2.6.30.patch
@@ -0,0 +1,37 @@
+From cb1b94ffa91d71aba8e07ed018e9f43064e05a49 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Wed, 10 Jun 2009 17:24:02 +0200
+Subject: [PATCH 3/3] Fix building with Linux kernel 2.6.30 and later.
+
+With commit 99b76233803beab302123d243eea9e41149804f3 the proc_dir_entry
+structure does not have an owner any longer, this just removes the
+assignment to make the code build with the newer kernel.
+---
+ kernel/config.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/kernel/config.c b/kernel/config.c
+index d6c4b5e..34681f5 100644
+--- a/kernel/config.c
++++ b/kernel/config.c
+@@ -5,6 +5,7 @@
+ */
+
+ #include <linux/proc_fs.h>
++#include <linux/version.h>
+
+ #include "iscsi.h"
+ #include "iscsi_dbg.h"
+@@ -43,7 +44,9 @@ int iet_procfs_init(void)
+ if (!(proc_iet_dir = proc_mkdir("iet", init_net.proc_net)))
+ goto err;
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 30)
+ proc_iet_dir->owner = THIS_MODULE;
++#endif
+
+ for (i = 0; i < ARRAY_SIZE(iet_proc_entries); i++) {
+ ent = create_proc_entry(iet_proc_entries[i].name, 0, proc_iet_dir);
+--
+1.6.3.1
+
diff --git a/sys-block/iscsitarget/iscsitarget-0.4.17.ebuild b/sys-block/iscsitarget/iscsitarget-0.4.17.ebuild
index 35956d71aa81..75a2758314b9 100644
--- a/sys-block/iscsitarget/iscsitarget-0.4.17.ebuild
+++ b/sys-block/iscsitarget/iscsitarget-0.4.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/iscsitarget-0.4.17.ebuild,v 1.4 2009/03/25 15:20:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/iscsitarget-0.4.17.ebuild,v 1.5 2009/06/10 15:30:44 flameeyes Exp $
inherit linux-mod eutils flag-o-matic
@@ -27,6 +27,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-0.4.17-build.patch
epatch "${FILESDIR}"/${PN}-0.4.17+linux-2.6.28.patch #252608
epatch "${FILESDIR}"/${PN}-0.4.17+linux-2.6.29.patch
+ epatch "${FILESDIR}"/${PN}-0.4.17+linux-2.6.30.patch
convert_to_m "${S}"/Makefile
}