summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-01 12:04:00 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-01 12:04:00 +0000
commit8b85848d5463ba524da6c2b788e70371a461b9f6 (patch)
treeefae368859770ad4c1b084a516b0a6c6812ad796 /sys-block/tgt
parentChange version scheme (diff)
downloadgentoo-2-8b85848d5463ba524da6c2b788e70371a461b9f6.tar.gz
gentoo-2-8b85848d5463ba524da6c2b788e70371a461b9f6.tar.bz2
gentoo-2-8b85848d5463ba524da6c2b788e70371a461b9f6.zip
[sys-block/tgt] Version bump
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/tgt')
-rw-r--r--sys-block/tgt/ChangeLog7
-rw-r--r--sys-block/tgt/tgt-1.0.18.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-block/tgt/ChangeLog b/sys-block/tgt/ChangeLog
index ce19f6d31a30..4d9c639df718 100644
--- a/sys-block/tgt/ChangeLog
+++ b/sys-block/tgt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/tgt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/ChangeLog,v 1.14 2011/06/30 22:10:10 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/ChangeLog,v 1.15 2011/09/01 12:04:00 alexxy Exp $
+
+*tgt-1.0.18 (01 Sep 2011)
+
+ 01 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +tgt-1.0.18.ebuild:
+ Version bump
30 Jun 2011; Alexey Shvetsov <alexxy@gentoo.org> -tgt-1.0.15.ebuild:
Drop old versions
diff --git a/sys-block/tgt/tgt-1.0.18.ebuild b/sys-block/tgt/tgt-1.0.18.ebuild
new file mode 100644
index 000000000000..fb7d66c3853d
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.18.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tgt/tgt-1.0.18.ebuild,v 1.1 2011/09/01 12:04:00 alexxy Exp $
+
+EAPI=4
+
+inherit flag-o-matic linux-info
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="http://stgt.sourceforge.net"
+SRC_URI="http://stgt.sourceforge.net/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ibmvio infiniband fcp fcoe"
+
+DEPEND="dev-perl/config-general
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )"
+RDEPEND="${DEPEND}
+ sys-apps/sg3_utils"
+
+pkg_setup() {
+ CONFIG_CHECK="~SCSI_TGT"
+ WARNING_SCSI_TGT="Your kernel needs CONFIG_SCSI_TGT"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ use ibmvio && myconf="${myconf} IBMVIO=1"
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use fcp && myconf="${myconf} FCP=1"
+ use fcoe && myconf="${myconf} FCOE=1"
+
+ sed -e 's:\($(CC)\):\1 $(LDFLAGS):' -i usr/Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF}
+ doinitd "${FILESDIR}/tgtd"
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}