summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-15 09:45:21 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-15 09:45:21 +0000
commit821eed389ee5988053fb02cf7c24f603b0e490e8 (patch)
treeb4b2f06424ba47ff1a09ddab1c6788b681ea6031 /sys-block/partimage
parentFix up broken changelog. (diff)
downloadgentoo-2-821eed389ee5988053fb02cf7c24f603b0e490e8.tar.gz
gentoo-2-821eed389ee5988053fb02cf7c24f603b0e490e8.tar.bz2
gentoo-2-821eed389ee5988053fb02cf7c24f603b0e490e8.zip
Remove tree-incompatible versions as slang-1 is no more.
(Portage version: 2.1.5.5)
Diffstat (limited to 'sys-block/partimage')
-rw-r--r--sys-block/partimage/ChangeLog6
-rw-r--r--sys-block/partimage/partimage-0.6.4-r3.ebuild147
-rw-r--r--sys-block/partimage/partimage-0.6.4-r4.ebuild184
3 files changed, 5 insertions, 332 deletions
diff --git a/sys-block/partimage/ChangeLog b/sys-block/partimage/ChangeLog
index abe5e9024b14..704cba9d125d 100644
--- a/sys-block/partimage/ChangeLog
+++ b/sys-block/partimage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/partimage
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.35 2008/04/07 20:57:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.36 2008/06/15 09:45:21 drac Exp $
+
+ 15 Jun 2008; Samuli Suominen <drac@gentoo.org> -partimage-0.6.4-r3.ebuild,
+ -partimage-0.6.4-r4.ebuild:
+ Remove tree-incompatible versions as slang-1 is no more.
07 Apr 2008; Markus Meier <maekke@gentoo.org> partimage-0.6.7.ebuild:
amd64/x86 stable, bug #216076
diff --git a/sys-block/partimage/partimage-0.6.4-r3.ebuild b/sys-block/partimage/partimage-0.6.4-r3.ebuild
deleted file mode 100644
index f451d9235490..000000000000
--- a/sys-block/partimage/partimage-0.6.4-r3.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.4-r3.ebuild,v 1.23 2008/02/26 19:08:06 xmerlin Exp $
-
-WANT_AUTOMAKE="1.8"
-
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="Console-based application to efficiently save raw partition data to an image file."
-HOMEPAGE="http://www.partimage.org/"
-SRC_URI="mirror://sourceforge/partimage/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc -ppc64 ~sparc x86"
-IUSE="ssl nologin nls"
-
-RDEPEND="virtual/libc
- >=sys-libs/zlib-1.1.4
- >=dev-libs/newt-0.51.6
- app-arch/bzip2
- =sys-libs/slang-1*
- nls? ( sys-devel/gettext )
- ssl? ( >=dev-libs/openssl-0.9.6g )"
-DEPEND="${RDEPEND}"
-
-PARTIMAG_GROUP_GID=91
-PARTIMAG_USER_UID=91
-PARTIMAG_GROUP_NAME=partimag
-PARTIMAG_USER_NAME=partimag
-PARTIMAG_USER_SH=-1
-PARTIMAG_USER_HOMEDIR=/var/log/partimage
-PARTIMAG_USER_GROUPS=partimag
-
-pkg_setup() {
- # Now add users if needed
- enewgroup ${PARTIMAG_GROUP_NAME} ${PARTIMAG_GROUP_GID}
- enewuser ${PARTIMAG_USER_NAME} ${PARTIMAG_USER_UID} ${PARTIMAG_USER_SH} ${PARTIMAG_USER_HOMEDIR} ${PARTIMAG_USER_GROUPS}
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # we can do better security ourselves
- epatch "${FILESDIR}"/${P}-nodumbpermchecks.diff || die
- epatch "${FILESDIR}"/${P}-chown.patch || die
- epatch "${FILESDIR}"/${P}-not_install_info.patch || die
- epatch "${FILESDIR}"/${P}-fixserverargs.diff || die
- epatch "${FILESDIR}"/${P}-lib64.patch || die
- epatch "${FILESDIR}"/${P}-fflush-before-re-read-partition-table.patch || die
- epatch "${FILESDIR}"/${P}-LP64-fixes.patch || die
- epatch "${FILESDIR}"/${P}-save_all_and_rest_all_actions.patch || die
- epatch "${FILESDIR}"/${P}-datadir-path.patch || die
- epatch "${FILESDIR}"/${P}-gui.diff || die
-}
-
-src_compile() {
- filter-flags -fno-exceptions
- use ppc && append-flags -fsigned-char
-
- local myconf
- use nologin && myconf="${myconf} --disable-login"
-
- econf \
- ${myconf} \
- --sysconfdir=/etc \
- `use_enable ssl` \
- `use_enable nls`|| die "econf failed"
-
- emake || die
-}
-
-src_install() {
- einstall \
- MKINSTALLDIRS=/usr/share/automake-1.8/mkinstalldirs || die
-
- keepdir /var/log/partimage
-
- insinto /etc/partimaged; doins "${FILESDIR}"/servercert.cnf || die
-
- newinitd "${FILESDIR}"/${PN}d.init ${PN}d || die
- newconfd "${FILESDIR}"/${PN}d.conf ${PN}d || die
-
- doman debian/partimage.1 debian/partimaged.8 "${FILESDIR}"/partimagedusers.5 || die
- dodoc AUTHORS BUGS ChangeLog INSTALL README* TODO partimage.lsm
-}
-
-# vars for SSL stuff
-confdir="${ROOT}etc/partimaged"
-privkey="${confdir}/partimaged.key"
-cnf="${confdir}/servercert.cnf"
-csr="${confdir}/partimaged.csr"
-cert="${confdir}/partimaged.cert"
-
-pkg_config() {
- if use ssl; then
- ewarn "Please customize /etc/partimaged/servercert.cnf before you continue!"
- ewarn "Press Ctrl-C to break now for it, or press enter to continue."
- read
- if [ ! -f ${privkey} ]; then
- einfo "Generating unencrypted private key: ${privkey}"
- openssl genrsa -out ${privkey} 1024 || die "Failed!"
- else
- einfo "Private key already exists: ${privkey}"
- fi
- if [ ! -f ${csr} ]; then
- einfo "Generating certificate request: ${csr}"
- openssl req -new -x509 -outform PEM -out ${csr} -key ${privkey} -config ${cnf} || die "Failed!"
- else
- einfo "Certificate request already exists: ${csr}"
- fi
- if [ ! -f ${cert} ]; then
- einfo "Generating self-signed certificate: ${cert}"
- openssl x509 -in ${csr} -out ${cert} -signkey ${privkey} || die "Failed!"
- else
- einfo "Self-signed certifcate already exists: ${cert}"
- fi
- einfo "Setting permissions"
- partimagesslperms || die "Failed!"
- einfo "Done"
- else
- einfo "SSL is disabled, not building certificates"
- fi
-}
-
-partimagesslperms() {
- local ret=0
- chmod 600 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chown partimag:0 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chmod 644 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- chown root:0 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- return $ret
-}
-
-pkg_postinst() {
- if use ssl; then
- einfo "To create the required SSL certificates, please do:"
- einfo "emerge --config =${PF}"
- # force a permmissions fixup
- partimagesslperms
- fi
- chown partimag:0 /etc/partimaged/partimagedusers || die
-}
diff --git a/sys-block/partimage/partimage-0.6.4-r4.ebuild b/sys-block/partimage/partimage-0.6.4-r4.ebuild
deleted file mode 100644
index 859ee985860f..000000000000
--- a/sys-block/partimage/partimage-0.6.4-r4.ebuild
+++ /dev/null
@@ -1,184 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.4-r4.ebuild,v 1.17 2008/02/26 19:08:06 xmerlin Exp $
-
-WANT_AUTOMAKE="1.8"
-
-inherit eutils flag-o-matic pam autotools
-
-MY_P="${PN}-${PV}-1"
-DESCRIPTION="Console-based application to efficiently save raw partition data to an image file."
-HOMEPAGE="http://www.partimage.org/"
-SRC_URI="mirror://sourceforge/partimage/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc"
-IUSE="ssl nologin nls pam static"
-
-DEPEND="virtual/libc
- >=sys-libs/zlib-1.1.4
- >=dev-libs/newt-0.51.6
- app-arch/bzip2
- =sys-libs/slang-1*
- nls? ( sys-devel/gettext )
- ssl? ( >=dev-libs/openssl-0.9.6g )"
-
-RDEPEND="!static? ( virtual/libc
- >=sys-libs/zlib-1.1.4
- >=dev-libs/lzo-1.08
- >=dev-libs/newt-0.51.6
- app-arch/bzip2
- >=sys-libs/slang-1.4.5-r2
- nls? ( sys-devel/gettext )
- ssl? ( >=dev-libs/openssl-0.9.6g )
- pam? ( virtual/pam )
- )"
-
-PARTIMAG_GROUP_GID=91
-PARTIMAG_USER_UID=91
-PARTIMAG_GROUP_NAME=partimag
-PARTIMAG_USER_NAME=partimag
-PARTIMAG_USER_SH=-1
-PARTIMAG_USER_HOMEDIR=/var/log/partimage
-PARTIMAG_USER_GROUPS=partimag
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # Now add users if needed
- enewgroup ${PARTIMAG_GROUP_NAME} ${PARTIMAG_GROUP_GID}
- enewuser ${PARTIMAG_USER_NAME} ${PARTIMAG_USER_UID} ${PARTIMAG_USER_SH} ${PARTIMAG_USER_HOMEDIR} ${PARTIMAG_USER_GROUPS}
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # we can do better security ourselves
- epatch "${FILESDIR}"/${P}-nodumbpermchecks.diff || die
- epatch "${FILESDIR}"/${P}-chown.patch || die
- epatch "${FILESDIR}"/${P}-not_install_info.patch || die
- epatch "${FILESDIR}"/${P}-fixserverargs.diff || die
- epatch "${FILESDIR}"/${P}-1-lib64.patch
- epatch "${FILESDIR}"/${P}-fflush-before-re-read-partition-table.patch || die
- epatch "${FILESDIR}"/${P}-save_all_and_rest_all_actions.patch || die
- epatch "${FILESDIR}"/${P}-datadir-path.patch || die
- epatch "${FILESDIR}"/${P}-dont-discard-error-message-in-batch-mode.patch || die
- epatch "${FILESDIR}"/${P}-save_file_and_rest_file_actions.patch || die
- epatch "${FILESDIR}"/${P}-varargs.patch || die
- epatch "${FILESDIR}"/${P}-gui.diff || die
- epatch "${FILESDIR}"/${P}-empty-salt.patch || die
- epatch "${FILESDIR}"/${P}-help.patch || die
- epatch "${FILESDIR}"/${P}-xfs.patch || die
- epatch "${FILESDIR}"/${P}-port.patch || die
-}
-
-src_compile() {
- filter-flags -fno-exceptions
- use ppc && append-flags -fsigned-char
-
- local myconf
- use nologin && myconf="${myconf} --disable-login"
- if use static
- then
- use pam && ewarn "pam and static compilation are mutually exclusive - using static and ignoring pam"
- else
- myconf="${myconf} `use_enable pam`"
- fi
- econf \
- ${myconf} \
- --sysconfdir=/etc \
- `use_enable ssl` \
- `use_enable nls` \
- `use_enable static all-static` \
- || die "econf failed"
-
- emake || die "make failed"
- #if use pam
- #then
- # make pamfile || die "couldn't create pam file"
- #fi
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- MKINSTALLDIRS=/usr/share/automake-1.8/mkinstalldirs install || die
-
- keepdir /var/log/partimage
-
- insinto /etc/partimaged; doins "${FILESDIR}"/servercert.cnf || die
-
- # init.d / conf.d
- newinitd "${FILESDIR}"/${PN}d.init ${PN}d || die
- newconfd "${FILESDIR}"/${PN}d.conf ${PN}d || die
-
- doman debian/partimage.1 debian/partimaged.8 "${FILESDIR}"/partimagedusers.5 || die
- dodoc AUTHORS BUGS ChangeLog INSTALL README* TODO partimage.lsm
-
- # pam
- if use pam
- then
- newpamd "${FILESDIR}"/partimaged.pam partimaged || die
- fi
-}
-
-# vars for SSL stuff
-confdir="${ROOT}etc/partimaged"
-privkey="${confdir}/partimaged.key"
-cnf="${confdir}/servercert.cnf"
-csr="${confdir}/partimaged.csr"
-cert="${confdir}/partimaged.cert"
-
-pkg_config() {
- if use ssl; then
- ewarn "Please customize /etc/partimaged/servercert.cnf before you continue!"
- ewarn "Press Ctrl-C to break now for it, or press enter to continue."
- read
- if [ ! -f ${privkey} ]; then
- einfo "Generating unencrypted private key: ${privkey}"
- openssl genrsa -out ${privkey} 1024 || die "Failed!"
- else
- einfo "Private key already exists: ${privkey}"
- fi
- if [ ! -f ${csr} ]; then
- einfo "Generating certificate request: ${csr}"
- openssl req -new -x509 -outform PEM -out ${csr} -key ${privkey} -config ${cnf} || die "Failed!"
- else
- einfo "Certificate request already exists: ${csr}"
- fi
- if [ ! -f ${cert} ]; then
- einfo "Generating self-signed certificate: ${cert}"
- openssl x509 -in ${csr} -out ${cert} -signkey ${privkey} || die "Failed!"
- else
- einfo "Self-signed certifcate already exists: ${cert}"
- fi
- einfo "Setting permissions"
- partimagesslperms || die "Failed!"
- einfo "Done"
- else
- einfo "SSL is disabled, not building certificates"
- fi
-}
-
-partimagesslperms() {
- local ret=0
- chmod 600 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chown partimag:0 ${privkey} 2>/dev/null
- ret=$((${ret}+$?))
- chmod 644 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- chown root:0 ${cert} ${csr} 2>/dev/null
- ret=$((${ret}+$?))
- return $ret
-}
-
-pkg_postinst() {
- if use ssl; then
- einfo "To create the required SSL certificates, please do:"
- einfo "emerge --config =${PF}"
- # force a permmissions fixup
- partimagesslperms
- fi
- chown partimag:0 /etc/partimaged/partimagedusers || die
-}