summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-07-17 02:15:20 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-07-17 02:15:20 +0000
commit7bf57701eebe813995c6fe91df7b3c82c29bcc39 (patch)
tree328e6cc44a8fb542536bca9299c55e07d6a5566b /sys-block/partimage
parentVersion bump. (diff)
downloadgentoo-2-7bf57701eebe813995c6fe91df7b3c82c29bcc39.tar.gz
gentoo-2-7bf57701eebe813995c6fe91df7b3c82c29bcc39.tar.bz2
gentoo-2-7bf57701eebe813995c6fe91df7b3c82c29bcc39.zip
Add patch to fix build errors with GCC 4.3. Bug #227231.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc9 x86_64)
Diffstat (limited to 'sys-block/partimage')
-rw-r--r--sys-block/partimage/ChangeLog6
-rw-r--r--sys-block/partimage/files/partimage-0.6.7-gcc43.patch36
-rw-r--r--sys-block/partimage/partimage-0.6.7.ebuild3
3 files changed, 43 insertions, 2 deletions
diff --git a/sys-block/partimage/ChangeLog b/sys-block/partimage/ChangeLog
index 704cba9d125d..3e34fca12996 100644
--- a/sys-block/partimage/ChangeLog
+++ b/sys-block/partimage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/partimage
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.36 2008/06/15 09:45:21 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.37 2008/07/17 02:15:20 dirtyepic Exp $
+
+ 17 Jul 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/partimage-0.6.7-gcc43.patch, partimage-0.6.7.ebuild:
+ Add patch to fix build errors with GCC 4.3. Bug #227231.
15 Jun 2008; Samuli Suominen <drac@gentoo.org> -partimage-0.6.4-r3.ebuild,
-partimage-0.6.4-r4.ebuild:
diff --git a/sys-block/partimage/files/partimage-0.6.7-gcc43.patch b/sys-block/partimage/files/partimage-0.6.7-gcc43.patch
new file mode 100644
index 000000000000..af37ee1c063e
--- /dev/null
+++ b/sys-block/partimage/files/partimage-0.6.7-gcc43.patch
@@ -0,0 +1,36 @@
+diff -Naurp partimage-0.6.7-orig/src/shared/net.h partimage-0.6.7/src/shared/net.h
+--- partimage-0.6.7-orig/src/shared/net.h 2008-02-03 15:57:55.000000000 -0600
++++ partimage-0.6.7/src/shared/net.h 2008-07-16 20:04:02.000000000 -0600
+@@ -28,7 +28,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <pthread.h>
+
+ #include "pathnames.h"
+diff -Naurp partimage-0.6.7-orig/src/server/partimaged.cpp partimage-0.6.7/src/server/partimaged.cpp
+--- partimage-0.6.7-orig/src/server/partimaged.cpp 2008-02-03 15:57:53.000000000 -0600
++++ partimage-0.6.7/src/server/partimaged.cpp 2008-07-16 20:10:04.000000000 -0600
+@@ -22,7 +22,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+
+ #include "net.h"
+ #include "netserver.h"
+diff -Naurp partimage-0.6.7-orig/src/server/partimaged-main.cpp partimage-0.6.7/src/server/partimaged-main.cpp
+--- partimage-0.6.7-orig/src/server/partimaged-main.cpp 2008-02-03 15:57:53.000000000 -0600
++++ partimage-0.6.7/src/server/partimaged-main.cpp 2008-07-16 20:10:45.000000000 -0600
+@@ -27,7 +27,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <signal.h>
diff --git a/sys-block/partimage/partimage-0.6.7.ebuild b/sys-block/partimage/partimage-0.6.7.ebuild
index 7d5beefe005d..6d6cf7f42647 100644
--- a/sys-block/partimage/partimage-0.6.7.ebuild
+++ b/sys-block/partimage/partimage-0.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.7.ebuild,v 1.3 2008/04/07 20:57:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.7.ebuild,v 1.4 2008/07/17 02:15:20 dirtyepic Exp $
WANT_AUTOMAKE="1.10"
@@ -55,6 +55,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-chown.patch || die
epatch "${FILESDIR}"/${PN}-0.6.6-disable_header_check.patch || die
epatch "${FILESDIR}"/${P}-datadir-path.patch || die
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {