summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-31 23:19:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-31 23:19:39 +0000
commitf5ed4e9f0cb9a666818181b9807819aad89c5ce5 (patch)
tree725e12a8ceb7a70e372650466feeeb53d926d7c6 /sys-block/open-iscsi
parentRemove old KDE versions. (diff)
downloadgentoo-2-f5ed4e9f0cb9a666818181b9807819aad89c5ce5.tar.gz
gentoo-2-f5ed4e9f0cb9a666818181b9807819aad89c5ce5.tar.bz2
gentoo-2-f5ed4e9f0cb9a666818181b9807819aad89c5ce5.zip
CONFIG_CHECK_MODULES should continue to exist for the as-module sanity check.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/open-iscsi')
-rw-r--r--sys-block/open-iscsi/ChangeLog7
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild5
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild3
3 files changed, 11 insertions, 4 deletions
diff --git a/sys-block/open-iscsi/ChangeLog b/sys-block/open-iscsi/ChangeLog
index 6b69f8ef37db..ad6a85108adc 100644
--- a/sys-block/open-iscsi/ChangeLog
+++ b/sys-block/open-iscsi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/open-iscsi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.28 2010/03/07 18:45:40 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.29 2010/03/31 23:19:39 robbat2 Exp $
+
+ 31 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
+ open-iscsi-2.0.871-r1.ebuild, open-iscsi-2.0.871.3.ebuild:
+ CONFIG_CHECK_MODULES should continue to exist for the as-module sanity
+ check.
*open-iscsi-2.0.871.3 (07 Mar 2010)
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
index b9997529fe45..faf03a6c6bbb 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.5 2009/12/08 19:08:11 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871-r1.ebuild,v 1.6 2010/03/31 23:19:39 robbat2 Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -31,6 +31,7 @@ pkg_setup() {
# more information:
# http://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966
# If there's a new release, check whether this is still valid!
+ CONFIG_CHECK_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
index 663bbc21ace1..ad2f53306f6e 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.1 2010/03/07 18:45:40 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.871.3.ebuild,v 1.2 2010/03/31 23:19:39 robbat2 Exp $
EAPI=2
inherit versionator linux-info eutils flag-o-matic
@@ -28,6 +28,7 @@ pkg_setup() {
# more information:
# http://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966
# If there's a new release, check whether this is still valid!
+ CONFIG_CHECK_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
linux_chkconfig_module ${module} || die "${module} needs to be built as module (builtin doesn't work)"