summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-01-25 04:29:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-01-25 04:29:56 +0000
commit034dd29947a303a99869512297b7ce036578e058 (patch)
tree7af06c42b58c83384c0e910537de15681a3e949c /sys-block/btrace
parentBug #267780: Fix typo in init script. (diff)
downloadgentoo-2-034dd29947a303a99869512297b7ce036578e058.tar.gz
gentoo-2-034dd29947a303a99869512297b7ce036578e058.tar.bz2
gentoo-2-034dd29947a303a99869512297b7ce036578e058.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/btrace')
-rw-r--r--sys-block/btrace/ChangeLog9
-rw-r--r--sys-block/btrace/btrace-1.0.1.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/sys-block/btrace/ChangeLog b/sys-block/btrace/ChangeLog
index b7a3dff01b1d..08f928be6f0b 100644
--- a/sys-block/btrace/ChangeLog
+++ b/sys-block/btrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/btrace
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/btrace/ChangeLog,v 1.17 2009/09/23 20:29:31 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/btrace/ChangeLog,v 1.18 2011/01/25 04:29:56 robbat2 Exp $
+
+*btrace-1.0.1 (25 Jan 2011)
+
+ 25 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> +btrace-1.0.1.ebuild:
+ Version bump.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org>
btrace-0.0.20060428050322.ebuild, btrace-0.0.20060614042007.ebuild,
diff --git a/sys-block/btrace/btrace-1.0.1.ebuild b/sys-block/btrace/btrace-1.0.1.ebuild
new file mode 100644
index 000000000000..8ea4b6420684
--- /dev/null
+++ b/sys-block/btrace/btrace-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/btrace/btrace-1.0.1.ebuild,v 1.1 2011/01/25 04:29:56 robbat2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic linux-info
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue."
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=""
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ || ( sys-kernel/linux-headers sys-kernel/mips-headers )
+ doc? ( virtual/latex-base )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_OPTS="-p1" epatch "${FILESDIR}"/${PN}-1.0.0-parallel-make.patch
+}
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}