summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-08-18 22:28:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-08-18 22:28:36 +0000
commit71257b11d2abadf270f6bd3281d4f105e5e0b54c (patch)
tree79d18e7e8670343901641a3573cb8fa47049ba4e /sys-block/btrace/btrace-0.0.20070730162628.ebuild
parentVersion bump (bug #171089), dropped old versions. (diff)
downloadgentoo-2-71257b11d2abadf270f6bd3281d4f105e5e0b54c.tar.gz
gentoo-2-71257b11d2abadf270f6bd3281d4f105e5e0b54c.tar.bz2
gentoo-2-71257b11d2abadf270f6bd3281d4f105e5e0b54c.zip
Version bump.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-block/btrace/btrace-0.0.20070730162628.ebuild')
-rw-r--r--sys-block/btrace/btrace-0.0.20070730162628.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-block/btrace/btrace-0.0.20070730162628.ebuild b/sys-block/btrace/btrace-0.0.20070730162628.ebuild
new file mode 100644
index 000000000000..33ecf8ab64f3
--- /dev/null
+++ b/sys-block/btrace/btrace-0.0.20070730162628.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/btrace/btrace-0.0.20070730162628.ebuild,v 1.1 2007/08/18 22:28:36 robbat2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue."
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+# this is in case Jens ever releases a real version
+MY_PV="git-${PV/0.0.}"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${MY_PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc"
+RDEPEND="virtual/libc"
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ || ( sys-kernel/linux-headers sys-kernel/mips-headers )
+ doc? ( virtual/tetex )"
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I${S}
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" || die "emake install failed"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf
+}