summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-09-24 10:11:44 +0000
committerHanno Böck <hanno@gentoo.org>2009-09-24 10:11:44 +0000
commitf0996f2600b7cc0a21d931ba17fc32f7f616f241 (patch)
treeada92a270a93c0db2507c5704e6759027c67cc7e /sys-auth
parentlibhx bump (diff)
downloadgentoo-2-f0996f2600b7cc0a21d931ba17fc32f7f616f241.tar.gz
gentoo-2-f0996f2600b7cc0a21d931ba17fc32f7f616f241.tar.bz2
gentoo-2-f0996f2600b7cc0a21d931ba17fc32f7f616f241.zip
pam_mount bump
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-1.32.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 30a5a21b5367..53b4294d65de 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.35 2009/09/06 08:53:47 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.36 2009/09/24 10:11:44 hanno Exp $
+
+*pam_mount-1.32 (24 Sep 2009)
+
+ 24 Sep 2009; Hanno Boeck <hanno@gentoo.org> +pam_mount-1.32.ebuild:
+ Version bump.
*pam_mount-1.31 (06 Sep 2009)
diff --git a/sys-auth/pam_mount/pam_mount-1.32.ebuild b/sys-auth/pam_mount/pam_mount-1.32.ebuild
new file mode 100644
index 000000000000..75661a626d05
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-1.32.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-1.32.ebuild,v 1.1 2009/09/24 10:11:44 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.1
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.1
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}