summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-14 21:59:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-14 21:59:21 +0000
commite3771e62cc4beca1002d47bec986cdc4f6208384 (patch)
treebce23e295bb383d590b6b302065b893f9b4a9612 /sys-auth
parentDelete older ebuild. (diff)
downloadgentoo-2-e3771e62cc4beca1002d47bec986cdc4f6208384.tar.gz
gentoo-2-e3771e62cc4beca1002d47bec986cdc4f6208384.tar.bz2
gentoo-2-e3771e62cc4beca1002d47bec986cdc4f6208384.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_pkcs11/ChangeLog11
-rw-r--r--sys-auth/pam_pkcs11/pam_pkcs11-0.6.4.ebuild98
2 files changed, 107 insertions, 2 deletions
diff --git a/sys-auth/pam_pkcs11/ChangeLog b/sys-auth/pam_pkcs11/ChangeLog
index 4b3e49ba6097..2890a7fcd71d 100644
--- a/sys-auth/pam_pkcs11/ChangeLog
+++ b/sys-auth/pam_pkcs11/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam_pkcs11
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pkcs11/ChangeLog,v 1.15 2009/12/19 20:25:23 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pkcs11/ChangeLog,v 1.16 2010/06/14 21:59:21 arfrever Exp $
+
+*pam_pkcs11-0.6.4 (14 Jun 2010)
+
+ 14 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pam_pkcs11-0.6.1-r1.ebuild, -files/pam_pkcs11-0.6.1-properinstall.patch,
+ +pam_pkcs11-0.6.4.ebuild:
+ Version bump.
*pam_pkcs11-0.6.2 (19 Dec 2009)
diff --git a/sys-auth/pam_pkcs11/pam_pkcs11-0.6.4.ebuild b/sys-auth/pam_pkcs11/pam_pkcs11-0.6.4.ebuild
new file mode 100644
index 000000000000..95b754fc9fc9
--- /dev/null
+++ b/sys-auth/pam_pkcs11/pam_pkcs11-0.6.4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pkcs11/pam_pkcs11-0.6.4.ebuild,v 1.1 2010/06/14 21:59:21 arfrever Exp $
+
+EAPI="3"
+
+inherit multilib pam
+
+DESCRIPTION="PKCS#11 PAM library"
+HOMEPAGE="http://www.opensc-project.org/pam_pkcs11"
+SRC_URI="http://www.opensc-project.org/files/pam_pkcs11/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="curl ldap pcsc-lite"
+
+RDEPEND="sys-libs/pam
+ dev-libs/openssl
+ curl? ( net-misc/curl )
+ ldap? ( net-nds/openldap )
+ pcsc-lite? ( sys-apps/pcsc-lite )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Fix the example files to be somewhat decent, and usable as
+ # default configuration
+ sed -i \
+ -e '/try_first_pass/s:false:true:' \
+ -e '/debug =/s:true:false:' \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ etc/pam_pkcs11.conf.example.in \
+ etc/pkcs11_eventmgr.conf.example || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ $(use_with curl) \
+ $(use_with pcsc-lite pcsclite) \
+ $(use_with ldap) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" pamdir="$(getpam_mod_dir)" install || die "emake install failed"
+
+ # These are all dlopened plugins, so .la files are useless.
+ find "${D}" -name '*.la' -delete || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+
+ # Move the make_hash_link script somehwere safe, it's _way_ too
+ # generic of a name to use.
+ dodir /usr/share/${PN}
+ mv "${D}"/usr/bin/make_hash_link.sh "${D}"/usr/share/${PN} || die
+
+ # Provide some basic configuration
+ keepdir /etc/pam_pkcs11{,/{cacerts,crl}}
+
+ insinto /etc/pam_pkcs11
+ newins etc/pam_pkcs11.conf.example pam_pkcs11.conf || die
+ newins etc/pkcs11_eventmgr.conf.example pkcs11_eventmgr.conf || die
+}
+
+pkg_config() {
+ local dir
+ for dir in "${ROOT}"/etc/${PN}/{cacerts,crl}; do
+ pushd "${dir}" &> /dev/null
+ ebegin "Creating hash links in '${dir}'"
+ "${ROOT}"/usr/share/${PN}/make_hash_link.sh || die
+ eend $?
+ popd &> /dev/null
+ done
+}
+
+pkg_postinst() {
+ elog "You probably want to configure the /etc/${PN}/${PN}.conf file."
+ elog "with the settings for your pkcs11 provider."
+ elog ""
+ elog "You might also want to set up /etc/${PN}/pkcs11_eventmgr.conf"
+ elog "with the settings for the event manager, and start it up at"
+ elog "user login."
+}
+
+# TODO list!
+#
+# - we need to find a way allow the user to choose whether to start the
+# event manager at _all_ the logins, and if that's the case, lock all
+# kind of sessions (terminal _and_ X);
+# - upstream should probably migrate the configuration of the event
+# manager on a per-user basis, since it makes little sense to be _all_
+# system-level configuration;
+# - we should probably provide some better config support that ensures
+# the configuration to be valid, as well as creating the symlinks;
+# - we should probably add support for nss;
+# - we should move the configuration in /etc/security as for the rest
+# of PAM-related configuration.