summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-05-14 20:17:51 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-05-14 20:17:51 +0000
commitc621ea9b4b536b1a953aeaec8fa2b86254f96b1b (patch)
treeeb7cb6bd2b6b91669884169d2cdf49bac19039ca /sys-auth
parentKeyword ~amd64 (diff)
downloadgentoo-2-c621ea9b4b536b1a953aeaec8fa2b86254f96b1b.tar.gz
gentoo-2-c621ea9b4b536b1a953aeaec8fa2b86254f96b1b.tar.bz2
gentoo-2-c621ea9b4b536b1a953aeaec8fa2b86254f96b1b.zip
version bump from upstream to build with freebsd and sparc
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-mdns/ChangeLog8
-rw-r--r--sys-auth/nss-mdns/files/digest-nss-mdns-0.103
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.10.ebuild59
3 files changed, 69 insertions, 1 deletions
diff --git a/sys-auth/nss-mdns/ChangeLog b/sys-auth/nss-mdns/ChangeLog
index 84e893a312cd..c4313952a4b4 100644
--- a/sys-auth/nss-mdns/ChangeLog
+++ b/sys-auth/nss-mdns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/nss-mdns
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.21 2007/05/14 15:33:29 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.22 2007/05/14 20:17:51 compnerd Exp $
+
+*nss-mdns-0.10 (14 May 2007)
+
+ 14 May 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +nss-mdns-0.10.ebuild:
+ Version bump from upstream to fix building on FreeBSD and SPARC
14 May 2007; Markus Ullmann <jokey@gentoo.org> nss-mdns-0.9-r1.ebuild:
Stable on x86 wrt bug #178470
diff --git a/sys-auth/nss-mdns/files/digest-nss-mdns-0.10 b/sys-auth/nss-mdns/files/digest-nss-mdns-0.10
new file mode 100644
index 000000000000..3b6e35cf8706
--- /dev/null
+++ b/sys-auth/nss-mdns/files/digest-nss-mdns-0.10
@@ -0,0 +1,3 @@
+MD5 03938f17646efbb50aa70ba5f99f51d7 nss-mdns-0.10.tar.gz 353130
+RMD160 e33f318790bc0a7367297284cad977289f830a84 nss-mdns-0.10.tar.gz 353130
+SHA256 1e683c2e7c3921814706d62fbbd3e9cbf493a75fa00255e0e715508d8134fa6d nss-mdns-0.10.tar.gz 353130
diff --git a/sys-auth/nss-mdns/nss-mdns-0.10.ebuild b/sys-auth/nss-mdns/nss-mdns-0.10.ebuild
new file mode 100644
index 000000000000..8fc0ba556cc5
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/nss-mdns-0.10.ebuild,v 1.1 2007/05/14 20:17:51 compnerd Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="http://0pointer.de/lennart/projects/nss-mdns/"
+SRC_URI="http://0pointer.de/lennart/projects/nss-mdns/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+DEPEND="net-dns/avahi"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.8-avahi-socket.patch
+}
+
+src_compile() {
+ econf --enable-search-domains --enable-avahi || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ insinto /etc
+ doins ${FILESDIR}/mdns.allow
+
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You must modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns. Keep in mind that mdns will be slower if there are no"
+ ewarn "IPv6 addresses published via mDNS on the network. There are also"
+ ewarn "minimal (mdns?_minimal) libraries which only lookup .local hosts"
+ ewarn "and 169.254.x.x addresses."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf"
+ ewarn "An example line looks like:"
+ einfo "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4"
+ ewarn
+ ewarn "If you want to perform mDNS lookups for domains other than the ones"
+ ewarn "ending in .local, add them to /etc/mdns.allow"
+ ewarn
+ ebeep 5
+ epause 10
+}