summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-12 11:22:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-12 11:22:45 +0000
commitbc09198f9ad6b64e550da6e8148cc6adb8a188ce (patch)
tree8c664c89da18d0e626469f6a984494469e3a2c18 /sys-auth
parentFix USE=doc install #410677 by Ole Henrik Jahren. Update to EAPI=4. (diff)
downloadgentoo-2-bc09198f9ad6b64e550da6e8148cc6adb8a188ce.tar.gz
gentoo-2-bc09198f9ad6b64e550da6e8148cc6adb8a188ce.tar.bz2
gentoo-2-bc09198f9ad6b64e550da6e8148cc6adb8a188ce.zip
Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS, WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog7
-rw-r--r--sys-auth/polkit/files/polkit-0.110-W_define.patch21
-rw-r--r--sys-auth/polkit/polkit-0.110.ebuild4
3 files changed, 30 insertions, 2 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 446f2048a257..a4e7ca4ad799 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.137 2013/03/09 19:07:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.138 2013/03/12 11:22:44 ssuominen Exp $
+
+ 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
+ +files/polkit-0.110-W_define.patch:
+ Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
+ WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
Stable for sparc, wrt bug #452688
diff --git a/sys-auth/polkit/files/polkit-0.110-W_define.patch b/sys-auth/polkit/files/polkit-0.110-W_define.patch
new file mode 100644
index 000000000000..7c0cc312d907
--- /dev/null
+++ b/sys-auth/polkit/files/polkit-0.110-W_define.patch
@@ -0,0 +1,21 @@
+Failure to compile on SH4 arch because <sys/wait.h> is missing for #define's of:
+WIFEXITED, WEXITSTATUS, WIFSIGNALED, WTERMSIG
+
+Errors are like this:
+
+polkitbackendjsauthority.c:1509:3: warning: implicit declaration of function 'WIFEXITED' [-Wimplicit-function-declaration]
+polkitbackendjsauthority.c:1509:3: warning: nested extern declaration of 'WIFEXITED' [-Wnested-externs]
+
+polkitbackendjsauthority.c:(.text+0x3008): undefined reference to `WIFEXITED'
+polkitbackendjsauthority.c:(.text+0x3010): undefined reference to `WIFEXITED'
+
+--- src/polkitbackend/polkitbackendjsauthority.c
++++ src/polkitbackend/polkitbackendjsauthority.c
+@@ -20,6 +20,7 @@
+ */
+
+ #include "config.h"
++#include <sys/wait.h>
+ #include <errno.h>
+ #include <pwd.h>
+ #include <grp.h>
diff --git a/sys-auth/polkit/polkit-0.110.ebuild b/sys-auth/polkit/polkit-0.110.ebuild
index 69b84110909b..dbd232859b9a 100644
--- a/sys-auth/polkit/polkit-0.110.ebuild
+++ b/sys-auth/polkit/polkit-0.110.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.110.ebuild,v 1.11 2013/03/09 19:07:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.110.ebuild,v 1.12 2013/03/12 11:22:44 ssuominen Exp $
EAPI=5
inherit eutils multilib pam pax-utils systemd user
@@ -57,6 +57,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-W_define.patch
+
sed -i -e 's|unix-group:wheel|unix-user:0|' src/polkitbackend/*-default.rules || die #401513
if has_version '>=dev-lang/spidermonkey-1.8.7'; then