summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-04-17 00:58:13 +0000
committerHanno Böck <hanno@gentoo.org>2011-04-17 00:58:13 +0000
commitbafd8cea3b1d25ae63ae696821899ddfcdc35d17 (patch)
tree3f4bb01303a29f81a8fc22fe1bb22076b7468dc9 /sys-auth
parentlibhx version bump. (diff)
downloadgentoo-2-bafd8cea3b1d25ae63ae696821899ddfcdc35d17.tar.gz
gentoo-2-bafd8cea3b1d25ae63ae696821899ddfcdc35d17.tar.bz2
gentoo-2-bafd8cea3b1d25ae63ae696821899ddfcdc35d17.zip
pam_mount version bump.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-2.10.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 9eadbc4acf6a..07aa369921db 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.50 2011/01/20 04:32:11 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.51 2011/04/17 00:58:13 hanno Exp $
+
+*pam_mount-2.10 (17 Apr 2011)
+
+ 17 Apr 2011; Hanno Boeck <hanno@gentoo.org> +pam_mount-2.10.ebuild:
+ Version bump.
*pam_mount-2.8 (20 Jan 2011)
diff --git a/sys-auth/pam_mount/pam_mount-2.10.ebuild b/sys-auth/pam_mount/pam_mount-2.10.ebuild
new file mode 100644
index 000000000000..e04ab878cc7e
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.10.ebuild,v 1.1 2011/04/17 00:58:13 hanno Exp $
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.10.1
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ dev-util/pkgconfig
+ app-arch/xz-utils"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.10.1
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ sys-process/lsof"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}