summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-03-05 17:06:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-03-05 17:06:15 +0000
commitb493a0e69a2fbb73bf6071e66ad53872f5a3918b (patch)
tree810f99a0b0629b71b52e15f5422fedf0f219002a /sys-auth
parentFixed to work with gtk+-2.12.1, bug #199495. (diff)
downloadgentoo-2-b493a0e69a2fbb73bf6071e66ad53872f5a3918b.tar.gz
gentoo-2-b493a0e69a2fbb73bf6071e66ad53872f5a3918b.tar.bz2
gentoo-2-b493a0e69a2fbb73bf6071e66ad53872f5a3918b.zip
Bump to avoid calling git during ebuild phases. Closes bug #212395.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pambase/ChangeLog8
-rw-r--r--sys-auth/pambase/pambase-20080305.ebuild (renamed from sys-auth/pambase/pambase-20080301.ebuild)5
2 files changed, 10 insertions, 3 deletions
diff --git a/sys-auth/pambase/ChangeLog b/sys-auth/pambase/ChangeLog
index 741c772c7c46..229ecd1f9636 100644
--- a/sys-auth/pambase/ChangeLog
+++ b/sys-auth/pambase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pambase
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.14 2008/03/04 23:09:32 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.15 2008/03/05 17:06:15 flameeyes Exp $
+
+*pambase-20080305 (05 Mar 2008)
+
+ 05 Mar 2008; Diego Pettenò <flameeyes@gentoo.org>
+ -pambase-20080301.ebuild, +pambase-20080305.ebuild:
+ Bump to avoid calling git during ebuild phases. Closes bug #212395.
04 Mar 2008; Brent Baude <ranger@gentoo.org> ChangeLog:
keyworded ~arch for ppc64, bug 210769
diff --git a/sys-auth/pambase/pambase-20080301.ebuild b/sys-auth/pambase/pambase-20080305.ebuild
index af80ac7a28ff..c6e13a827e19 100644
--- a/sys-auth/pambase/pambase-20080301.ebuild
+++ b/sys-auth/pambase/pambase-20080305.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20080301.ebuild,v 1.5 2008/03/04 23:03:15 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20080305.ebuild,v 1.1 2008/03/05 17:06:15 flameeyes Exp $
inherit eutils
@@ -65,6 +65,7 @@ src_compile() {
has_version sys-auth/openpam && implementation="openpam"
emake \
+ GIT=true \
DEBUG=$(use debug && echo yes || echo no) \
CRACKLIB=$(use cracklib && echo yes || echo no) \
CONSOLEKIT=$(use consolekit && echo yes || echo no) \
@@ -75,5 +76,5 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake GIT=true DESTDIR="${D}" install || die "emake install failed"
}