summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-12-05 21:12:52 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-12-05 21:12:52 +0000
commita1429d88b89f9e35462c389e04ed8d2b8a2c186e (patch)
treeb7e970fecb25cc1312677d468c91fbe641940864 /sys-auth
parentVersion bump and keyword ~x86. (diff)
downloadgentoo-2-a1429d88b89f9e35462c389e04ed8d2b8a2c186e.tar.gz
gentoo-2-a1429d88b89f9e35462c389e04ed8d2b8a2c186e.tar.bz2
gentoo-2-a1429d88b89f9e35462c389e04ed8d2b8a2c186e.zip
merge in improvements from Sunrise Overlay by Heath Caldwell <hncaldwell@gentoo.org>
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-ldapd/ChangeLog7
-rw-r--r--sys-auth/nss-ldapd/files/nslcd.rc20
-rw-r--r--sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild24
3 files changed, 45 insertions, 6 deletions
diff --git a/sys-auth/nss-ldapd/ChangeLog b/sys-auth/nss-ldapd/ChangeLog
index 01d6e898b684..7e0f464f1047 100644
--- a/sys-auth/nss-ldapd/ChangeLog
+++ b/sys-auth/nss-ldapd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/nss-ldapd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/ChangeLog,v 1.1 2008/12/04 22:17:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/ChangeLog,v 1.2 2008/12/05 21:12:51 cardoe Exp $
+
+ 05 Dec 2008; Doug Goldstein <cardoe@gentoo.org> files/nslcd.rc,
+ nss-ldapd-0.6.7.ebuild:
+ merge in improvements from Sunrise Overlay by Heath Caldwell
+ <hncaldwell@gentoo.org>
*nss-ldapd-0.6.7 (04 Dec 2008)
diff --git a/sys-auth/nss-ldapd/files/nslcd.rc b/sys-auth/nss-ldapd/files/nslcd.rc
index 79a7fbeeb900..60f4e340cf9e 100644
--- a/sys-auth/nss-ldapd/files/nslcd.rc
+++ b/sys-auth/nss-ldapd/files/nslcd.rc
@@ -1,17 +1,35 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/files/nslcd.rc,v 1.1 2008/12/04 22:17:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/files/nslcd.rc,v 1.2 2008/12/05 21:12:52 cardoe Exp $
+
+opts="checkconfig"
depend() {
need net
+ use dns logger
+}
+
+checkconfig() {
+ if [ ! -f /etc/nss-ldapd.conf ] ; then
+ eerror "Please create /etc/nss-ldapd.conf"
+ eerror "Example config: /usr/share/nss-ldapd/nss-ldapd.conf"
+ return 1
+ fi
+ return 0
}
start() {
+ checkconfig || return $?
+
+ ebegin "Starting nslcd"
start-stop-daemon --start --pidfile /var/run/nslcd/nslcd.pid \
--exec /usr/sbin/nslcd
+ eend $? "Failed to start nslcd"
}
stop() {
+ ebegin "Stopping nslcd"
start-stop-daemon --stop --pidfile /var/run/nslcd/nslcd.pid
+ eend $? "Failed to stop nslcd"
}
diff --git a/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild b/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
index 5e09048417a9..4a2c2a40e042 100644
--- a/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
+++ b/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild,v 1.1 2008/12/04 22:17:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild,v 1.2 2008/12/05 21:12:51 cardoe Exp $
+
+inherit multilib
DESCRIPTION="NSS module for name lookups using LDAP"
HOMEPAGE="http://ch.tudelft.nl/~arthur/nss-ldapd/"
@@ -12,11 +14,15 @@ KEYWORDS="~amd64"
IUSE="debug"
DEPEND="net-nds/openldap
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )
!sys-auth/nss_ldap"
RDEPEND="${DEPEND}"
src_compile() {
+ # nss libraries always go in /lib on Gentoo
econf --enable-warnings --with-ldap-lib=openldap $(use_enable debug) \
+ --libdir=/$(get_libdir) \
|| die "econf failed"
emake || die "emake failed"
}
@@ -24,11 +30,17 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS ChangeLog AUTHORS README
+
# for socket and pid file
- mkdir "${D}"/var/run/nslcd
+ keepdir /var/run/nslcd
# init script
newinitd "${FILESDIR}"/nslcd.rc nslcd
+
+ # make an example copy
+ insinto /usr/share/nss-ldapd
+ doins nss-ldapd.conf
}
pkg_postinst() {
@@ -36,6 +48,10 @@ pkg_postinst() {
elog "For this to work you must configure /etc/nss-ldapd.conf"
elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
elog
- elog "After configuring it, you MUST add `nslcd` to be started"
- elog "i.e. $ rc-update add nslcd default"
+ elog "In order to use nss-ldapd, nslcd needs to be running. You can"
+ elog "start it like this:"
+ elog " # /etc/init.d/nslcd start"
+ elog
+ elog "You can add it to the default runlevel like so:"
+ elog " # rc-update add nslcd default"
}