summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-09 15:24:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-09 15:24:59 +0000
commit987a89bf8d841db8592e5b02970de231a0fbfc80 (patch)
tree1c883f6f4aa8cb80440923e415e1e4bc577b18c7 /sys-auth
parentNew version with sparc patches for sanitized headers (diff)
downloadgentoo-2-987a89bf8d841db8592e5b02970de231a0fbfc80.tar.gz
gentoo-2-987a89bf8d841db8592e5b02970de231a0fbfc80.tar.bz2
gentoo-2-987a89bf8d841db8592e5b02970de231a0fbfc80.zip
Version bump as per bug #166087.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_ssh/ChangeLog9
-rw-r--r--sys-auth/pam_ssh/files/digest-pam_ssh-1.923
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.92.ebuild48
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-auth/pam_ssh/ChangeLog b/sys-auth/pam_ssh/ChangeLog
index 8d9da8bbe805..25dba4095488 100644
--- a/sys-auth/pam_ssh/ChangeLog
+++ b/sys-auth/pam_ssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_ssh
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.6 2006/10/02 01:26:14 tester Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.7 2007/02/09 15:24:59 flameeyes Exp $
+
+*pam_ssh-1.92 (09 Feb 2007)
+
+ 09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> +pam_ssh-1.92.ebuild:
+ Version bump as per bug #166087.
02 Oct 2006; Olivier Crête <tester@gentoo.org> pam_ssh-1.91-r2.ebuild:
Stable on amd64
diff --git a/sys-auth/pam_ssh/files/digest-pam_ssh-1.92 b/sys-auth/pam_ssh/files/digest-pam_ssh-1.92
new file mode 100644
index 000000000000..64368d777413
--- /dev/null
+++ b/sys-auth/pam_ssh/files/digest-pam_ssh-1.92
@@ -0,0 +1,3 @@
+MD5 3861f20572183adfadef8c77270e6165 pam_ssh-1.92.tar.bz2 260444
+RMD160 d7121ab89baaec82853758449f84429a387fee0e pam_ssh-1.92.tar.bz2 260444
+SHA256 d98f4698f692d46996b3845c2164528c8ad82f112df1c42abe7b8ebb2b133362 pam_ssh-1.92.tar.bz2 260444
diff --git a/sys-auth/pam_ssh/pam_ssh-1.92.ebuild b/sys-auth/pam_ssh/pam_ssh-1.92.ebuild
new file mode 100644
index 000000000000..ebb1970a9c75
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-1.92.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/pam_ssh-1.92.ebuild,v 1.1 2007/02/09 15:24:59 flameeyes Exp $
+
+inherit pam eutils
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+RESTRICT="nomirror confcache"
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# Doesn't work on OpenPAM.
+DEPEND="sys-libs/pam
+ sys-devel/libtool"
+
+RDEPEND="sys-libs/pam
+ virtual/ssh"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.91-debian.patch" #105546
+ epatch "${FILESDIR}/${PN}-1.91-syslog.patch" # glibc-2.4
+}
+
+src_compile() {
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO "${FILESDIR}/system-auth.example"
+}
+
+pkg_postinst() {
+ einfo "You can find an example system-auth file that uses this"
+ einfo "library in /usr/share/doc/${PF}"
+}