summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-09 14:23:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-09 14:23:21 +0000
commit947f5af991ae529dee68a194824fb79aa5e3588d (patch)
tree80e62100c6f575151a169bebc4532e658f254447 /sys-auth
parentMask pam_keystore. (diff)
downloadgentoo-2-947f5af991ae529dee68a194824fb79aa5e3588d.tar.gz
gentoo-2-947f5af991ae529dee68a194824fb79aa5e3588d.tar.bz2
gentoo-2-947f5af991ae529dee68a194824fb79aa5e3588d.zip
Initial import, thanks to Alexander Tratsevskiy in bug #285765. Masked missing some documentation on how to actually make use of this.
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_keystore/ChangeLog11
-rw-r--r--sys-auth/pam_keystore/metadata.xml5
-rw-r--r--sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild31
3 files changed, 47 insertions, 0 deletions
diff --git a/sys-auth/pam_keystore/ChangeLog b/sys-auth/pam_keystore/ChangeLog
new file mode 100644
index 000000000000..eced655a1408
--- /dev/null
+++ b/sys-auth/pam_keystore/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-auth/pam_keystore
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_keystore/ChangeLog,v 1.1 2009/10/09 14:23:21 flameeyes Exp $
+
+*pam_keystore-0.1.3 (09 Oct 2009)
+
+ 09 Oct 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pam_keystore-0.1.3.ebuild, +metadata.xml:
+ Initial import, thanks to Alexander Tratsevskiy in bug #285765. Masked
+ missing some documentation on how to actually make use of this.
+
diff --git a/sys-auth/pam_keystore/metadata.xml b/sys-auth/pam_keystore/metadata.xml
new file mode 100644
index 000000000000..81ada335fc94
--- /dev/null
+++ b/sys-auth/pam_keystore/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pam</herd>
+</pkgmetadata>
diff --git a/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild b/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild
new file mode 100644
index 000000000000..8b575ed34457
--- /dev/null
+++ b/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild,v 1.1 2009/10/09 14:23:21 flameeyes Exp $
+
+inherit pam toolchain-funcs
+
+DESCRIPTION="Keeps a login and the password the user in the kernel"
+HOMEPAGE="http://www.calculate-linux.org/pam_keystore"
+SRC_URI="ftp://ftp.calculate.ru/pub/calculate/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="virtual/pam
+ >=sys-apps/keyutils-1.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD_D="$(tc-getCC) -shared ${LDFLAGS}" \
+ CFLAGS="-fPIC ${CFLAGS}" \
+ SHARE= \
+ || die "make failed"
+}
+
+src_install() {
+ dopammod pam_keystore.so || die
+ newdoc README README.ru || die
+}