summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-27 18:10:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-27 18:10:05 +0000
commit8a3c5bf1b7ba653e4b5a0a10cbc069f0686693f7 (patch)
tree4e8c8068a795a87b3460273a9f7ee05ef9319db4 /sys-auth
parentAdd keywords and a disgusting libdl hack (diff)
downloadgentoo-2-8a3c5bf1b7ba653e4b5a0a10cbc069f0686693f7.tar.gz
gentoo-2-8a3c5bf1b7ba653e4b5a0a10cbc069f0686693f7.tar.bz2
gentoo-2-8a3c5bf1b7ba653e4b5a0a10cbc069f0686693f7.zip
old
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/ChangeLog10
-rw-r--r--sys-auth/consolekit/consolekit-0.4.5-r1.ebuild96
-rw-r--r--sys-auth/consolekit/files/consolekit-0.1.rc24
-rw-r--r--sys-auth/consolekit/files/consolekit-0.2.10-cleanup_console_tags.patch66
-rw-r--r--sys-auth/consolekit/files/consolekit-0.4.0-multilib.patch120
-rw-r--r--sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch31
-rw-r--r--sys-auth/consolekit/files/consolekit-0.4.1-shutdown-reboot-without-policies.patch35
7 files changed, 9 insertions, 373 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index c83a78265766..b7ec0dba4669 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.131 2012/07/15 17:45:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.132 2012/07/27 18:10:05 ssuominen Exp $
+
+ 27 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -files/consolekit-0.1.rc,
+ -files/consolekit-0.2.10-cleanup_console_tags.patch,
+ -files/consolekit-0.4.0-multilib.patch,
+ -files/consolekit-0.4.0-polkit-automagic.patch,
+ -files/consolekit-0.4.1-shutdown-reboot-without-policies.patch,
+ -consolekit-0.4.5-r1.ebuild:
+ old
15 Jul 2012; Raúl Porcel <armin76@gentoo.org>
consolekit-0.4.5_p20120320.ebuild:
diff --git a/sys-auth/consolekit/consolekit-0.4.5-r1.ebuild b/sys-auth/consolekit/consolekit-0.4.5-r1.ebuild
deleted file mode 100644
index ca39d964d8bb..000000000000
--- a/sys-auth/consolekit/consolekit-0.4.5-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.5-r1.ebuild,v 1.10 2012/06/30 10:35:54 swift Exp $
-
-EAPI=4
-inherit autotools eutils linux-info multilib pam systemd
-
-MY_PN=ConsoleKit
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Framework for defining and tracking users, login sessions and seats."
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/ConsoleKit"
-SRC_URI="http://www.freedesktop.org/software/${MY_PN}/dist/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="debug doc kernel_linux pam policykit selinux test"
-
-RDEPEND=">=dev-libs/dbus-glib-0.88
- >=dev-libs/glib-2.20:2
- sys-libs/zlib
- x11-libs/libX11
- pam? ( virtual/pam )
- policykit? ( >=sys-auth/polkit-0.101-r1 )
- selinux? ( sec-policy/selinux-consolekit )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-libs/libxslt
- doc? ( app-text/xmlto )
- test? ( app-text/docbook-xml-dtd:4.1.2 )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- # This is required to get login-session-id string with pam_ck_connector.so
- if use pam && use kernel_linux; then
- CONFIG_CHECK="~AUDITSYSCALL"
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-0.2.10-cleanup_console_tags.patch \
- "${FILESDIR}"/${PN}-0.4.0-polkit-automagic.patch \
- "${FILESDIR}"/${PN}-0.4.0-multilib.patch \
- "${FILESDIR}"/${PN}-0.4.1-shutdown-reboot-without-policies.patch
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- XMLTO_FLAGS="--skip-validation" \
- --localstatedir="${EPREFIX}"/var \
- $(use_enable pam pam-module) \
- $(use_enable doc docbook-docs) \
- $(use_enable debug) \
- $(use_enable policykit polkit) \
- --with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
- --with-pam-module-dir=$(getpam_mod_dir) \
- "$(systemd_with_unitdir)"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- htmldocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
- install
-
- dodoc AUTHORS ChangeLog HACKING NEWS README TODO
-
- newinitd "${FILESDIR}"/${PN}-0.1.rc consolekit
-
- keepdir /usr/$(get_libdir)/ConsoleKit/run-seat.d
- keepdir /usr/$(get_libdir)/ConsoleKit/run-session.d
- keepdir /etc/ConsoleKit/run-session.d
- keepdir /var/run/ConsoleKit
- keepdir /var/log/ConsoleKit
-
- exeinto /etc/X11/xinit/xinitrc.d
- newexe "${FILESDIR}"/90-consolekit-3 90-consolekit
-
- exeinto /usr/$(get_libdir)/ConsoleKit/run-session.d
- doexe "${FILESDIR}"/pam-foreground-compat.ck
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-}
-
-pkg_postinst() {
- ewarn "You need to restart ConsoleKit to get the new features."
- ewarn "This can be done with /etc/init.d/consolekit restart"
- ewarn "but make sure you do this and then restart your session"
- ewarn "otherwise you will get access denied for certain actions"
-}
diff --git a/sys-auth/consolekit/files/consolekit-0.1.rc b/sys-auth/consolekit/files/consolekit-0.1.rc
deleted file mode 100644
index d469b46343ef..000000000000
--- a/sys-auth/consolekit/files/consolekit-0.1.rc
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/files/consolekit-0.1.rc,v 1.2 2009/09/12 19:46:19 nirbheek Exp $
-
-depend() {
- need dbus
- use logger
-}
-
-start() {
- ebegin "Starting ConsoleKit daemon"
-
- start-stop-daemon --start -q \
- --pidfile /var/run/ConsoleKit/pid \
- --exec /usr/sbin/console-kit-daemon --
- eend $?
-}
-
-stop() {
- ebegin "Stopping ConsoleKit daemon"
- start-stop-daemon --stop -q --pidfile /var/run/ConsoleKit/pid
- eend $?
-}
diff --git a/sys-auth/consolekit/files/consolekit-0.2.10-cleanup_console_tags.patch b/sys-auth/consolekit/files/consolekit-0.2.10-cleanup_console_tags.patch
deleted file mode 100644
index 4dbd62575949..000000000000
--- a/sys-auth/consolekit/files/consolekit-0.2.10-cleanup_console_tags.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-# Clean up at_console compat files, bug #257761
-# http://patches.ubuntu.com/by-release/extracted/ubuntu/c/consolekit/0.2.10-1ubuntu9/
---- a/src/main.c 2008-07-25 03:19:34.000000000 +0200
-+++ b/src/main.c 2008-07-26 00:25:13.000000000 +0200
-@@ -149,6 +149,43 @@
- unlink (CONSOLE_KIT_PID_FILE);
- }
-
-+#define CONSOLE_TAGS_DIR "/var/run/console"
-+
-+static void
-+delete_console_tags (void)
-+{
-+ GDir *dir;
-+ GError *error = NULL;
-+ const gchar *name;
-+
-+ g_debug ("Cleaning up %s", CONSOLE_TAGS_DIR);
-+
-+ dir = g_dir_open (CONSOLE_TAGS_DIR, 0, &error);
-+ if (dir == NULL) {
-+ g_debug ("Couldn't open directory %s: %s", CONSOLE_TAGS_DIR,
-+ error->message);
-+ g_error_free (error);
-+ return;
-+ }
-+ while ((name = g_dir_read_name (dir)) != NULL) {
-+ gchar *file;
-+ file = g_build_filename (CONSOLE_TAGS_DIR, name, NULL);
-+
-+ g_debug ("Removing tag file: %s", file);
-+ if (unlink (file) == -1) {
-+ g_warning ("Couldn't delete tag file: %s", file);
-+ }
-+ g_free (file);
-+ }
-+}
-+
-+static void
-+cleanup (void)
-+{
-+ delete_console_tags ();
-+ delete_pid ();
-+}
-+
- /* copied from nautilus */
- static int debug_log_pipes[2];
-
-@@ -229,7 +266,7 @@
- snprintf (pid, sizeof (pid), "%lu\n", (long unsigned) getpid ());
- written = write (pf, pid, strlen (pid));
- close (pf);
-- g_atexit (delete_pid);
-+ g_atexit (cleanup);
- } else {
- g_warning ("Unable to write pid file %s: %s",
- CONSOLE_KIT_PID_FILE,
-@@ -312,6 +349,8 @@
-
- g_debug ("initializing console-kit-daemon %s", VERSION);
-
-+ delete_console_tags ();
-+
- create_pid_file ();
-
- manager = ck_manager_new ();
diff --git a/sys-auth/consolekit/files/consolekit-0.4.0-multilib.patch b/sys-auth/consolekit/files/consolekit-0.4.0-multilib.patch
deleted file mode 100644
index b898353d8f2e..000000000000
--- a/sys-auth/consolekit/files/consolekit-0.4.0-multilib.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-From c4ba8b276bf95faf2f643e42988709ed6cb0b2f0 Mon Sep 17 00:00:00 2001
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Sun, 18 Oct 2009 23:30:36 +0200
-Subject: [PATCH] respect multilib
-
----
- src/Makefile.am | 4 ++--
- src/ck-manager.c | 4 ++--
- src/ck-seat.c | 2 +-
- src/ck-session.c | 2 +-
- tools/freebsd/Makefile.am | 2 +-
- tools/linux/Makefile.am | 2 +-
- tools/solaris/Makefile.am | 2 +-
- 7 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 6ab05c8..d6fb810 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -204,8 +204,8 @@ MAINTAINERCLEANFILES = \
-
- install-data-local:
- -mkdir -p $(DESTDIR)$(sysconfdir)/ConsoleKit/run-session.d
-- -mkdir -p $(DESTDIR)$(prefix)/lib/ConsoleKit/run-session.d
-+ -mkdir -p $(DESTDIR)$(libdir)/ConsoleKit/run-session.d
- -mkdir -p $(DESTDIR)$(sysconfdir)/ConsoleKit/run-seat.d
-- -mkdir -p $(DESTDIR)$(prefix)/lib/ConsoleKit/run-seat.d
-+ -mkdir -p $(DESTDIR)$(libdir)/ConsoleKit/run-seat.d
- -mkdir -p $(DESTDIR)$(localstatedir)/run/ConsoleKit
- -mkdir -p $(DESTDIR)$(localstatedir)/log/ConsoleKit
-diff --git a/src/ck-manager.c b/src/ck-manager.c
-index 99693a3..e65e25b 100644
---- a/src/ck-manager.c
-+++ b/src/ck-manager.c
-@@ -1083,7 +1083,7 @@ do_restart (CkManager *manager,
- log_system_restart_event (manager);
-
- error = NULL;
-- res = g_spawn_command_line_async (PREFIX "/lib/ConsoleKit/scripts/ck-system-restart",
-+ res = g_spawn_command_line_async (LIBDIR "/ConsoleKit/scripts/ck-system-restart",
- &error);
- if (! res) {
- GError *new_error;
-@@ -1164,7 +1164,7 @@ do_stop (CkManager *manager,
- log_system_stop_event (manager);
-
- error = NULL;
-- res = g_spawn_command_line_async (PREFIX "/lib/ConsoleKit/scripts/ck-system-stop",
-+ res = g_spawn_command_line_async (LIBDIR "/ConsoleKit/scripts/ck-system-stop",
- &error);
- if (! res) {
- GError *new_error;
-diff --git a/src/ck-seat.c b/src/ck-seat.c
-index af7db59..d089f29 100644
---- a/src/ck-seat.c
-+++ b/src/ck-seat.c
-@@ -1278,7 +1278,7 @@ ck_seat_run_programs (CkSeat *seat,
- g_assert(n <= G_N_ELEMENTS(extra_env));
-
- ck_run_programs (SYSCONFDIR "/ConsoleKit/run-seat.d", action, extra_env);
-- ck_run_programs (PREFIX "/lib/ConsoleKit/run-seat.d", action, extra_env);
-+ ck_run_programs (LIBDIR "/ConsoleKit/run-seat.d", action, extra_env);
-
- for (n = 0; extra_env[n] != NULL; n++) {
- g_free (extra_env[n]);
-diff --git a/src/ck-session.c b/src/ck-session.c
-index d8db9dd..c2fc320 100644
---- a/src/ck-session.c
-+++ b/src/ck-session.c
-@@ -1287,7 +1287,7 @@ ck_session_run_programs (CkSession *session,
- g_assert(n <= G_N_ELEMENTS(extra_env));
-
- ck_run_programs (SYSCONFDIR "/ConsoleKit/run-session.d", action, extra_env);
-- ck_run_programs (PREFIX "/lib/ConsoleKit/run-session.d", action, extra_env);
-+ ck_run_programs (LIBDIR "/ConsoleKit/run-session.d", action, extra_env);
-
- for (n = 0; extra_env[n] != NULL; n++) {
- g_free (extra_env[n]);
-diff --git a/tools/freebsd/Makefile.am b/tools/freebsd/Makefile.am
-index f668722..d25930e 100644
---- a/tools/freebsd/Makefile.am
-+++ b/tools/freebsd/Makefile.am
-@@ -6,7 +6,7 @@ NULL =
- SUBDIRS = \
- $(NULL)
-
--scriptdir = $(prefix)/lib/ConsoleKit/scripts
-+scriptdir = $(libdir)/ConsoleKit/scripts
- script_SCRIPTS = \
- ck-system-stop \
- ck-system-restart \
-diff --git a/tools/linux/Makefile.am b/tools/linux/Makefile.am
-index 5a95942..51196c0 100644
---- a/tools/linux/Makefile.am
-+++ b/tools/linux/Makefile.am
-@@ -6,7 +6,7 @@ NULL =
- SUBDIRS = \
- $(NULL)
-
--scriptdir = $(prefix)/lib/ConsoleKit/scripts
-+scriptdir = $(libdir)/ConsoleKit/scripts
- script_SCRIPTS = \
- ck-system-stop \
- ck-system-restart \
-diff --git a/tools/solaris/Makefile.am b/tools/solaris/Makefile.am
-index f668722..d25930e 100644
---- a/tools/solaris/Makefile.am
-+++ b/tools/solaris/Makefile.am
-@@ -6,7 +6,7 @@ NULL =
- SUBDIRS = \
- $(NULL)
-
--scriptdir = $(prefix)/lib/ConsoleKit/scripts
-+scriptdir = $(libdir)/ConsoleKit/scripts
- script_SCRIPTS = \
- ck-system-stop \
- ck-system-restart \
---
-1.6.5.rc1
-
diff --git a/sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch b/sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch
deleted file mode 100644
index d068ca23798d..000000000000
--- a/sys-auth/consolekit/files/consolekit-0.4.0-polkit-automagic.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Automagic polkit
-
----
---- configure.ac
-+++ configure.ac
-@@ -55,10 +55,21 @@
- gthread-2.0 >= $GLIB_REQUIRED_VERSION
- )
-
--PKG_CHECK_MODULES(POLKIT,
-- polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
-- have_polkit=yes,
-- have_polkit=no)
-+AC_ARG_ENABLE([polkit],
-+ AC_HELP_STRING([--enable-polkit], [Enable PolicyKit support (default auto)]),
-+ enable_polkit=$enableval,
-+ enable_polkit=auto)
-+
-+if test "x$enable_polkit" != "xno"; then
-+ PKG_CHECK_MODULES(POLKIT,
-+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
-+ have_polkit=yes,
-+ have_polkit=no)
-+ if test "x$enable_polkit" = "xyes" -a "x$have_polkit" = "xno"; then
-+ AC_MSG_ERROR([PolicyKit support explicitly requested but dependencies not found])
-+ fi
-+fi
-+
- if test "x$have_polkit" = "xyes" ; then
- AC_DEFINE(HAVE_POLKIT, [], [Define if we have polkit])
- fi
diff --git a/sys-auth/consolekit/files/consolekit-0.4.1-shutdown-reboot-without-policies.patch b/sys-auth/consolekit/files/consolekit-0.4.1-shutdown-reboot-without-policies.patch
deleted file mode 100644
index 3183f11ece08..000000000000
--- a/sys-auth/consolekit/files/consolekit-0.4.1-shutdown-reboot-without-policies.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Romain Perier <mrpouet@gentoo.org>
-Date: Sat, 24 Oct 2009 18:43:43 +0200
-Subject: [PATCH] Be able to shutdown or reboot even without polkit or RBAC supports
-
-Ck does NOTHING at the origin if its built without polkit or RBAC supports, except
-display a warning using g_warning() (which does not make sense).
-The trick is to to call do_stop()/do_restart() in the #else directive :)
-
----
- src/ck-manager.c | 2 ++
- 1 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/src/ck-manager.c b/src/ck-manager.c
-index 99693a3..181df0d 100644
---- a/src/ck-manager.c
-+++ b/src/ck-manager.c
-@@ -1129,6 +1129,7 @@ ck_manager_restart (CkManager *manager,
- check_rbac_permissions (manager, context, do_restart);
- #else
- g_warning ("Compiled without PolicyKit or RBAC support!");
-+ do_restart(manager, context);
- #endif
-
- return TRUE;
-@@ -1200,6 +1201,7 @@ ck_manager_stop (CkManager *manager,
- check_rbac_permissions (manager, context, do_stop);
- #else
- g_warning ("Compiled without PolicyKit or RBAC support!");
-+ do_stop(manager, context);
- #endif
-
- return TRUE;
---
-1.6.5.1
-