summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2012-07-24 07:16:14 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2012-07-24 07:16:14 +0000
commit7715a63e0e60023d9aea2cbbdc81b733896b083e (patch)
treef894fa40cc6d8313ae2622db1f8f9c29d87d1759 /sys-auth
parentrecovering from cvs mistakes (diff)
downloadgentoo-2-7715a63e0e60023d9aea2cbbdc81b733896b083e.tar.gz
gentoo-2-7715a63e0e60023d9aea2cbbdc81b733896b083e.tar.bz2
gentoo-2-7715a63e0e60023d9aea2cbbdc81b733896b083e.zip
adding nss-pam-ldapd for reals this time
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-pam-ldapd/ChangeLog38
-rw-r--r--sys-auth/nss-pam-ldapd/files/nslcd-init35
-rw-r--r--sys-auth/nss-pam-ldapd/files/nslcd.rc35
-rw-r--r--sys-auth/nss-pam-ldapd/metadata.xml9
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild59
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.8.10.ebuild84
6 files changed, 260 insertions, 0 deletions
diff --git a/sys-auth/nss-pam-ldapd/ChangeLog b/sys-auth/nss-pam-ldapd/ChangeLog
new file mode 100644
index 000000000000..0da3c936a9c6
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for sys-auth/nss-pam-ldapd
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/ChangeLog,v 1.1 2012/07/24 07:16:14 prometheanfire Exp $
+
+*nss-pam-ldapd-0.8.10 (24 Jul 2012)
+*nss-pam-ldapd-0.6.7-r1 (24 Jul 2012)
+
+ 24 Jul 2012; Matthew Thode <prometheanfire@gentoo.org>
+ +nss-pam-ldapd-0.6.7-r1.ebuild, +nss-pam-ldapd-0.8.10.ebuild,
+ +files/nslcd-init:
+ moving to nss-pam-ldapd, also fixes bugs #287727 #234555
+
+*nss-ldapd-0.6.7-r1 (02 Apr 2009)
+
+ 02 Apr 2009; Doug Goldstein <cardoe@gentoo.org> -nss-ldapd-0.6.7.ebuild,
+ +nss-ldapd-0.6.7-r1.ebuild:
+ Remove world read from config file to fix security issue when using bindpw
+ field. bug #264574 CVE-2009-1073
+
+ 08 Dec 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ metadata.xml:
+ Added no-herd to metadata.
+
+ 05 Dec 2008; Doug Goldstein <cardoe@gentoo.org> files/nslcd.rc,
+ nss-ldapd-0.6.7.ebuild:
+ merge in improvements from Sunrise Overlay by Heath Caldwell
+ <hncaldwell@gentoo.org>
+
+*nss-ldapd-0.6.7 (04 Dec 2008)
+
+ 04 Dec 2008; Doug Goldstein <cardoe@gentoo.org> +files/nslcd.rc,
+ +nss-ldapd-0.6.7.ebuild:
+ add new nss-ldapd package which is a fork of nss_ldap. It simplifies the
+ code base and provides a small nss library that speaks to a local daemon
+ that does all the LDAP communication. Due to the way NSS works, this will
+ improve interaction with user programs since less code is being loaded
+ into their process space.
+
diff --git a/sys-auth/nss-pam-ldapd/files/nslcd-init b/sys-auth/nss-pam-ldapd/files/nslcd-init
new file mode 100644
index 000000000000..208f970890a1
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/files/nslcd-init
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/files/nslcd-init,v 1.1 2012/07/24 07:16:14 prometheanfire Exp $
+
+extra_commands="checkconfig"
+
+depend() {
+ need net
+ use dns logger
+}
+
+checkconfig() {
+ if [ ! -f /etc/nslcd.conf ] ; then
+ eerror "Please create /etc/nslcd.conf"
+ eerror "Example config: /usr/share/nss-ldapd/nslcd.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Starting nslcd"
+ start-stop-daemon --start --pidfile /var/run/nslcd/nslcd.pid \
+ --exec /usr/sbin/nslcd
+ eend $? "Failed to start nslcd"
+}
+
+stop() {
+ ebegin "Stopping nslcd"
+ start-stop-daemon --stop --pidfile /var/run/nslcd/nslcd.pid
+ eend $? "Failed to stop nslcd"
+}
diff --git a/sys-auth/nss-pam-ldapd/files/nslcd.rc b/sys-auth/nss-pam-ldapd/files/nslcd.rc
new file mode 100644
index 000000000000..e02d8c0c95ed
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/files/nslcd.rc
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/files/nslcd.rc,v 1.1 2012/07/24 07:16:14 prometheanfire Exp $
+
+opts="checkconfig"
+
+depend() {
+ need net
+ use dns logger
+}
+
+checkconfig() {
+ if [ ! -f /etc/nss-ldapd.conf ] ; then
+ eerror "Please create /etc/nss-ldapd.conf"
+ eerror "Example config: /usr/share/nss-ldapd/nss-ldapd.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Starting nslcd"
+ start-stop-daemon --start --pidfile /var/run/nslcd/nslcd.pid \
+ --exec /usr/sbin/nslcd
+ eend $? "Failed to start nslcd"
+}
+
+stop() {
+ ebegin "Stopping nslcd"
+ start-stop-daemon --stop --pidfile /var/run/nslcd/nslcd.pid
+ eend $? "Failed to stop nslcd"
+}
diff --git a/sys-auth/nss-pam-ldapd/metadata.xml b/sys-auth/nss-pam-ldapd/metadata.xml
new file mode 100644
index 000000000000..de55eff773c9
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild
new file mode 100644
index 000000000000..9861c90d3d50
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild,v 1.1 2012/07/24 07:16:14 prometheanfire Exp $
+
+inherit multilib
+
+DESCRIPTION="NSS module for name lookups using LDAP"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/nss-ldapd/"
+SRC_URI="http://ch.tudelft.nl/~arthur/nss-ldapd/nss-ldapd-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug kerberos sasl"
+
+DEPEND="net-nds/openldap
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )
+ !sys-auth/nss_ldap"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # nss libraries always go in /lib on Gentoo
+ econf --enable-warnings --with-ldap-lib=openldap $(use_enable debug) \
+ --libdir=/$(get_libdir) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc NEWS ChangeLog AUTHORS README
+
+ # for socket and pid file
+ keepdir /var/run/nslcd
+
+ # init script
+ newinitd "${FILESDIR}"/nslcd.rc nslcd
+
+ # make an example copy
+ insinto /usr/share/nss-ldapd
+ doins nss-ldapd.conf
+
+ fperms o-r /etc/nss-ldapd.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "For this to work you must configure /etc/nss-ldapd.conf"
+ elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
+ elog
+ elog "In order to use nss-ldapd, nslcd needs to be running. You can"
+ elog "start it like this:"
+ elog " # /etc/init.d/nslcd start"
+ elog
+ elog "You can add it to the default runlevel like so:"
+ elog " # rc-update add nslcd default"
+}
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.8.10.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.8.10.ebuild
new file mode 100644
index 000000000000..09f6f51e3f27
--- /dev/null
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.8.10.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.8.10.ebuild,v 1.1 2012/07/24 07:16:14 prometheanfire Exp $
+
+EAPI=4
+
+inherit multilib user
+
+DESCRIPTION="NSS module for name lookups using LDAP"
+HOMEPAGE="http://arthurdejong.org/nss-pam-ldapd/"
+SRC_URI="http://arthurdejong.org/nss-pam-ldapd/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug kerberos sasl +pam"
+
+DEPEND="net-nds/openldap
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )
+ !sys-auth/nss_ldap"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup nslcd
+ enewuser nslcd -1 -1 -1 nslcd
+}
+
+src_configure() {
+ # nss libraries always go in /lib on Gentoo
+ myconf="--enable-warnings
+ --with-ldap-lib=openldap
+ --with-ldap-conf-file=/etc/nslcd.conf
+ --with-nslcd-pidfile=/var/run/nslcd/nslcd.pid
+ --with-nslcd-socket=/var/run/nslcd/socket
+ --libdir=/$(get_libdir)
+ $(use_enable debug)
+ $(use_enable kerberos)
+ $(use_enable pam)"
+
+ if use x86-fbsd; then
+ myconf+=" --with-nss-flavour=freebsd"
+ else
+ myconf+=" --with-nss-flavour=glibc"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc NEWS ChangeLog AUTHORS README
+
+ # for socket and pid file
+ keepdir /var/run/nslcd
+
+ # init script
+ newinitd "${FILESDIR}"/nslcd-init nslcd
+
+ # make an example copy
+ insinto /usr/share/nss-pam-ldapd
+ doins nslcd.conf
+
+ fperms o-r /etc/nslcd.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "For this to work you must configure /etc/nslcd.conf"
+ elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
+ elog
+ elog "In order to use nss-pam-ldapd, nslcd needs to be running. You can"
+ elog "start it like this:"
+ elog " # /etc/init.d/nslcd start"
+ elog
+ elog "You can add it to the default runlevel like so:"
+ elog " # rc-update add nslcd default"
+ elog
+ elog "If you are upgrading, keep in mind that /etc/nss-ldapd.conf"
+ elog " is now named /etc/nslcd.conf"
+ elog
+}