summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:28:02 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:28:02 +0000
commit71d0ba9c5296905571495c062ddf3bb61342672c (patch)
tree661dd7f53c3cc67b743164d81ea6cca2b0345e27 /sys-auth
parentNew version for GNOME 2.28. (diff)
downloadgentoo-2-71d0ba9c5296905571495c062ddf3bb61342672c.tar.gz
gentoo-2-71d0ba9c5296905571495c062ddf3bb61342672c.tar.bz2
gentoo-2-71d0ba9c5296905571495c062ddf3bb61342672c.zip
Initial ebuild for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog12
-rw-r--r--sys-auth/polkit/files/polkit-0.92-zsh-completions.patch159
-rw-r--r--sys-auth/polkit/files/polkit-0.93-fix-daemon-name.patch221
-rw-r--r--sys-auth/polkit/metadata.xml10
-rw-r--r--sys-auth/polkit/polkit-0.94.ebuild97
5 files changed, 499 insertions, 0 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
new file mode 100644
index 000000000000..9b329b312a9a
--- /dev/null
+++ b/sys-auth/polkit/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sys-auth/polkit
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.1 2009/10/29 23:28:01 eva Exp $
+
+*polkit-0.94 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/polkit-0.92-zsh-completions.patch,
+ +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
+ +metadata.xml:
+ Initial ebuild for GNOME 2.28.
+
diff --git a/sys-auth/polkit/files/polkit-0.92-zsh-completions.patch b/sys-auth/polkit/files/polkit-0.92-zsh-completions.patch
new file mode 100644
index 000000000000..6c6e24143b32
--- /dev/null
+++ b/sys-auth/polkit/files/polkit-0.92-zsh-completions.patch
@@ -0,0 +1,159 @@
+Author: Saleem Abdulrasool <compnerd@compnerd.org>
+Date: Mon Nov 19 15:35:03 2007 -0800
+
+ add zsh completion and optionalize bash and zsh completion
+
+ Signed-off-by: Saleem Abdulrasool <compnerd@compnerd.org>
+
+
+ tools/_polkit | 54 ++++++++++++++++++++++++++++++++++++++++++++++++++
+ tools/_polkit_action | 24 ++++++++++++++++++++++
+ tools/_polkit_auth | 50 ++++++++++++++++++++++++++++++++++++++++++++++
+ 3 files changed, 128 insertions(+), 0 deletions(-)
+
+diff --git a/tools/_polkit b/tools/_polkit
+new file mode 100644
+index 0000000..bc7bdac
+--- /dev/null
++++ tools/_polkit
+@@ -0,0 +1,54 @@
++#autoload
++
++# vim: set et sw=3 sts=3 ts=3 ft=zsh:
++# ZSH Completion for polkit-auth
++# Written by Saleem Abdulrasool <compnerd@compnerd.org>
++# Usage: _polkit actions|constraints|authorization|overriden-actions|obtainable-actions|authorized-actions
++
++_polkit_actions() {
++ local actions
++ actions=( $(polkit-action) )
++ compadd "$@" -k actions
++}
++
++_polkit_constraints() {
++ local constraints
++ constraints=( local active local+active )
++ compadd "$@" -k constraints
++}
++
++_polkit_authorization() {
++ local authorization
++ authorization=( no auth_admin_one_shot auth_admin auth_admin_keep_session auth_admin_keep_always auth_self_one_shot auth_self auth_self_keep_session auth_self_keep_always yes )
++ compadd "$@" -k authorization
++}
++
++_polkit_overriden_actions() {
++ local overrides
++ overrides=( $(polkit-action --show-overrides) )
++ compadd "$@" -k overrides
++}
++
++_polkit_obtainable_actions() {
++ local actions
++ actions=( $(polkit-auth --show-obtainable) )
++ compadd "$@" -k actions
++}
++
++_polkit_authorized_actions() {
++ local actions
++ actions=( $(polkit-auth --explicit) )
++ compadd "$@" -k actions
++}
++
++_polkit() {
++ local command="$argv[$#]"
++
++ [[ "$command" == (actions|constraints|authorization|overriden-actions|obtainable-actions|authorized-actions) ]] || {
++ _message "unknown command: $command"
++ }
++
++ _polkit_${command/-/_}
++}
++
++_polkit "$@"
+diff --git a/tools/_polkit_action b/tools/_polkit_action
+new file mode 100644
+index 0000000..7ec7365
+--- /dev/null
++++ tools/_polkit_action
+@@ -0,0 +1,24 @@
++#compdef polkit-action
++
++# vim: set et sw=3 sts=3 ts=3 ft=zsh:
++# ZSH Completion for polkit-action
++# Written by Saleem Abdulrasool <compnerd@compnerd.org>
++
++_polkit_action() {
++ local arguments
++
++ arguments=(
++ "(-)--action[Show detailed information about a specific action]:action:_polkit actions"
++ "(-)--reset-defaults[Reset the defaults for the specified action]:Overridden Action:_polkit overriden-actions"
++ "(-)--show-overrides[List actions where the defaults are overridden]"
++ "(-)--set-defaults-any[Override the any stanza for an action]:Action:_polkit _actions:Authorization:_polkit authorization"
++ "(-)--set-defaults-inactive[Override the inactive stanza for an action]:Action:polkit _actions:Authorization:_polkit authorization"
++ "(-)--set-defaults-active[Override the active stanza for an action]:Action:polkit _actions:Authorization:_polkit authorization"
++ "(-)--version[Display program version]"
++ "(-)--help[Display program help]"
++ )
++
++ _arguments $arguments
++}
++
++_polkit_action "$@"
+diff --git a/tools/_polkit_auth b/tools/_polkit_auth
+new file mode 100644
+index 0000000..e70f1a0
+--- /dev/null
++++ tools/_polkit_auth
+@@ -0,0 +1,50 @@
++#compdef polkit-auth
++
++# vim: set et sw=3 sts=3 ts=3 ft=zsh:
++# ZSH Completion for polkit-auth
++# Written by Saleem Abdulrasool <compnerd@compnerd.org>
++
++_polkit_auth() {
++ local arguments action_arguments user_arguments grant_arguments
++ local commands actions grant=0
++
++ commands=( --show-obtainable --version --help )
++ actions=( --obtain --explicit --explicit-detail --grant --revoke )
++
++ for (( i = 0 ; i < ${#words[@]} ; i++ )) ; do
++ if [[ "${words[$i]##--#}" == "grant" ]] ; then
++ grant=1
++ break
++ fi
++ done
++
++ arguments=(
++ '(-)--show-obtainable[Show all actions that can be obtained via authentication]'
++ '(-)--version[Show version and exit]'
++ '(-)--help[Show help information]'
++ )
++
++ action_arguments=(
++ "($commands $actions)--obtain[Attempt to obtain authorization to do an action]:Obtainable Actions:_polkit obtainable-actions"
++ "($commands $actions)--explicit[Show explicit authorizations]"
++ "($commands $actions)--explicit-detail[Show detailed information about explicit authorizations]"
++ "($commands $actions)--grant[Grant an authorization for an action]:Obtainable Actions:_polkit actions"
++ "($commands $actions)--revoke[Revoke all authorization for an action]:Authorized Actions:_polkit authorized-actions"
++ )
++
++ user_arguments=(
++ "($commands)--user[The user the authorization applies to]:User:_users"
++ )
++
++ grant_arguments=(
++ "($commands)--constraint[Optional constraints on the granted authorization]:Constraint:_polkit constraints"
++ )
++
++ if [[ grant -eq 1 ]] ; then
++ _arguments $arguments $user_arguments $action_arguments $grant_arguments
++ else
++ _arguments $arguments $user_arguments $action_arguments
++ fi
++}
++
++_polkit_auth "$@"
diff --git a/sys-auth/polkit/files/polkit-0.93-fix-daemon-name.patch b/sys-auth/polkit/files/polkit-0.93-fix-daemon-name.patch
new file mode 100644
index 000000000000..e8b467e934b9
--- /dev/null
+++ b/sys-auth/polkit/files/polkit-0.93-fix-daemon-name.patch
@@ -0,0 +1,221 @@
+Fix daemon binary collision with <=policykit-0.9
+
+https://bugs.freedesktop.org/show_bug.cgi?id=22951
+
+--
+--- data/org.freedesktop.PolicyKit1.service.in
++++ data/org.freedesktop.PolicyKit1.service.in
+@@ -1,4 +1,4 @@
+ [D-BUS Service]
+ Name=org.freedesktop.PolicyKit1
+-Exec=@libexecdir@/polkitd
++Exec=@libexecdir@/polkitd-1
+ User=root
+--- docs/man/Makefile.am
++++ docs/man/Makefile.am
+@@ -5,7 +5,7 @@
+
+ man_MANS = \
+ polkit.8 \
+- polkitd.8 \
++ polkitd-1.8 \
+ pklocalauthority.8 \
+ pkexec.1 \
+ pkcheck.1 \
+@@ -19,7 +19,7 @@
+
+ EXTRA_DIST = \
+ polkit.xml \
+- polkitd.xml \
++ polkitd-1.xml \
+ pklocalauthority.xml \
+ pkexec.xml \
+ pkcheck.xml \
+--- docs/man/polkitd-1.xml
++++ docs/man/polkitd-1.xml
+@@ -0,0 +1,67 @@
++<?xml version="1.0"?>
++<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
++ "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
++<!ENTITY version SYSTEM "../version.xml">
++]>
++<refentry id="polkitd-1.8">
++ <refentryinfo>
++ <title>polkitd-1</title>
++ <date>May 2009</date>
++ <productname>polkit</productname>
++ </refentryinfo>
++
++ <refmeta>
++ <refentrytitle>polkitd-1</refentrytitle>
++ <manvolnum>8</manvolnum>
++ <refmiscinfo class="version"></refmiscinfo>
++ </refmeta>
++
++ <refnamediv>
++ <refname>polkitd-1</refname>
++ <refpurpose>PolicyKit daemon</refpurpose>
++ </refnamediv>
++
++ <refsynopsisdiv>
++ <cmdsynopsis>
++ <command>polkitd-1</command>
++ </cmdsynopsis>
++ </refsynopsisdiv>
++
++ <refsect1 id="polkitd-1-description"><title>DESCRIPTION</title>
++ <para>
++ <command>polkitd-1</command> provides
++ the <emphasis>org.freedesktop.PolicyKit1</emphasis> D-Bus
++ service on the system message bus. Users or administrators
++ should never need to start this daemon as it will be
++ automatically started by
++ <citerefentry><refentrytitle>dbus-daemon</refentrytitle><manvolnum>1</manvolnum></citerefentry>
++ whenever an application calls into the service.
++ </para>
++ </refsect1>
++
++ <refsect1 id="polkitd-1-author"><title>AUTHOR</title>
++ <para>
++ Written by David Zeuthen <email>davidz@redhat.com</email> with
++ a lot of help from many others.
++ </para>
++ </refsect1>
++
++ <refsect1 id="polkitd-1-bugs">
++ <title>BUGS</title>
++ <para>
++ Please send bug reports to either the distribution or the
++ polkit-devel mailing list,
++ see the link <ulink url="http://lists.freedesktop.org/mailman/listinfo/polkit-devel"/>
++ on how to subscribe.
++ </para>
++ </refsect1>
++
++ <refsect1 id="polkitd-1-see-also">
++ <title>SEE ALSO</title>
++ <para>
++ <citerefentry>
++ <refentrytitle>polkit</refentrytitle><manvolnum>8</manvolnum>
++ </citerefentry>
++ </para>
++ </refsect1>
++</refentry>
+--- docs/man/polkitd.xml
++++ docs/man/polkitd.xml
+@@ -1,67 +0,0 @@
+-<?xml version="1.0"?>
+-<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
+- "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+-<!ENTITY version SYSTEM "../version.xml">
+-]>
+-<refentry id="polkitd.8">
+- <refentryinfo>
+- <title>polkitd</title>
+- <date>May 2009</date>
+- <productname>polkit</productname>
+- </refentryinfo>
+-
+- <refmeta>
+- <refentrytitle>polkitd</refentrytitle>
+- <manvolnum>8</manvolnum>
+- <refmiscinfo class="version"></refmiscinfo>
+- </refmeta>
+-
+- <refnamediv>
+- <refname>polkitd</refname>
+- <refpurpose>PolicyKit daemon</refpurpose>
+- </refnamediv>
+-
+- <refsynopsisdiv>
+- <cmdsynopsis>
+- <command>polkitd</command>
+- </cmdsynopsis>
+- </refsynopsisdiv>
+-
+- <refsect1 id="polkitd-description"><title>DESCRIPTION</title>
+- <para>
+- <command>polkitd</command> provides
+- the <emphasis>org.freedesktop.PolicyKit1</emphasis> D-Bus
+- service on the system message bus. Users or administrators
+- should never need to start this daemon as it will be
+- automatically started by
+- <citerefentry><refentrytitle>dbus-daemon</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+- whenever an application calls into the service.
+- </para>
+- </refsect1>
+-
+- <refsect1 id="polkitd-author"><title>AUTHOR</title>
+- <para>
+- Written by David Zeuthen <email>davidz@redhat.com</email> with
+- a lot of help from many others.
+- </para>
+- </refsect1>
+-
+- <refsect1 id="polkitd-bugs">
+- <title>BUGS</title>
+- <para>
+- Please send bug reports to either the distribution or the
+- polkit-devel mailing list,
+- see the link <ulink url="http://lists.freedesktop.org/mailman/listinfo/polkit-devel"/>
+- on how to subscribe.
+- </para>
+- </refsect1>
+-
+- <refsect1 id="polkitd-see-also">
+- <title>SEE ALSO</title>
+- <para>
+- <citerefentry>
+- <refentrytitle>polkit</refentrytitle><manvolnum>8</manvolnum>
+- </citerefentry>
+- </para>
+- </refsect1>
+-</refentry>
+--- docs/man/polkit.xml
++++ docs/man/polkit.xml
+@@ -424,7 +424,7 @@
+ <refentrytitle>pklocalauthority</refentrytitle><manvolnum>8</manvolnum>
+ </citerefentry>
+ <citerefentry>
+- <refentrytitle>polkitd</refentrytitle><manvolnum>8</manvolnum>
++ <refentrytitle>polkitd-1</refentrytitle><manvolnum>8</manvolnum>
+ </citerefentry>
+ <citerefentry>
+ <refentrytitle>pkaction</refentrytitle><manvolnum>1</manvolnum>
+--- docs/polkit/Makefile.am
++++ docs/polkit/Makefile.am
+@@ -60,7 +60,7 @@
+ ../../src/polkit/docbook-interface-org.freedesktop.PolicyKit1.Authority.xml \
+ ../../src/polkit/docbook-interface-org.freedesktop.PolicyKit1.AuthenticationAgent.xml \
+ ../man/polkit.xml \
+- ../man/polkitd.xml \
++ ../man/polkitd-1.xml \
+ ../man/pklocalauthority.xml \
+ ../man/pkcheck.xml \
+ ../man/pkaction.xml \
+--- src/polkitd/Makefile.am
++++ src/polkitd/Makefile.am
+@@ -14,19 +14,19 @@
+ -D_REENTRANT \
+ $(NULL)
+
+-libexec_PROGRAMS = polkitd
++libexec_PROGRAMS = polkitd-1
+
+-polkitd_SOURCES = \
++polkitd_1_SOURCES = \
+ main.c \
+ $(NULL)
+
+-polkitd_CFLAGS = \
++polkitd_1_CFLAGS = \
+ -DPOLKIT_BACKEND_I_KNOW_API_IS_SUBJECT_TO_CHANGE \
+ -DG_LOG_DOMAIN=\"polkitd-1\" \
+ $(GLIB_CFLAGS) \
+ $(NULL)
+
+-polkitd_LDADD = \
++polkitd_1_LDADD = \
+ $(DBUS_GLIB_LIBS) \
+ $(GLIB_LIBS) \
+ $(top_builddir)/src/polkit/libpolkit-gobject-1.la \
diff --git a/sys-auth/polkit/metadata.xml b/sys-auth/polkit/metadata.xml
new file mode 100644
index 000000000000..5f2c7e524af6
--- /dev/null
+++ b/sys-auth/polkit/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nirbheek@gentoo.org</email>
+ <name>Nirbheek Chauhan</name>
+ </maintainer>
+ <herd>freedesktop</herd>
+</pkgmetadata>
+
diff --git a/sys-auth/polkit/polkit-0.94.ebuild b/sys-auth/polkit/polkit-0.94.ebuild
new file mode 100644
index 000000000000..2fca33336ba9
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.94.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.94.ebuild,v 1.1 2009/10/29 23:28:01 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils multilib pam
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="http://hal.freedesktop.org/docs/PolicyKit"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc expat pam zsh-completion nls"
+# introspection
+
+# not mature enough
+# introspection? ( dev-libs/gobject-introspection )
+RDEPEND=">=dev-libs/glib-2.21.4
+ >=dev-libs/eggdbus-0.5
+ expat? ( dev-libs/expat )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ !!>=sys-auth/policykit-0.92
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.36
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+
+pkg_setup() {
+ enewgroup polkituser
+ enewuser polkituser -1 "-1" /dev/null polkituser
+}
+
+src_prepare() {
+ # Add zsh completions
+ if use zsh-completion; then
+ epatch "${FILESDIR}/${PN}-0.92-zsh-completions.patch"
+ fi
+
+ # Fix daemon binary collision with <=policykit-0.9, fdo bug 22951
+ epatch "${FILESDIR}/${PN}-0.93-fix-daemon-name.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_configure() {
+ local conf
+
+ if use pam ; then
+ conf="--with-authfw=pam --with-pam-module-dir=$(getpam_mod_dir)"
+ else
+ conf="--with-authfw=none"
+ fi
+
+ if use expat; then
+ conf="--with-expat=/usr"
+ fi
+
+ econf ${conf} \
+ --disable-introspection \
+ --disable-ansi \
+ --enable-fast-install \
+ --enable-libtool-lock \
+ --enable-man-pages \
+ --disable-dependency-tracking \
+ --with-os-type=gentoo \
+ --with-polkit-user=polkituser \
+ --localstatedir=/var \
+ $(use_enable debug verbose-mode) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls)
+ #$(use_enable introspection)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc NEWS README AUTHORS ChangeLog || die "dodoc failed"
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins "${S}/tools/_polkit" || die "zsh completion died"
+ doins "${S}/tools/_polkit_auth" || die "zsh completion died"
+ doins "${S}/tools/_polkit_action" || die "zsh completion died"
+ fi
+
+ # Need to keep a few directories around...
+ diropts -m0700 -o root -g polkituser
+ keepdir /var/run/polkit-1
+ keepdir /var/lib/polkit-1
+}