summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-24 10:17:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-24 10:17:35 +0000
commit59cd32c8a93ceb23ecc347a9fc00d360dedd2c2b (patch)
treec30602c411ed3e2417d772753e32052c2c2cb455 /sys-auth
parentUSE="static-libs" and convert to prune_libtool_files() function. Remove -Werr... (diff)
downloadgentoo-2-59cd32c8a93ceb23ecc347a9fc00d360dedd2c2b.tar.gz
gentoo-2-59cd32c8a93ceb23ecc347a9fc00d360dedd2c2b.tar.bz2
gentoo-2-59cd32c8a93ceb23ecc347a9fc00d360dedd2c2b.zip
USE="static-libs" and convert to prune_libtool_files() function. Remove -Werror from AM_INIT_AUTOMAKE for compability with sys-devel/automake >= 1.12.
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ykpers/ChangeLog7
-rw-r--r--sys-auth/ykpers/ykpers-1.3.4.ebuild21
2 files changed, 19 insertions, 9 deletions
diff --git a/sys-auth/ykpers/ChangeLog b/sys-auth/ykpers/ChangeLog
index a0aba97b9e41..6d4b8867f39f 100644
--- a/sys-auth/ykpers/ChangeLog
+++ b/sys-auth/ykpers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/ykpers
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.4 2012/06/12 11:52:06 iksaif Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.5 2012/06/24 10:17:35 ssuominen Exp $
+
+ 24 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> ykpers-1.3.4.ebuild:
+ USE="static-libs" and convert to prune_libtool_files() function. Remove
+ -Werror from AM_INIT_AUTOMAKE for compability with sys-devel/automake >=
+ 1.12.
12 Jun 2012; Corentin Chary <iksaif@gentoo.org> ykpers-1.3.4.ebuild:
Fix HOMEPAGE
diff --git a/sys-auth/ykpers/ykpers-1.3.4.ebuild b/sys-auth/ykpers/ykpers-1.3.4.ebuild
index 0f072527a51f..bb0674c78127 100644
--- a/sys-auth/ykpers/ykpers-1.3.4.ebuild
+++ b/sys-auth/ykpers/ykpers-1.3.4.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.3.4.ebuild,v 1.4 2012/06/12 11:52:06 iksaif Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.3.4.ebuild,v 1.5 2012/06/24 10:17:35 ssuominen Exp $
-EAPI=2
-inherit eutils autotools
+EAPI=4
+inherit autotools eutils
DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
-SRC_URI="http://yubikey-personalization.googlecode.com/files/${P}.tar.gz"
HOMEPAGE="http://code.google.com/p/yubikey-personalization"
+SRC_URI="http://yubikey-personalization.googlecode.com/files/${P}.tar.gz"
KEYWORDS="~amd64"
SLOT="0"
LICENSE="BSD-2"
-IUSE=""
+IUSE="static-libs"
RDEPEND=">=sys-auth/libyubikey-1.6
virtual/libusb:1"
@@ -21,11 +21,16 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-rpath.patch
+ sed -i -e '/AM_INIT_AUTOMAKE/s: -Werror::' configure.ac || die #423255
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README doc/* || die
- find "${D}" -name '*.la' -delete || die
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README doc/*
+ prune_libtool_files
}