summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-14 05:35:27 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-14 05:35:27 +0000
commit586b5cd69d7409bfb12962d5162a907e01747626 (patch)
treea10f4b4fe83e693f6189a8f1c874ab0c65cb6ed7 /sys-auth
parentFix building with newer glibc #246734 by Diego E. Pettenò. (diff)
downloadgentoo-2-586b5cd69d7409bfb12962d5162a907e01747626.tar.gz
gentoo-2-586b5cd69d7409bfb12962d5162a907e01747626.tar.bz2
gentoo-2-586b5cd69d7409bfb12962d5162a907e01747626.zip
Cleanup multilib handling and fix building with newer glibc #241318 by Diego E. Pettenò.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/icmpdn/ChangeLog8
-rw-r--r--sys-auth/icmpdn/icmpdn-0.4.ebuild20
2 files changed, 15 insertions, 13 deletions
diff --git a/sys-auth/icmpdn/ChangeLog b/sys-auth/icmpdn/ChangeLog
index 67713d342d37..9ca5e6e67fb2 100644
--- a/sys-auth/icmpdn/ChangeLog
+++ b/sys-auth/icmpdn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/icmpdn
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/icmpdn/ChangeLog,v 1.2 2007/02/22 01:00:28 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/icmpdn/ChangeLog,v 1.3 2009/01/14 05:35:27 vapier Exp $
+
+ 14 Jan 2009; Mike Frysinger <vapier@gentoo.org> icmpdn-0.4.ebuild:
+ Cleanup multilib handling and fix building with newer glibc #241318 by
+ Diego E. Pettenò.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-auth/icmpdn/icmpdn-0.4.ebuild b/sys-auth/icmpdn/icmpdn-0.4.ebuild
index 9eb0e5c995b9..6af7961f855e 100644
--- a/sys-auth/icmpdn/icmpdn-0.4.ebuild
+++ b/sys-auth/icmpdn/icmpdn-0.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/icmpdn/icmpdn-0.4.ebuild,v 1.2 2007/07/15 02:34:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/icmpdn/icmpdn-0.4.ebuild,v 1.3 2009/01/14 05:35:27 vapier Exp $
-inherit eutils
+inherit eutils flag-o-matic multilib
DESCRIPTION="ICMP Domain Name utilities & NSS backend"
HOMEPAGE="http://www.dolda2000.com/~fredrik/icmp-dn/"
@@ -12,27 +12,25 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="sys-libs/glibc"
-RDEPEND="${DEPEND}"
src_compile() {
- LDFLAGS='-Wl,-z,now' \
- econf \
+ append-cppflags -D_GNU_SOURCE #241318
+ econf \
--sysconfdir=/etc \
- --libdir=/lib \
+ --libdir=/$(get_libdir) \
|| die "econf failed"
emake || die "emake failed"
}
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
- newinitd ${FILESDIR}/init.d-icmpdnd icmpdnd
- newconfd ${FILESDIR}/conf.d-icmpdnd icmpdnd
+ newinitd "${FILESDIR}"/init.d-icmpdnd icmpdnd
+ newconfd "${FILESDIR}"/conf.d-icmpdnd icmpdnd
dodoc AUTHORS ChangeLog README
# must always run as root
fperms 4711 /usr/bin/idnlookup
# useless as nothing should link against this lib
- rm ${D}/lib/*.la
+ rm "${D}"/lib*/*.{la,so}
}
pkg_postinst() {