summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-10-30 17:31:05 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-10-30 17:31:05 +0000
commit544e56634933055424ee255ea2bd23b51b24e0ba (patch)
tree5c05f6de78903dc01ccfa7c8a929517e9c37bb6f /sys-auth
parentStable for HPPA (bug #290664). (diff)
downloadgentoo-2-544e56634933055424ee255ea2bd23b51b24e0ba.tar.gz
gentoo-2-544e56634933055424ee255ea2bd23b51b24e0ba.tar.bz2
gentoo-2-544e56634933055424ee255ea2bd23b51b24e0ba.zip
Remove zsh-completion (bug 291114), force pam support on (bug 291116)
(Portage version: 2.1.7.1/cvs/Linux i686)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog6
-rw-r--r--sys-auth/polkit/files/polkit-0.92-zsh-completions.patch159
-rw-r--r--sys-auth/polkit/polkit-0.94.ebuild33
3 files changed, 14 insertions, 184 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 9b329b312a9a..2686c09db270 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.1 2009/10/29 23:28:01 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.2 2009/10/30 17:31:04 nirbheek Exp $
+
+ 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
+ Remove zsh-completion (bug 291114), force pam support on (bug 291116)
*polkit-0.94 (29 Oct 2009)
diff --git a/sys-auth/polkit/files/polkit-0.92-zsh-completions.patch b/sys-auth/polkit/files/polkit-0.92-zsh-completions.patch
deleted file mode 100644
index 6c6e24143b32..000000000000
--- a/sys-auth/polkit/files/polkit-0.92-zsh-completions.patch
+++ /dev/null
@@ -1,159 +0,0 @@
-Author: Saleem Abdulrasool <compnerd@compnerd.org>
-Date: Mon Nov 19 15:35:03 2007 -0800
-
- add zsh completion and optionalize bash and zsh completion
-
- Signed-off-by: Saleem Abdulrasool <compnerd@compnerd.org>
-
-
- tools/_polkit | 54 ++++++++++++++++++++++++++++++++++++++++++++++++++
- tools/_polkit_action | 24 ++++++++++++++++++++++
- tools/_polkit_auth | 50 ++++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 128 insertions(+), 0 deletions(-)
-
-diff --git a/tools/_polkit b/tools/_polkit
-new file mode 100644
-index 0000000..bc7bdac
---- /dev/null
-+++ tools/_polkit
-@@ -0,0 +1,54 @@
-+#autoload
-+
-+# vim: set et sw=3 sts=3 ts=3 ft=zsh:
-+# ZSH Completion for polkit-auth
-+# Written by Saleem Abdulrasool <compnerd@compnerd.org>
-+# Usage: _polkit actions|constraints|authorization|overriden-actions|obtainable-actions|authorized-actions
-+
-+_polkit_actions() {
-+ local actions
-+ actions=( $(polkit-action) )
-+ compadd "$@" -k actions
-+}
-+
-+_polkit_constraints() {
-+ local constraints
-+ constraints=( local active local+active )
-+ compadd "$@" -k constraints
-+}
-+
-+_polkit_authorization() {
-+ local authorization
-+ authorization=( no auth_admin_one_shot auth_admin auth_admin_keep_session auth_admin_keep_always auth_self_one_shot auth_self auth_self_keep_session auth_self_keep_always yes )
-+ compadd "$@" -k authorization
-+}
-+
-+_polkit_overriden_actions() {
-+ local overrides
-+ overrides=( $(polkit-action --show-overrides) )
-+ compadd "$@" -k overrides
-+}
-+
-+_polkit_obtainable_actions() {
-+ local actions
-+ actions=( $(polkit-auth --show-obtainable) )
-+ compadd "$@" -k actions
-+}
-+
-+_polkit_authorized_actions() {
-+ local actions
-+ actions=( $(polkit-auth --explicit) )
-+ compadd "$@" -k actions
-+}
-+
-+_polkit() {
-+ local command="$argv[$#]"
-+
-+ [[ "$command" == (actions|constraints|authorization|overriden-actions|obtainable-actions|authorized-actions) ]] || {
-+ _message "unknown command: $command"
-+ }
-+
-+ _polkit_${command/-/_}
-+}
-+
-+_polkit "$@"
-diff --git a/tools/_polkit_action b/tools/_polkit_action
-new file mode 100644
-index 0000000..7ec7365
---- /dev/null
-+++ tools/_polkit_action
-@@ -0,0 +1,24 @@
-+#compdef polkit-action
-+
-+# vim: set et sw=3 sts=3 ts=3 ft=zsh:
-+# ZSH Completion for polkit-action
-+# Written by Saleem Abdulrasool <compnerd@compnerd.org>
-+
-+_polkit_action() {
-+ local arguments
-+
-+ arguments=(
-+ "(-)--action[Show detailed information about a specific action]:action:_polkit actions"
-+ "(-)--reset-defaults[Reset the defaults for the specified action]:Overridden Action:_polkit overriden-actions"
-+ "(-)--show-overrides[List actions where the defaults are overridden]"
-+ "(-)--set-defaults-any[Override the any stanza for an action]:Action:_polkit _actions:Authorization:_polkit authorization"
-+ "(-)--set-defaults-inactive[Override the inactive stanza for an action]:Action:polkit _actions:Authorization:_polkit authorization"
-+ "(-)--set-defaults-active[Override the active stanza for an action]:Action:polkit _actions:Authorization:_polkit authorization"
-+ "(-)--version[Display program version]"
-+ "(-)--help[Display program help]"
-+ )
-+
-+ _arguments $arguments
-+}
-+
-+_polkit_action "$@"
-diff --git a/tools/_polkit_auth b/tools/_polkit_auth
-new file mode 100644
-index 0000000..e70f1a0
---- /dev/null
-+++ tools/_polkit_auth
-@@ -0,0 +1,50 @@
-+#compdef polkit-auth
-+
-+# vim: set et sw=3 sts=3 ts=3 ft=zsh:
-+# ZSH Completion for polkit-auth
-+# Written by Saleem Abdulrasool <compnerd@compnerd.org>
-+
-+_polkit_auth() {
-+ local arguments action_arguments user_arguments grant_arguments
-+ local commands actions grant=0
-+
-+ commands=( --show-obtainable --version --help )
-+ actions=( --obtain --explicit --explicit-detail --grant --revoke )
-+
-+ for (( i = 0 ; i < ${#words[@]} ; i++ )) ; do
-+ if [[ "${words[$i]##--#}" == "grant" ]] ; then
-+ grant=1
-+ break
-+ fi
-+ done
-+
-+ arguments=(
-+ '(-)--show-obtainable[Show all actions that can be obtained via authentication]'
-+ '(-)--version[Show version and exit]'
-+ '(-)--help[Show help information]'
-+ )
-+
-+ action_arguments=(
-+ "($commands $actions)--obtain[Attempt to obtain authorization to do an action]:Obtainable Actions:_polkit obtainable-actions"
-+ "($commands $actions)--explicit[Show explicit authorizations]"
-+ "($commands $actions)--explicit-detail[Show detailed information about explicit authorizations]"
-+ "($commands $actions)--grant[Grant an authorization for an action]:Obtainable Actions:_polkit actions"
-+ "($commands $actions)--revoke[Revoke all authorization for an action]:Authorized Actions:_polkit authorized-actions"
-+ )
-+
-+ user_arguments=(
-+ "($commands)--user[The user the authorization applies to]:User:_users"
-+ )
-+
-+ grant_arguments=(
-+ "($commands)--constraint[Optional constraints on the granted authorization]:Constraint:_polkit constraints"
-+ )
-+
-+ if [[ grant -eq 1 ]] ; then
-+ _arguments $arguments $user_arguments $action_arguments $grant_arguments
-+ else
-+ _arguments $arguments $user_arguments $action_arguments
-+ fi
-+}
-+
-+_polkit_auth "$@"
diff --git a/sys-auth/polkit/polkit-0.94.ebuild b/sys-auth/polkit/polkit-0.94.ebuild
index 2fca33336ba9..804a9c58e254 100644
--- a/sys-auth/polkit/polkit-0.94.ebuild
+++ b/sys-auth/polkit/polkit-0.94.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.94.ebuild,v 1.1 2009/10/29 23:28:01 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.94.ebuild,v 1.2 2009/10/30 17:31:04 nirbheek Exp $
EAPI="2"
@@ -13,15 +13,16 @@ SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc expat pam zsh-completion nls"
-# introspection
+IUSE="debug doc expat nls"
+# building w/o pam is broken, bug 291116
+# introspection pam
# not mature enough
# introspection? ( dev-libs/gobject-introspection )
RDEPEND=">=dev-libs/glib-2.21.4
>=dev-libs/eggdbus-0.5
- expat? ( dev-libs/expat )
- pam? ( virtual/pam )"
+ virtual/pam
+ expat? ( dev-libs/expat )"
DEPEND="${RDEPEND}
!!>=sys-auth/policykit-0.92
dev-libs/libxslt
@@ -37,11 +38,6 @@ pkg_setup() {
}
src_prepare() {
- # Add zsh completions
- if use zsh-completion; then
- epatch "${FILESDIR}/${PN}-0.92-zsh-completions.patch"
- fi
-
# Fix daemon binary collision with <=policykit-0.9, fdo bug 22951
epatch "${FILESDIR}/${PN}-0.93-fix-daemon-name.patch"
@@ -52,14 +48,8 @@ src_prepare() {
src_configure() {
local conf
- if use pam ; then
- conf="--with-authfw=pam --with-pam-module-dir=$(getpam_mod_dir)"
- else
- conf="--with-authfw=none"
- fi
-
if use expat; then
- conf="--with-expat=/usr"
+ conf="${conf} --with-expat=/usr"
fi
econf ${conf} \
@@ -72,6 +62,8 @@ src_configure() {
--with-os-type=gentoo \
--with-polkit-user=polkituser \
--localstatedir=/var \
+ --with-authfw=pam \
+ --with-pam-module-dir=$(getpam_mod_dir) \
$(use_enable debug verbose-mode) \
$(use_enable doc gtk-doc) \
$(use_enable nls)
@@ -83,13 +75,6 @@ src_install() {
dodoc NEWS README AUTHORS ChangeLog || die "dodoc failed"
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- doins "${S}/tools/_polkit" || die "zsh completion died"
- doins "${S}/tools/_polkit_auth" || die "zsh completion died"
- doins "${S}/tools/_polkit_action" || die "zsh completion died"
- fi
-
# Need to keep a few directories around...
diropts -m0700 -o root -g polkituser
keepdir /var/run/polkit-1