summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-10-28 13:41:26 +0000
committerRick Farina <zerochaos@gentoo.org>2013-10-28 13:41:26 +0000
commit53fd41d810cb03d5b39dceddc305b664749a19a8 (patch)
treee508571a7c98a99b9965b2db9e34a3740e6b2136 /sys-auth
parentversion bump, new homepage, new download site, remove unneeded(?) patch (diff)
downloadgentoo-2-53fd41d810cb03d5b39dceddc305b664749a19a8.tar.gz
gentoo-2-53fd41d810cb03d5b39dceddc305b664749a19a8.tar.bz2
gentoo-2-53fd41d810cb03d5b39dceddc305b664749a19a8.zip
version bump, update download location
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ykclient/ChangeLog7
-rw-r--r--sys-auth/ykclient/ykclient-2.12.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-auth/ykclient/ChangeLog b/sys-auth/ykclient/ChangeLog
index 75130f86bd8f..16bcea3af5c3 100644
--- a/sys-auth/ykclient/ChangeLog
+++ b/sys-auth/ykclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/ykclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ChangeLog,v 1.6 2013/04/22 13:55:05 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ChangeLog,v 1.7 2013/10/28 13:41:26 zerochaos Exp $
+
+*ykclient-2.12 (28 Oct 2013)
+
+ 28 Oct 2013; Rick Farina <zerochaos@gentoo.org> +ykclient-2.12.ebuild:
+ version bump, update download location
22 Apr 2013; Rick Farina <zerochaos@gentoo.org> ykclient-2.9.ebuild:
tested on ~x86
diff --git a/sys-auth/ykclient/ykclient-2.12.ebuild b/sys-auth/ykclient/ykclient-2.12.ebuild
new file mode 100644
index 000000000000..c4c0b6c8ec41
--- /dev/null
+++ b/sys-auth/ykclient/ykclient-2.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ykclient-2.12.ebuild,v 1.1 2013/10/28 13:41:26 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Yubico C client library"
+SRC_URI="http://opensource.yubico.com/yubico-c-client/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubico-c-client"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs"
+
+RDEPEND=">=net-misc/curl-7.21.1"
+DEPEND="${RDEPEND}"
+
+# Tests require an active network connection, we don't want to run them
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ prune_libtool_files
+}