summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-07-22 19:49:06 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-07-22 19:49:06 +0000
commit4e9a59d63db5a508430b32175b071d8ecc709d9f (patch)
tree46bb9a94401842b45223b4702e4cec69caf5dcb6 /sys-auth
parentSet SUPPORT_PYTHON_ABIS (bug #316949). (diff)
downloadgentoo-2-4e9a59d63db5a508430b32175b071d8ecc709d9f.tar.gz
gentoo-2-4e9a59d63db5a508430b32175b071d8ecc709d9f.tar.bz2
gentoo-2-4e9a59d63db5a508430b32175b071d8ecc709d9f.zip
Version bump 0.96.1, update SRC_URI for 0.95.1 (they moved tarball elsewhere)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit-qt/ChangeLog9
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild4
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.96.1.ebuild41
3 files changed, 51 insertions, 3 deletions
diff --git a/sys-auth/polkit-qt/ChangeLog b/sys-auth/polkit-qt/ChangeLog
index 375bf4e64d2c..84ac67df20b0 100644
--- a/sys-auth/polkit-qt/ChangeLog
+++ b/sys-auth/polkit-qt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/polkit-qt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/ChangeLog,v 1.7 2010/06/27 08:59:47 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/ChangeLog,v 1.8 2010/07/22 19:49:06 reavertm Exp $
+
+*polkit-qt-0.96.1 (22 Jul 2010)
+
+ 22 Jul 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ polkit-qt-0.95.1.ebuild, +polkit-qt-0.96.1.ebuild:
+ Version bump 0.96.1, update SRC_URI for 0.95.1 (they moved tarball
+ elsewhere)
27 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
polkit-qt-0.95.1.ebuild:
diff --git a/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild b/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild
index c3c252d0cbba..30c41d13a0f2 100644
--- a/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild
+++ b/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild,v 1.7 2010/06/27 08:59:47 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild,v 1.8 2010/07/22 19:49:06 reavertm Exp $
EAPI="2"
@@ -10,7 +10,7 @@ MY_P="${P/qt/qt-1}"
DESCRIPTION="PolicyKit Qt4 API wrapper library."
HOMEPAGE="http://kde.org/"
-SRC_URI="mirror://kde/stable/polkit-qt-1/${MY_P}.tar.bz2"
+SRC_URI="mirror://kde/stable/apps/KDE4.x/admin/${MY_P}.tar.bz2"
LICENSE="LGPL-2"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x86-fbsd"
diff --git a/sys-auth/polkit-qt/polkit-qt-0.96.1.ebuild b/sys-auth/polkit-qt/polkit-qt-0.96.1.ebuild
new file mode 100644
index 000000000000..030e845a33e1
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.96.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/polkit-qt-0.96.1.ebuild,v 1.1 2010/07/22 19:49:06 reavertm Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+MY_P="${P/qt/qt-1}"
+
+DESCRIPTION="PolicyKit Qt4 API wrapper library."
+HOMEPAGE="http://kde.org/"
+SRC_URI="mirror://kde/stable/apps/KDE4.x/admin/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug examples"
+
+COMMON_DEPEND="
+ >=sys-auth/polkit-0.96
+ x11-libs/qt-gui[dbus]
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/automoc
+"
+RDEPEND="${COMMON_DEPEND}
+ examples? ( !sys-auth/policykit-qt[examples] )
+"
+
+DOCS="AUTHORS README README.porting TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ )
+
+ cmake-utils_src_configure
+}