summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-08-19 17:14:31 +0000
committerBrian Evans <grknight@gentoo.org>2014-08-19 17:14:31 +0000
commit4a023b12ee7d519c5730fdedab9c39c91bce8027 (patch)
tree43bffb6ea5f1c45ee4353063cb081ceaa93bdc98 /sys-auth
parentAdjusted PYTHON_COMPAT variable as requested by Arfrever in IRC (diff)
downloadgentoo-2-4a023b12ee7d519c5730fdedab9c39c91bce8027.tar.gz
gentoo-2-4a023b12ee7d519c5730fdedab9c39c91bce8027.tar.bz2
gentoo-2-4a023b12ee7d519c5730fdedab9c39c91bce8027.zip
Fix deprecated autotools macros for bug 468750 and EAPI5 bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mysql/ChangeLog7
-rw-r--r--sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-auth/pam_mysql/ChangeLog b/sys-auth/pam_mysql/ChangeLog
index d59bdf407857..685eac9032f2 100644
--- a/sys-auth/pam_mysql/ChangeLog
+++ b/sys-auth/pam_mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mysql
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.23 2014/05/07 02:21:43 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.24 2014/08/19 17:14:31 grknight Exp $
+
+*pam_mysql-0.7_rc1-r5 (19 Aug 2014)
+
+ 19 Aug 2014; <grknight@gentoo.org> +pam_mysql-0.7_rc1-r5.ebuild:
+ Fix deprecated autotools macros for bug 468750 and EAPI5 bump
07 May 2014; Brian Evans <grknight@gentoo.org> -pam_mysql-0.7_rc1-r1.ebuild,
-pam_mysql-0.7_rc1-r2.ebuild, -pam_mysql-0.7_rc1-r3.ebuild:
diff --git a/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild
new file mode 100644
index 000000000000..5d1c85a400eb
--- /dev/null
+++ b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild,v 1.1 2014/08/19 17:14:31 grknight Exp $
+
+EAPI=5
+inherit autotools-utils pam
+
+DESCRIPTION="pam_mysql is a module for pam to authenticate users with mysql"
+HOMEPAGE="http://pam-mysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/pam-mysql/${P/_rc/RC}.tar.gz"
+DEPEND="
+ openssl? ( dev-libs/openssl:0= )
+ >=sys-libs/pam-0.72:0=
+ virtual/mysql:0=
+ "
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="openssl"
+S="${WORKDIR}/${P/_rc/RC}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-link-to-pam.diff"
+ "${FILESDIR}/${P}-memleak.diff"
+ )
+DOCS=( CREDITS ChangeLog NEWS README )
+AUTOTOOLS_AUTORECONF="yes"
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
+
+src_prepare() {
+ # Update autotools deprecated file name and macro for bug 468750
+ mv configure.in configure.ac || die "configure rename failed"
+ sed -i s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/ configure.ac || die "sed failed"
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with openssl) )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install libdir="$(getpam_mod_dir)"
+}