summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-04-22 13:57:20 +0000
committerRick Farina <zerochaos@gentoo.org>2013-04-22 13:57:20 +0000
commit144571edbc94f0c122b8ca8329bb1e8cb663d8a6 (patch)
treedc90631cda2bf225a720a59427545c6ad84b594a /sys-auth
parenttested on ~x86 (diff)
downloadgentoo-2-144571edbc94f0c122b8ca8329bb1e8cb663d8a6.tar.gz
gentoo-2-144571edbc94f0c122b8ca8329bb1e8cb663d8a6.tar.bz2
gentoo-2-144571edbc94f0c122b8ca8329bb1e8cb663d8a6.zip
initial commit, deps are likely a bit more complex than this
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_yubico/ChangeLog9
-rw-r--r--sys-auth/pam_yubico/files/2.11-drop_privs.patch14
-rw-r--r--sys-auth/pam_yubico/metadata.xml14
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.13.ebuild40
4 files changed, 77 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/ChangeLog b/sys-auth/pam_yubico/ChangeLog
new file mode 100644
index 000000000000..422cc02b5e16
--- /dev/null
+++ b/sys-auth/pam_yubico/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-auth/pam_yubico
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/ChangeLog,v 1.1 2013/04/22 13:57:20 zerochaos Exp $
+
+*pam_yubico-2.13 (22 Apr 2013)
+
+ 22 Apr 2013; Rick Farina <zerochaos@gentoo.org> +files/2.11-drop_privs.patch,
+ +metadata.xml, +pam_yubico-2.13.ebuild:
+ initial commit, deps are likely a bit more complex than this
diff --git a/sys-auth/pam_yubico/files/2.11-drop_privs.patch b/sys-auth/pam_yubico/files/2.11-drop_privs.patch
new file mode 100644
index 000000000000..f4b29bac83b1
--- /dev/null
+++ b/sys-auth/pam_yubico/files/2.11-drop_privs.patch
@@ -0,0 +1,14 @@
+--- drop_privs.c 2012-03-09 12:36:04.792191180 -0500
++++ drop_privs.c.new 2012-03-09 12:36:00.827333242 -0500
+@@ -47,9 +47,9 @@
+ #endif
+
+ #ifdef HAVE_PAM_MODUTIL_DROP_PRIV
+-#ifdef HAVE_SECURITY_PAM_MODUTIL_H
++//#ifdef HAVE_SECURITY_PAM_MODUTIL_H
+ #include <security/pam_modutil.h>
+-#endif /* HAVE_SECURITY_PAM_MODUTIL_H */
++//#endif /* HAVE_SECURITY_PAM_MODUTIL_H */
+ #else
+ static uid_t saved_euid;
+ static gid_t saved_egid;
diff --git a/sys-auth/pam_yubico/metadata.xml b/sys-auth/pam_yubico/metadata.xml
new file mode 100644
index 000000000000..6cbb2f1f5ddf
--- /dev/null
+++ b/sys-auth/pam_yubico/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<maintainer>
+<email>anyone@whowantsto.com</email>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/sys-auth/pam_yubico/pam_yubico-2.13.ebuild b/sys-auth/pam_yubico/pam_yubico-2.13.ebuild
new file mode 100644
index 000000000000..66963deefdbc
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/pam_yubico-2.13.ebuild,v 1.1 2013/04/22 13:57:20 zerochaos Exp $
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://code.google.com/p/yubico-pam/"
+SRC_URI="http://yubico-pam.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND="virtual/pam
+ >=sys-auth/ykclient-2.4
+ >=sys-auth/ykpers-1.6"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/2.11-drop_privs.patch"
+ eautoreconf
+}
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ econf \
+ --with-cr \
+ $(use_with ldap) \
+ --with-pam-dir=/$(get_libdir)/security
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README doc/*
+ prune_libtool_files
+}
+