summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-01-20 04:32:11 +0000
committerMatt Turner <mattst88@gentoo.org>2011-01-20 04:32:11 +0000
commit0d586f412acb764ef728289f4ebb478db1867931 (patch)
treec194462e221c9d50abc9a936fafbfd326de5835e /sys-auth
parentSilence a harmless warning from repoman by renaming a variable. (diff)
downloadgentoo-2-0d586f412acb764ef728289f4ebb478db1867931.tar.gz
gentoo-2-0d586f412acb764ef728289f4ebb478db1867931.tar.bz2
gentoo-2-0d586f412acb764ef728289f4ebb478db1867931.zip
Version bump to 2.8.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-2.8.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 575e7c261f4f..9eadbc4acf6a 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.49 2011/01/20 04:16:21 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.50 2011/01/20 04:32:11 mattst88 Exp $
+
+*pam_mount-2.8 (20 Jan 2011)
+
+ 20 Jan 2011; Matt Turner <mattst88@gentoo.org> +pam_mount-2.8.ebuild:
+ Version bump.
20 Jan 2011; Matt Turner <mattst88@gentoo.org> metadata.xml:
Add myself as a maintainer.
diff --git a/sys-auth/pam_mount/pam_mount-2.8.ebuild b/sys-auth/pam_mount/pam_mount-2.8.ebuild
new file mode 100644
index 000000000000..995b20a4ee91
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.8.ebuild,v 1.1 2011/01/20 04:32:11 mattst88 Exp $
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.8
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ dev-util/pkgconfig
+ app-arch/xz-utils"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.8
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ sys-process/lsof"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}