summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-10-23 18:06:10 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-10-23 18:06:10 +0000
commitaf93836863b604f6b1ff85aa2743dbabf265485e (patch)
tree8c9f48d9472746a49c29a70028b970576473f59b /sys-auth/sssd
parentcleanup. (diff)
downloadgentoo-2-af93836863b604f6b1ff85aa2743dbabf265485e.tar.gz
gentoo-2-af93836863b604f6b1ff85aa2743dbabf265485e.tar.bz2
gentoo-2-af93836863b604f6b1ff85aa2743dbabf265485e.zip
Fix depends in init script, bug 385157
(Portage version: 2.1.10.26/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/sssd')
-rw-r--r--sys-auth/sssd/ChangeLog8
-rw-r--r--sys-auth/sssd/files/sssd21
-rw-r--r--sys-auth/sssd/files/sssd.conf4
-rw-r--r--sys-auth/sssd/sssd-1.6.1-r2.ebuild116
4 files changed, 148 insertions, 1 deletions
diff --git a/sys-auth/sssd/ChangeLog b/sys-auth/sssd/ChangeLog
index 6507b45f4c02..c8b580e74067 100644
--- a/sys-auth/sssd/ChangeLog
+++ b/sys-auth/sssd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/sssd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.8 2011/09/17 09:35:47 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.9 2011/10/23 18:06:10 maksbotan Exp $
+
+*sssd-1.6.1-r2 (23 Oct 2011)
+
+ 23 Oct 2011; Maxim Koltsov <maksbotan@gentoo.org> +sssd-1.6.1-r2.ebuild,
+ +files/sssd, +files/sssd.conf:
+ Fix depends in init script, bug 385157
17 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org> -sssd-1.6.1.ebuild,
sssd-1.6.1-r1.ebuild:
diff --git a/sys-auth/sssd/files/sssd b/sys-auth/sssd/files/sssd
new file mode 100644
index 000000000000..dbf7850227c4
--- /dev/null
+++ b/sys-auth/sssd/files/sssd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+
+command="/usr/sbin/sssd"
+command_args="${SSSD_OPTIONS} -D"
+start_stop_daemon_args="--quiet"
+description="System Security Services Daemon"
+
+depend(){
+ need localmount clock
+ use syslog xdm
+}
+
+if [ "${RC_VERSION:-0}" = "0" ]; then
+ start() {
+ eerror "This script cannot be used for baselayout-1."
+ return 1
+ }
+fi
diff --git a/sys-auth/sssd/files/sssd.conf b/sys-auth/sssd/files/sssd.conf
new file mode 100644
index 000000000000..33dab3ddcd5d
--- /dev/null
+++ b/sys-auth/sssd/files/sssd.conf
@@ -0,0 +1,4 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+SSSD_OPTIONS=""
diff --git a/sys-auth/sssd/sssd-1.6.1-r2.ebuild b/sys-auth/sssd/sssd-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..f6fa555850b7
--- /dev/null
+++ b/sys-auth/sssd/sssd-1.6.1-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.6.1-r2.ebuild,v 1.1 2011/10/23 18:06:10 maksbotan Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit python multilib pam linux-info autotools-utils
+
+DESCRIPTION="System Security Services Daemon provides access to identity and authentication"
+HOMEPAGE="http://fedorahosted.org/sssd/"
+SRC_URI="http://fedorahosted.org/released/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +locator logrotate nls python selinux test"
+
+COMMON_DEP="virtual/pam
+ dev-libs/popt
+ >=dev-libs/libunistring-0.9.3
+ >=dev-libs/ding-libs-0.1.2
+ >=sys-libs/talloc-2.0
+ sys-libs/tdb
+ sys-libs/tevent
+ sys-libs/ldb
+ >=net-nds/openldap-2.4.19
+ dev-libs/libpcre
+ >=app-crypt/mit-krb5-1.9.1
+ >=net-dns/c-ares-1.7.4
+ >=dev-libs/nss-3.12.9
+ selinux? ( >=sys-libs/libselinux-2.0.94 >=sys-libs/libsemanage-2.0.45 )
+ net-dns/bind-tools
+ dev-libs/cyrus-sasl
+ sys-apps/dbus
+ >=sys-devel/gettext-0.17
+ virtual/libintl
+ dev-libs/libnl"
+
+RDEPEND="${COMMON_DEP}"
+DEPEND="${COMMON_DEP}
+ test? ( dev-libs/check )
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.4
+ doc? ( app-doc/doxygen )"
+
+CONFIG_CHECK="~KEYS"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+#PATCHES=("${FILESDIR}"/new_openrc.patch)
+
+pkg_setup(){
+ python_set_active_version 2
+ python_need_rebuild
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ cp -f "${FILESDIR}"/sssd "${S}/"src/sysv/gentoo/sssd
+}
+
+src_configure(){
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --enable-nsslibdir="${EPREFIX}"/$(get_libdir)
+ --with-plugin-path="${EPREFIX}"/usr/$(get_libdir)/sssd
+ --enable-pammoddir="${EPREFIX}"/$(getpam_mod_dir)
+ --with-ldb-lib-dir="${EPREFIX}"/usr/$(get_libdir)/ldb/modules/ldb
+ --with-libnl
+ --without-nscd
+ $(use_with selinux)
+ $(use_with selinux semanage)
+ $(use_with python python-bindings)
+ $(use_enable locator krb5-locator-plugin)
+ $(use_enable nls ) )
+
+ autotools-utils_src_configure
+}
+
+src_install(){
+ autotools-utils_src_install
+ remove_libtool_files all
+
+ insinto /etc/sssd
+ insopts -m600
+ doins "${S}"/src/examples/sssd.conf
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ insopts -m644
+ newins "${S}"/src/examples/logrotate sssd
+ fi
+
+ if use python; then
+ python_clean_installation_image
+ python_convert_shebangs 2 "${ED}$(python_get_sitedir)/"*.py
+ fi
+ newconfd "${FILESDIR}"/sssd.conf sssd
+}
+
+src_test() {
+ autotools-utils_src_test
+}
+
+pkg_postinst(){
+ elog "You must set up sssd.conf (default installed into /etc/sssd)"
+ elog "and (optionally) configuration in /etc/pam.d in order to use SSSD"
+ elog "features. Please see howto in http://fedorahosted.org/sssd/wiki/HOWTO_Configure_1_0_2"
+
+ use python && python_need_rebuild
+ use python && python_mod_optimize SSSDConfig.py ipachangeconf.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup SSSDConfig.py ipachangeconf.py
+}