summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-07-07 21:20:06 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-07-07 21:20:06 +0000
commitef7c776c4ce5daea17cf301d7a246fd276b7a80f (patch)
tree298b02b5682050e964a14461eb195092db566c84 /sys-auth/polkit
parentversion bump; clean old - ebuild submitted by Locke Shinseiko via bug #324869 (diff)
downloadgentoo-2-ef7c776c4ce5daea17cf301d7a246fd276b7a80f.tar.gz
gentoo-2-ef7c776c4ce5daea17cf301d7a246fd276b7a80f.tar.bz2
gentoo-2-ef7c776c4ce5daea17cf301d7a246fd276b7a80f.zip
Add ewarn about ensuring that consolekit sessions are working. Either the user needs to login using a login-manager with consolekit support, or use ck-launch-session to launch the DE as suggested in bug 291116 comment 13
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'sys-auth/polkit')
-rw-r--r--sys-auth/polkit/ChangeLog8
-rw-r--r--sys-auth/polkit/polkit-0.96-r1.ebuild30
-rw-r--r--sys-auth/polkit/polkit-0.96-r2.ebuild30
3 files changed, 65 insertions, 3 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index d5eecb14ec97..87438142de78 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.18 2010/07/02 10:02:24 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.19 2010/07/07 21:20:06 nirbheek Exp $
+
+ 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
+ polkit-0.96-r2.ebuild:
+ Add ewarn about ensuring that consolekit sessions are working. Either the
+ user needs to login using a login-manager with consolekit support, or use
+ ck-launch-session to launch the DE as suggested in bug 291116 comment 13
*polkit-0.96-r2 (02 Jul 2010)
diff --git a/sys-auth/polkit/polkit-0.96-r1.ebuild b/sys-auth/polkit/polkit-0.96-r1.ebuild
index 2336bfce757e..7bd3ebd6158f 100644
--- a/sys-auth/polkit/polkit-0.96-r1.ebuild
+++ b/sys-auth/polkit/polkit-0.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.96-r1.ebuild,v 1.6 2010/06/04 19:50:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.96-r1.ebuild,v 1.7 2010/07/07 21:20:06 nirbheek Exp $
EAPI="2"
@@ -97,3 +97,31 @@ src_install() {
keepdir /var/run/polkit-1
keepdir /var/lib/polkit-1
}
+
+pkg_postinst() {
+ # Make sure that the user has consolekit sessions working so that the
+ # 'allow_active' directive in polkit action policies works
+ if has_version 'gnome-base/gdm' && ! has_version 'gnome-base/gdm[consolekit]'; then
+ # If user has GDM installed, but USE=-consolekit, warn them
+ ewarn "You have GDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using GDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if has_version 'kde-base/kdm' && ! has_version 'kde-base/kdm[consolekit]'; then
+ # If user has KDM installed, but USE=-consolekit, warn them
+ ewarn "You have KDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using KDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if ! has_version 'gnome-base/gdm[consolekit]' && \
+ ! has_version 'kde-base/kdm[consolekit]'; then
+ # Inform user about the alternative method
+ ewarn "If you don't use GDM or KDM for logging in,"
+ ewarn "you must start your desktop environment (DE) as follows:"
+ ewarn " ck-launch-session \$STARTGUI"
+ ewarn "Where \$STARTGUI is a DE-starting command such as 'gnome-session'."
+ ewarn "You should add this to your ~/.xinitrc if you use startx."
+ fi
+}
diff --git a/sys-auth/polkit/polkit-0.96-r2.ebuild b/sys-auth/polkit/polkit-0.96-r2.ebuild
index bed7a4e62702..73fcd2cc7215 100644
--- a/sys-auth/polkit/polkit-0.96-r2.ebuild
+++ b/sys-auth/polkit/polkit-0.96-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.96-r2.ebuild,v 1.1 2010/07/02 10:02:24 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.96-r2.ebuild,v 1.2 2010/07/07 21:20:06 nirbheek Exp $
EAPI="2"
@@ -86,3 +86,31 @@ src_install() {
keepdir /var/run/polkit-1
keepdir /var/lib/polkit-1
}
+
+pkg_postinst() {
+ # Make sure that the user has consolekit sessions working so that the
+ # 'allow_active' directive in polkit action policies works
+ if has_version 'gnome-base/gdm' && ! has_version 'gnome-base/gdm[consolekit]'; then
+ # If user has GDM installed, but USE=-consolekit, warn them
+ ewarn "You have GDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using GDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if has_version 'kde-base/kdm' && ! has_version 'kde-base/kdm[consolekit]'; then
+ # If user has KDM installed, but USE=-consolekit, warn them
+ ewarn "You have KDM installed, but it does not have USE=consolekit"
+ ewarn "If you login using KDM, polkit authorizations will not work"
+ ewarn "unless you enable USE=consolekit"
+ einfo
+ fi
+ if ! has_version 'gnome-base/gdm[consolekit]' && \
+ ! has_version 'kde-base/kdm[consolekit]'; then
+ # Inform user about the alternative method
+ ewarn "If you don't use GDM or KDM for logging in,"
+ ewarn "you must start your desktop environment (DE) as follows:"
+ ewarn " ck-launch-session \$STARTGUI"
+ ewarn "Where \$STARTGUI is a DE-starting command such as 'gnome-session'."
+ ewarn "You should add this to your ~/.xinitrc if you use startx."
+ fi
+}