summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-01 12:09:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-01 12:09:41 +0000
commit832b8f84e04b13a1be7562f9c74340305ca7d932 (patch)
tree018ac34df215877d8010de837a9f4d4382c1a160 /sys-auth/polkit
parentppc64 stable wrt #360721 (diff)
downloadgentoo-2-832b8f84e04b13a1be7562f9c74340305ca7d932.tar.gz
gentoo-2-832b8f84e04b13a1be7562f9c74340305ca7d932.tar.bz2
gentoo-2-832b8f84e04b13a1be7562f9c74340305ca7d932.zip
old
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/polkit')
-rw-r--r--sys-auth/polkit/files/polkit-0.96-getcwd.patch22
-rw-r--r--sys-auth/polkit/polkit-0.101.ebuild94
-rw-r--r--sys-auth/polkit/polkit-0.99-r1.ebuild102
3 files changed, 0 insertions, 218 deletions
diff --git a/sys-auth/polkit/files/polkit-0.96-getcwd.patch b/sys-auth/polkit/files/polkit-0.96-getcwd.patch
deleted file mode 100644
index 64e888a74c5b..000000000000
--- a/sys-auth/polkit/files/polkit-0.96-getcwd.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=309457
-https://bugs.freedesktop.org/show_bug.cgi?id=27081
-
---- src/programs/pkexec.c
-+++ src/programs/pkexec.c
-@@ -375,6 +375,7 @@
- gchar *path;
- struct passwd pwstruct;
- gchar pwbuf[8192];
-+ gchar cwdbuf[PATH_MAX];
- gchar *s;
- const gchar *environment_variables_to_save[] = {
- "SHELL",
-@@ -438,7 +439,7 @@
- goto out;
- }
-
-- original_cwd = g_strdup (get_current_dir_name ());
-+ original_cwd = g_strdup (getcwd(cwdbuf,PATH_MAX));
- if (original_cwd == NULL)
- {
- g_printerr ("Error getting cwd.\n");
diff --git a/sys-auth/polkit/polkit-0.101.ebuild b/sys-auth/polkit/polkit-0.101.ebuild
deleted file mode 100644
index 79531f0ba2fd..000000000000
--- a/sys-auth/polkit/polkit-0.101.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.101.ebuild,v 1.2 2011/03/15 18:02:39 nirbheek Exp $
-
-EAPI=3
-inherit pam
-
-DESCRIPTION="Policy framework for controlling privileges for system-wide services"
-HOMEPAGE="http://hal.freedesktop.org/docs/polkit/"
-SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples gtk +introspection kde nls pam"
-
-RDEPEND=">=dev-libs/glib-2.28
- dev-libs/expat
- introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- !!sys-auth/policykit
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
- dev-util/pkgconfig
- >=dev-util/intltool-0.36
- doc? ( >=dev-util/gtk-doc-1.13 )"
-PDEPEND=">=sys-auth/consolekit-0.4[policykit]
- gtk? ( || ( >=gnome-extra/polkit-gnome-0.101 lxde-base/lxpolkit ) )
- kde? ( || ( sys-auth/polkit-kde-agent sys-auth/polkit-kde ) )"
-
-src_configure() {
- local myauth="--with-authfw=shadow"
- use pam && myauth="--with-authfw=pam --with-pam-module-dir=$(getpam_mod_dir)"
-
- econf \
- --localstatedir="${EPREFIX}"/var \
- --disable-dependency-tracking \
- --disable-static \
- $(use_enable debug verbose-mode) \
- --enable-man-pages \
- $(use_enable doc gtk-doc) \
- $(use_enable introspection) \
- --disable-examples \
- $(use_enable nls) \
- --with-os-type=gentoo \
- ${myauth}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc docs/TODO HACKING NEWS README
-
- find "${D}" -name '*.la' -exec rm -f {} +
-
- # We disable example compilation above, and handle it here
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins src/examples/{*.c,*.policy*}
- fi
-
- # Need to keep a few directories around...
- diropts -m0700 -o root -g root
- keepdir /var/run/polkit-1
- keepdir /var/lib/polkit-1
-}
-
-pkg_postinst() {
- # Make sure that the user has consolekit sessions working so that the
- # 'allow_active' directive in polkit action policies works
- if has_version 'gnome-base/gdm' && ! has_version 'gnome-base/gdm[consolekit]'; then
- # If user has GDM installed, but USE=-consolekit, warn them
- ewarn "You have GDM installed, but it does not have USE=consolekit"
- ewarn "If you login using GDM, polkit authorizations will not work"
- ewarn "unless you enable USE=consolekit"
- einfo
- fi
- if has_version 'kde-base/kdm' && ! has_version 'kde-base/kdm[consolekit]'; then
- # If user has KDM installed, but USE=-consolekit, warn them
- ewarn "You have KDM installed, but it does not have USE=consolekit"
- ewarn "If you login using KDM, polkit authorizations will not work"
- ewarn "unless you enable USE=consolekit"
- einfo
- fi
- if ! has_version 'gnome-base/gdm[consolekit]' && \
- ! has_version 'kde-base/kdm[consolekit]'; then
- # Inform user about the alternative method
- ewarn "If you don't use GDM or KDM for logging in,"
- ewarn "you must start your desktop environment (DE) as follows:"
- ewarn " ck-launch-session \$STARTGUI"
- ewarn "Where \$STARTGUI is a DE-starting command such as 'gnome-session'."
- ewarn "You should add this to your ~/.xinitrc if you use startx."
- fi
-}
diff --git a/sys-auth/polkit/polkit-0.99-r1.ebuild b/sys-auth/polkit/polkit-0.99-r1.ebuild
deleted file mode 100644
index 32437ab90420..000000000000
--- a/sys-auth/polkit/polkit-0.99-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.99-r1.ebuild,v 1.10 2011/03/22 21:12:38 xarthisius Exp $
-
-EAPI=2
-inherit eutils pam
-
-DESCRIPTION="Policy framework for controlling privileges for system-wide services"
-HOMEPAGE="http://hal.freedesktop.org/docs/polkit/"
-SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc examples gtk +introspection kde nls pam"
-
-RDEPEND=">=dev-libs/glib-2.25.12
- dev-libs/expat
- introspection? ( dev-libs/gobject-introspection )
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- !!>=sys-auth/policykit-0.92
- !<sys-auth/policykit-0.92
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
- dev-util/pkgconfig
- >=dev-util/intltool-0.36
- doc? ( >=dev-util/gtk-doc-1.13 )"
-PDEPEND=">=sys-auth/consolekit-0.4[policykit]
- gtk? ( || ( >=gnome-extra/polkit-gnome-0.96-r1 lxde-base/lxpolkit ) )
- kde? ( || ( sys-auth/polkit-kde-agent sys-auth/polkit-kde ) )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.96-getcwd.patch
-}
-
-src_configure() {
- local myauth="--with-authfw=shadow"
- use pam && myauth="--with-authfw=pam --with-pam-module-dir=$(getpam_mod_dir)"
-
- # We define libexecdir due to fdo bug #22951
- # easier to maintain than patching everything
- econf \
- --libexecdir='${exec_prefix}/libexec/polkit-1' \
- --localstatedir=/var \
- --disable-dependency-tracking \
- --disable-static \
- $(use_enable debug verbose-mode) \
- --enable-man-pages \
- $(use_enable doc gtk-doc) \
- $(use_enable introspection) \
- --disable-examples \
- $(use_enable nls) \
- --with-os-type=gentoo \
- ${myauth}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc docs/TODO HACKING NEWS README
-
- find "${D}" -name '*.la' -exec rm -f '{}' +
-
- # We disable example compilation above, and handle it here
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins src/examples/{*.c,*.policy*}
- fi
-
- # Need to keep a few directories around...
- diropts -m0700 -o root -g root
- keepdir /var/run/polkit-1
- keepdir /var/lib/polkit-1
-}
-
-pkg_postinst() {
- # Make sure that the user has consolekit sessions working so that the
- # 'allow_active' directive in polkit action policies works
- if has_version 'gnome-base/gdm' && ! has_version 'gnome-base/gdm[consolekit]'; then
- # If user has GDM installed, but USE=-consolekit, warn them
- ewarn "You have GDM installed, but it does not have USE=consolekit"
- ewarn "If you login using GDM, polkit authorizations will not work"
- ewarn "unless you enable USE=consolekit"
- einfo
- fi
- if has_version 'kde-base/kdm' && ! has_version 'kde-base/kdm[consolekit]'; then
- # If user has KDM installed, but USE=-consolekit, warn them
- ewarn "You have KDM installed, but it does not have USE=consolekit"
- ewarn "If you login using KDM, polkit authorizations will not work"
- ewarn "unless you enable USE=consolekit"
- einfo
- fi
- if ! has_version 'gnome-base/gdm[consolekit]' && \
- ! has_version 'kde-base/kdm[consolekit]'; then
- # Inform user about the alternative method
- ewarn "If you don't use GDM or KDM for logging in,"
- ewarn "you must start your desktop environment (DE) as follows:"
- ewarn " ck-launch-session \$STARTGUI"
- ewarn "Where \$STARTGUI is a DE-starting command such as 'gnome-session'."
- ewarn "You should add this to your ~/.xinitrc if you use startx."
- fi
-}