summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-07 11:27:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-07 11:27:50 +0000
commitc8181c41cefab7a3012a91ff74a69ba5ff912eea (patch)
tree6e87e1c5318ee7250215c522301a73c19f265236 /sys-auth/pam_ssh
parentApply ldap implicit pointer conversion patch again to fix failure on amd64 hosts (diff)
downloadgentoo-2-c8181c41cefab7a3012a91ff74a69ba5ff912eea.tar.gz
gentoo-2-c8181c41cefab7a3012a91ff74a69ba5ff912eea.tar.bz2
gentoo-2-c8181c41cefab7a3012a91ff74a69ba5ff912eea.zip
Hide all non-necessary symbols, fix using this with dovecot (bug #274924).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_ssh')
-rw-r--r--sys-auth/pam_ssh/ChangeLog8
-rw-r--r--sys-auth/pam_ssh/files/pam_symbols.ver4
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild51
3 files changed, 62 insertions, 1 deletions
diff --git a/sys-auth/pam_ssh/ChangeLog b/sys-auth/pam_ssh/ChangeLog
index 0b44bd93e16c..417388ca4d96 100644
--- a/sys-auth/pam_ssh/ChangeLog
+++ b/sys-auth/pam_ssh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pam_ssh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.36 2010/01/17 05:31:51 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.37 2010/08/07 11:27:50 flameeyes Exp $
+
+*pam_ssh-1.97-r2 (07 Aug 2010)
+
+ 07 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pam_ssh-1.97-r2.ebuild, +files/pam_symbols.ver:
+ Hide all non-necessary symbols, fix using this with dovecot (bug #274924).
17 Jan 2010; Jonathan Callen <abcd@gentoo.org> pam_ssh-1.97-r1.ebuild:
Add prefix keywords
diff --git a/sys-auth/pam_ssh/files/pam_symbols.ver b/sys-auth/pam_ssh/files/pam_symbols.ver
new file mode 100644
index 000000000000..dbc677b77a2d
--- /dev/null
+++ b/sys-auth/pam_ssh/files/pam_symbols.ver
@@ -0,0 +1,4 @@
+{
+ global: pam_sm_*;
+ local: *;
+};
diff --git a/sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild b/sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild
new file mode 100644
index 000000000000..2ca8d978fed6
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/pam_ssh-1.97-r2.ebuild,v 1.1 2010/08/07 11:27:50 flameeyes Exp $
+
+EAPI=2
+
+inherit pam autotools
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+# Doesn't work on OpenPAM.
+DEPEND="sys-libs/pam
+ sys-devel/libtool"
+
+RDEPEND="sys-libs/pam
+ virtual/ssh"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-doublefree.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # hide all the otherwise-exported symbols that may clash with
+ # other software loading the PAM modules (see bug #274924 as an
+ # example).
+ append-ldflags -Wl,--version-script="${FILESDIR}"/pam_symbols.ver
+
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)" \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+
+ find "${D}" -name '*.la' -delete || die "Unable to remove libtool archives."
+}
+
+pkg_postinst() {
+ elog "You can enable pam_ssh for system authentication by enabling"
+ elog "the ssh USE flag on sys-auth/pambase."
+}