summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-28 02:10:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-28 02:10:27 +0000
commitbe69ec45cf00501df987d1568d103eecaf772d87 (patch)
treee2a2d1fec0f8fce3cf33c2ef4f8c9c52d595f549 /sys-auth/pam_ssh
parentBug #279286: Min iptables version required for ipset is 1.4.4. Thanks to Jame... (diff)
downloadgentoo-2-be69ec45cf00501df987d1568d103eecaf772d87.tar.gz
gentoo-2-be69ec45cf00501df987d1568d103eecaf772d87.tar.bz2
gentoo-2-be69ec45cf00501df987d1568d103eecaf772d87.zip
Version bump, thanks to Mansour Moufid for noticing the release in bug #263579.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_ssh')
-rw-r--r--sys-auth/pam_ssh/ChangeLog9
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.97.ebuild45
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-auth/pam_ssh/ChangeLog b/sys-auth/pam_ssh/ChangeLog
index da0ae4efd5cd..a093a4b42395 100644
--- a/sys-auth/pam_ssh/ChangeLog
+++ b/sys-auth/pam_ssh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam_ssh
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.26 2009/03/15 16:55:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.27 2009/07/28 02:10:27 flameeyes Exp $
+
+*pam_ssh-1.97 (28 Jul 2009)
+
+ 28 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pam_ssh-1.97.ebuild:
+ Version bump, thanks to Mansour Moufid for noticing the release in bug
+ #263579.
15 Mar 2009; Brent Baude <ranger@gentoo.org> pam_ssh-1.92.ebuild:
Marking pam_ssh-1.92 ppc64 for bug 261595
diff --git a/sys-auth/pam_ssh/pam_ssh-1.97.ebuild b/sys-auth/pam_ssh/pam_ssh-1.97.ebuild
new file mode 100644
index 000000000000..e00070dc115c
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-1.97.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/pam_ssh-1.97.ebuild,v 1.1 2009/07/28 02:10:27 flameeyes Exp $
+
+EAPI=2
+
+inherit pam autotools
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# Doesn't work on OpenPAM.
+DEPEND="sys-libs/pam
+ sys-devel/libtool"
+
+RDEPEND="sys-libs/pam
+ virtual/ssh"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)" \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+
+ find "${D}" -name '*.la' -delete || die "Unable to remove libtool archives."
+}
+
+pkg_postinst() {
+ elog "You can enable pam_ssh for system authentication by enabling"
+ elog "the ssh USE flag on sys-auth/pambase."
+}