summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-11-06 20:27:05 +0000
committerPacho Ramos <pacho@gentoo.org>2013-11-06 20:27:05 +0000
commit631e731181fed3fe2a945281ce57a8e3e1fb264d (patch)
treed5f4d70b554a45759ef3bf6cc712a9e43b97399d /sys-auth/pam_ssh
parentEnsure people get fix for bug #487504 (diff)
downloadgentoo-2-631e731181fed3fe2a945281ce57a8e3e1fb264d.tar.gz
gentoo-2-631e731181fed3fe2a945281ce57a8e3e1fb264d.tar.bz2
gentoo-2-631e731181fed3fe2a945281ce57a8e3e1fb264d.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-auth/pam_ssh')
-rw-r--r--sys-auth/pam_ssh/ChangeLog9
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.98.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/sys-auth/pam_ssh/ChangeLog b/sys-auth/pam_ssh/ChangeLog
index ddff8cbc86f6..3e3998862255 100644
--- a/sys-auth/pam_ssh/ChangeLog
+++ b/sys-auth/pam_ssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_ssh
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.47 2012/11/01 13:50:43 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/ChangeLog,v 1.48 2013/11/06 20:27:05 pacho Exp $
+
+*pam_ssh-1.98 (06 Nov 2013)
+
+ 06 Nov 2013; Pacho Ramos <pacho@gentoo.org> +pam_ssh-1.98.ebuild:
+ Version bump
01 Nov 2012; Ulrich Müller <ulm@gentoo.org> pam_ssh-1.97-r1.ebuild,
pam_ssh-1.97-r2.ebuild, pam_ssh-1.97-r3.ebuild:
diff --git a/sys-auth/pam_ssh/pam_ssh-1.98.ebuild b/sys-auth/pam_ssh/pam_ssh-1.98.ebuild
new file mode 100644
index 000000000000..6f679f25d64a
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-1.98.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/pam_ssh-1.98.ebuild,v 1.1 2013/11/06 20:27:05 pacho Exp $
+
+EAPI=5
+inherit pam eutils flag-o-matic readme.gentoo
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+LICENSE="BSD-2 BSD ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+# Doesn't work on OpenPAM; looks for OpenSSH at build time (bug
+# #282993) and won't work with other implementations either
+RDEPEND="
+ sys-libs/pam
+ net-misc/openssh
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+DOC_CONTENTS="
+ You can enable pam_ssh for system authentication by enabling
+ the pam_ssh USE flag on sys-auth/pambase.
+"
+
+src_configure() {
+ # hide all the otherwise-exported symbols that may clash with
+ # other software loading the PAM modules (see bug #274924 as an
+ # example).
+ append-ldflags -Wl,--version-script="${FILESDIR}"/pam_symbols.ver
+
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)"
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+ readme.gentoo_create_doc
+}