summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-09-08 19:38:59 +0000
committerUlrich Müller <ulm@gentoo.org>2010-09-08 19:38:59 +0000
commit771e76f773986a49646b6b4a63b2cfd9536fd1a5 (patch)
tree614427b6e3177a16d5b41671601fbcdf09298c2a /sys-auth/pam_skey
parentMask sys-auth/pam_skey-1.1.5-r2 for testing. (diff)
downloadgentoo-2-771e76f773986a49646b6b4a63b2cfd9536fd1a5.tar.gz
gentoo-2-771e76f773986a49646b6b4a63b2cfd9536fd1a5.tar.bz2
gentoo-2-771e76f773986a49646b6b4a63b2cfd9536fd1a5.zip
New module option "require_skey" for mandatory authentication, bug 336449.
(Portage version: 2.2_rc71/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_skey')
-rw-r--r--sys-auth/pam_skey/ChangeLog8
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5-r2.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-auth/pam_skey/ChangeLog b/sys-auth/pam_skey/ChangeLog
index 0dcb2e104cd7..9e23039a8cf7 100644
--- a/sys-auth/pam_skey/ChangeLog
+++ b/sys-auth/pam_skey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pam_skey
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.12 2010/05/23 19:58:27 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/ChangeLog,v 1.13 2010/09/08 19:38:59 ulm Exp $
+
+*pam_skey-1.1.5-r2 (08 Sep 2010)
+
+ 08 Sep 2010; Ulrich Mueller <ulm@gentoo.org> +pam_skey-1.1.5-r2.ebuild:
+ New module option "require_skey" that makes S/Key authentication mandatory.
+ Patch contributed by Jan Sembera <fis@bofh.cz> in bug 336449.
23 May 2010; Ulrich Mueller <ulm@gentoo.org> -pam_skey-1.1.5.ebuild:
Remove old.
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5-r2.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5-r2.ebuild
new file mode 100644
index 000000000000..767900eb71f7
--- /dev/null
+++ b/sys-auth/pam_skey/pam_skey-1.1.5-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/pam_skey-1.1.5-r2.ebuild,v 1.1 2010/09/08 19:38:59 ulm Exp $
+
+inherit eutils pam autotools multilib
+
+DESCRIPTION="PAM interface for the S/Key authentication system"
+HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
+SRC_URI="http://dkorunic.net/tarballs/${P}.tar.gz
+ mirror://gentoo/${P}-patches-2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/pam-0.78-r3
+ >=sys-auth/skey-1.1.5-r4"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_SUFFIX=patch epatch
+
+ cd autoconf
+ eautoconf
+ eautoheader
+ mv configure defs.h.in .. || die "mv failed"
+}
+
+src_compile() {
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README INSTALL
+}
+
+pkg_postinst() {
+ elog "To use this, you need to add something like"
+ elog
+ elog "auth [success=done ignore=ignore auth_err=die default=bad] pam_skey.so"
+ elog "auth sufficient pam_unix.so likeauth nullok try_first_pass"
+ elog
+ elog "to an appropriate place in /etc/pam.d/system-auth"
+ elog "Consult the documentation for instructions."
+}