summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-09-13 07:29:13 +0000
committerHanno Böck <hanno@gentoo.org>2011-09-13 07:29:13 +0000
commite08054a81f884334dfa031c7ca340eb0d2837ede (patch)
tree0ae7434f4cdfa34a9f40d342629e752b2c2a8a29 /sys-auth/pam_mysql
parentadded new release, removed old versions (diff)
downloadgentoo-2-e08054a81f884334dfa031c7ca340eb0d2837ede.tar.gz
gentoo-2-e08054a81f884334dfa031c7ca340eb0d2837ede.tar.bz2
gentoo-2-e08054a81f884334dfa031c7ca340eb0d2837ede.zip
patch for pam_mysql to link against pam
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_mysql')
-rw-r--r--sys-auth/pam_mysql/ChangeLog10
-rw-r--r--sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff9
-rw-r--r--sys-auth/pam_mysql/pam_mysql-0.7_rc1-r3.ebuild38
3 files changed, 55 insertions, 2 deletions
diff --git a/sys-auth/pam_mysql/ChangeLog b/sys-auth/pam_mysql/ChangeLog
index fab4a4d127c2..ffed435920ed 100644
--- a/sys-auth/pam_mysql/ChangeLog
+++ b/sys-auth/pam_mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pam_mysql
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.15 2010/03/24 19:45:15 robbat2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.16 2011/09/13 07:29:13 hanno Exp $
+
+*pam_mysql-0.7_rc1-r3 (13 Sep 2011)
+
+ 13 Sep 2011; Hanno Boeck <hanno@gentoo.org> +pam_mysql-0.7_rc1-r3.ebuild,
+ +files/pam_mysql-0.7_rc1-link-to-pam.diff:
+ Patch to link against pam, see http://bugs.debian.org/418500.
*pam_mysql-0.7_rc1-r2 (24 Mar 2010)
diff --git a/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff
new file mode 100644
index 000000000000..0b32b37e9e05
--- /dev/null
+++ b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff
@@ -0,0 +1,9 @@
+--- pam_mysql-0.7RC1/Makefile.am 2005-09-20 07:43:44.000000000 +0200
++++ pam_mysql-0.7RC1-1/Makefile.am 2011-09-13 09:21:53.198200066 +0200
+@@ -3,5 +3,6 @@
+ noinst_FILES=pam_mysql.la pam_mysql.a
+ pam_mysql_la_SOURCES=pam_mysql.c
+ pam_mysql_la_LDFLAGS=-module -avoid-version
++pam_mysql_la_LIBADD=-lpam
+ INCLUDES=@INCLUDES@
+ EXTRA_DIST=COPYING NEWS README CREDITS ChangeLog INSTALL pam_mysql.spec.in install-sh missing mkinstalldirs pkg.m4 pam_mysql.spec
diff --git a/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r3.ebuild b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r3.ebuild
new file mode 100644
index 000000000000..38db114bd6b0
--- /dev/null
+++ b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r3.ebuild,v 1.1 2011/09/13 07:29:13 hanno Exp $
+
+EAPI=2
+inherit autotools libtool pam
+
+DESCRIPTION="pam_mysql is a module for pam to authenticate users with mysql"
+HOMEPAGE="http://pam-mysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/pam-mysql/${P/_rc/RC}.tar.gz"
+DEPEND=">=sys-libs/pam-0.72 virtual/mysql"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="openssl"
+S="${WORKDIR}/${P/_rc/RC}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-link-to-pam.diff"
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_with openssl)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="$(getpam_mod_dir)" install || die "install failed"
+ rm "${D}/$(getpam_mod_dir)/pam_mysql.la" || die "Failed to remove pam_mysql.la"
+ dodoc CREDITS ChangeLog NEWS README
+}