summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-01-29 18:59:55 +0000
committerHanno Böck <hanno@gentoo.org>2009-01-29 18:59:55 +0000
commit805e8a35df73afa8a09f7da830f2873fa3675788 (patch)
tree7366ba979a1e8d6e1723ddb5cbf6bdaf9dfb6d0b /sys-auth/pam_mount
parentAdd fix by Andreas Wiese for NULL ptr deref #256464. (diff)
downloadgentoo-2-805e8a35df73afa8a09f7da830f2873fa3675788.tar.gz
gentoo-2-805e8a35df73afa8a09f7da830f2873fa3675788.tar.bz2
gentoo-2-805e8a35df73afa8a09f7da830f2873fa3675788.zip
pam_mount version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-1.17.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 92a151e47465..16e977ecfe26 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.26 2009/01/26 20:03:07 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.27 2009/01/29 18:59:55 hanno Exp $
+
+*pam_mount-1.17 (29 Jan 2009)
+
+ 29 Jan 2009; Hanno Boeck <hanno@gentoo.org> +pam_mount-1.17.ebuild:
+ Version bump.
*pam_mount-1.16 (26 Jan 2009)
diff --git a/sys-auth/pam_mount/pam_mount-1.17.ebuild b/sys-auth/pam_mount/pam_mount-1.17.ebuild
new file mode 100644
index 000000000000..321e0eebe7dd
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-1.17.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-1.17.ebuild,v 1.1 2009/01/29 18:59:55 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.2
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.2
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}