summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-04-23 13:27:57 +0000
committerHanno Böck <hanno@gentoo.org>2010-04-23 13:27:57 +0000
commit277c66dcde0ccab336986b759212e3667bd493b0 (patch)
tree5a6f14b1ef84c5612833afe0b76fa2f7243cc663 /sys-auth/pam_mount
parentlibhx bump (diff)
downloadgentoo-2-277c66dcde0ccab336986b759212e3667bd493b0.tar.gz
gentoo-2-277c66dcde0ccab336986b759212e3667bd493b0.tar.bz2
gentoo-2-277c66dcde0ccab336986b759212e3667bd493b0.zip
pam_mount bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-2.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 3a43ebedc45f..e5a3f36f558e 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.37 2010/01/10 15:51:34 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.38 2010/04/23 13:27:57 hanno Exp $
+
+*pam_mount-2.0 (23 Apr 2010)
+
+ 23 Apr 2010; Hanno Boeck <hanno@gentoo.org> +pam_mount-2.0.ebuild:
+ Version bump.
*pam_mount-1.33 (10 Jan 2010)
diff --git a/sys-auth/pam_mount/pam_mount-2.0.ebuild b/sys-auth/pam_mount/pam_mount-2.0.ebuild
new file mode 100644
index 000000000000..e4970f85d627
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.0.ebuild,v 1.1 2010/04/23 13:27:57 hanno Exp $
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.4
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.4
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}