summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-26 04:17:17 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-26 04:17:17 +0000
commitb223b7bdc09718124e6385e52ca937f5b9306675 (patch)
tree10d83872726943a78764bcfea51e0e227875e9d7 /sys-auth/pam_bioapi
parentold (diff)
downloadgentoo-2-b223b7bdc09718124e6385e52ca937f5b9306675.tar.gz
gentoo-2-b223b7bdc09718124e6385e52ca937f5b9306675.tar.bz2
gentoo-2-b223b7bdc09718124e6385e52ca937f5b9306675.zip
Cleanup and add alter-env patch.
(Portage version: 2.1.2-r10)
Diffstat (limited to 'sys-auth/pam_bioapi')
-rw-r--r--sys-auth/pam_bioapi/ChangeLog10
-rw-r--r--sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.1-r16
-rw-r--r--sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild39
3 files changed, 53 insertions, 2 deletions
diff --git a/sys-auth/pam_bioapi/ChangeLog b/sys-auth/pam_bioapi/ChangeLog
index cba5d380d074..d9677650a43e 100644
--- a/sys-auth/pam_bioapi/ChangeLog
+++ b/sys-auth/pam_bioapi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pam_bioapi
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/ChangeLog,v 1.1 2006/10/05 13:50:35 wolf31o2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/ChangeLog,v 1.2 2007/02/26 04:17:17 vapier Exp $
+
+*pam_bioapi-0.2.1-r1 (26 Feb 2007)
+
+ 26 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +pam_bioapi-0.2.1-r1.ebuild:
+ Cleanup and add alter-env patch.
*pam_bioapi-0.2.1 (05 Oct 2006)
diff --git a/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.1-r1 b/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.1-r1
new file mode 100644
index 000000000000..7caf5628b667
--- /dev/null
+++ b/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.1-r1
@@ -0,0 +1,6 @@
+MD5 655397c28e725e8a406435585a1f1acb pam_bioapi-0.2.1-alter-environ.patch 859
+RMD160 10271fcbad30590f93c2c483a34005949756b6bf pam_bioapi-0.2.1-alter-environ.patch 859
+SHA256 fc25ee1a761e7068d7b7c1ad2e35c3e859ae554218d8fdaba36e232c84a9258c pam_bioapi-0.2.1-alter-environ.patch 859
+MD5 7101c49d5774e892f0eda401b4c1f634 pam_bioapi-0.2.1.tar.bz2 190025
+RMD160 8629841e99da13607c3e3f124bb2612af3b166b6 pam_bioapi-0.2.1.tar.bz2 190025
+SHA256 36b73c41fe455a5eb7c2b5f1de5d2fa147865c8b0e69e7c9cc8c164936ae72c6 pam_bioapi-0.2.1.tar.bz2 190025
diff --git a/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild b/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..2b024bbbb788
--- /dev/null
+++ b/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild,v 1.1 2007/02/26 04:17:17 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="PAM interface for biometric auth"
+HOMEPAGE="http://www.qrivy.net/~michael/blua/"
+SRC_URI="http://www.qrivy.net/~michael/blua/pam_bioapi/${P}.tar.bz2
+ http://upir.cz/linux/patches/${P}-alter-environ.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-auth/bioapi
+ sys-libs/pam
+ sys-auth/tfm-fingerprint"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/pam_bioapi.c-${PV}.patch
+ epatch "${DISTDIR}"/${P}-alter-environ.patch
+}
+
+src_compile() {
+ export CPPFLAGS="${CPPFLAGS} -I/opt/bioapi/include"
+ econf --prefix=/ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "einstall failed"
+ find "${D}" -name '*.la' -print0 | xargs -0 rm
+ dodir /usr
+ mv "${D}"/bin "${D}"/usr/bin || die
+}